Kanał - ATNEL tech-forum
Wszystkie działy
Najnowsze wątki



Teraz jest 9 kwi 2020, o 10:50


Strefa czasowa: UTC + 1





Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 6 ] 
Autor Wiadomość
PostNapisane: 22 mar 2020, o 01:20 
Offline
Nowy

Dołączył(a): 06 wrz 2015
Posty: 2
Pomógł: 0

Jestem nowym użytkownikiem pełnej wersji mkAVR i i USBASP 4.2 i niestety od początku sa z nim same problemy.

Od razu po uruchomieniu programu pojawia sie taki oto komunikat
Obrazek

Program dalej sie niby uruchamia, ale po pierwszej próbie wgrania prostego programu do FLASH-a program się zawiesił po wykonaniu zapisu i weryfikacji. Pasek postępu zatrzymał się na 100% , "kółko" sie kręciło, można było przełączać zakładki programu, ale nic poza tym. Na programatorze świeciła się czerwona dioda i powoli mrugała niebieska.Program nie dał się zamknąć, udało się to dopiero poprzez managera zadań.

Oczywiście program do ATTINY się nie wgrał :evil:

Po ponownym uruchomieniu mkAVR nie da sie odczytać rodzaju procesora. Po kliknięciu "Sprawdż podłączony AVR"
Obrazek

pojawia się komunikat
Obrazek

a następnie mamy taki efekt
Obrazek

Odczyt trwa w nieskończoność. Zamknięcie i ponowne otwieranie programu nic nie zmienia.

Szczerze jestem zawiedziony tymi problemami. W darmowej wersji programu i za pomocą chińskiego USB wgrywałem bez problemu wsad do ATMEGI8 i nigdy nie miałem takich problemów. Kupiłem pełna wersję żeby mieć dostęp do innych procesorów i żeby być pewny działania tej wersji zakupiłem USBASP. Spędziłem dzisiaj cały dzień nad tym kompletem i same porażki. I jeszcze jedno na czym sie zawiodłem to W ARDUINO IDE programator nie jest widziany i nie ma szans na bezpośrednie wrzucenie softu, a w informacji jest że współpracuje z arduino.

Proszę o rozwiązanie moich problemów, może coś robię nie tak, ale sterowniki wgrałem tak jak pokazuje instrukcja i to jest chyba jedyna rzecz którą udało się zrobić bez problemów.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 22 mar 2020, o 03:23 
Offline
Użytkownik

Dołączył(a): 14 sie 2016
Posty: 782
Pomógł: 34

Stawiam na antywira, wyłącz go na chwilę i zobacz jaki będzie efekt.
Jeżeli nie pomoże to sprawdź co trzyma plik "tmp.tmp" np za pomoca "Process Explorera" - https://docs.microsoft.com/en-us/sysint ... s-explorer

_________________
Moje porady są błędne,nie czytać,zbanować od razu.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 22 mar 2020, o 06:05 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 25328
Lokalizacja: Szczecin
Pomógł: 958

darek_op napisał(a):
Od razu po uruchomieniu programu pojawia sie taki oto komunikat

A w jakim folderze masz wgrany program ? to pierwsze ważne pytanie

Druga sprawa jak masz podłączony procesor ?

Trzecie - jaki masz windows bo jeśli windows XP to rzeczywiście można się spodziewać wielu problemów szczególnie gdy instalka była robiona dawno temu albo gdy jest mało zasobów pamięci bo jest odpalonych mnóstwo programów w tle.

Czy sprawdzałeś to na innym kompie ?

Warto czasem podać więcej informacji ....

I na koniec - oczywiście że programator współpracuje z andruino - tylko że w andruinowym avrdude coś skopali i pokazywałem w jednym z poradników jak sobie z tym radzić


"GDY NIE DZIAŁA CI USBASP pod kocim andruino"

https://mirekk36.blogspot.com/2020/03/g ... ruino.html


i nie jest to żaden problem z atnelowskim usbasp tylko mnóstwo ludzi ma problem z różnymi usbasp pod tym całym mega kocim andruino .... Ja tam się nie znam i nie używam tego całego kociego andruino ale aż mnie coś ściska gdy andruinowcy (przepraszam) marudzą że im usbasp nie działa pod andruino - zamiast sobie wpisać w gogla i zobaczyć że to znany problem dla każdego andruinowca i że już dawno o tym napisali

tu masz cały wątek:

https://forum.arduino.cc/index.php?topic=415210.0

gdzie właśnie to opisują - oczywiście rozwiązanie na końcu z tym avrdude 6.3 poprawionym dla andruino czyli to samo co masz na moim blogu w jednym miejscu

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 22 mar 2020, o 08:17 
Offline
Użytkownik

Dołączył(a): 25 lip 2013
Posty: 2078
Pomógł: 98

Albo masz coś pomieszane z systemem albo antywirus Ci blokuję soft. Najprościej postaw sobie czysty system na wirtualnej maszynie i pójdzie od kopa. Co do Arduino to jest to znany problem z nowymi wersjami Avrdude - dotyczącymi różnych USB ASP - Mirek zrobił na ten temat bodaj filmik czy opis na forum jak to rozwiązać.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 22 mar 2020, o 10:11 
Offline
Nowy

Dołączył(a): 06 wrz 2015
Posty: 2
Pomógł: 0

A w jakim folderze masz wgrany program ? to pierwsze ważne pytanie w folderze na pulpicie

Druga sprawa jak masz podłączony procesor ? płytka z podstawkami do procesorów, uniemożliwiająca pomyłkę i zapewniająca prawidłowy styk

Trzecie - jaki masz windows bo jeśli windows XP to rzeczywiście można się spodziewać wielu problemów szczególnie gdy instalka była robiona dawno temu albo gdy jest mało zasobów pamięci bo jest odpalonych mnóstwo programów w tle. Win 7

Czy sprawdzałeś to na innym kompie ? nie

Warto czasem podać więcej informacji ....
antywirus wyłączony i w dalszym ciągu mam komunikat o błedzie przy otwieraniu programu

I na koniec - oczywiście że programator współpracuje z andruino - tylko że w andruinowym avrdude coś skopali i pokazywałem w jednym z poradników jak sobie z tym radzić




"GDY NIE DZIAŁA CI USBASP pod kocim andruino"

https://mirekk36.blogspot.com/2020/03/g ... ruino.html

postępowałem zgodnie z zamieszczonymi informacjami, podmieniłem pliki na właściwe. Jedyna różnica to brak folderu \arduino-1.8.12\........ u mnie jest folder Arduino\........... Niestety nic to nie zmieniło

Obrazek


Dzisiaj przy próbie odczytu zapisanego wczoraj wsadu. programator odczytał właściwie typ procesora i rozpoczął odczyt
Obrazek

Niestety do dojściu do 100% zawiesił się.
Obrazek

Na USBASP świeci czerwona dioda i niebieska mruga, programu nie da sie zamknąć.

EDIT:

Po resecie komputera i próbie odczytu procesora, pojawił się komunikat

Obrazek

Ręce mi opadają :(

------------------------ [ Dodano po: 37 minutach ]

Nie mogę ponownie edytować poprzedniego postu :shock:

Zmniejszyłem SCK i teraz

Obrazek



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 22 mar 2020, o 15:13 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 25328
Lokalizacja: Szczecin
Pomógł: 958

darek_op napisał(a):
w folderze na pulpicie

No i tak to jest ... eeeeh ... weź Pan zapomnij o umieszczaniu rzeczy programistycznych na pulpicie jeśli nie wiesz co to oznacza - a oznacza to mega długą ścieżkę na pewno ze spacjami, a jeszcze na dodatek często z polskimi znakami

więc prosto i krótko - wgraj że cały ten program bezpośrednio na C do krótkiego folderu

c:\MkAvrCalculator

- a na pulpit sobie zrób skrót do MkAvrCalculator

------------------------ [ Dodano po: 7 minutach ]

darek_op napisał(a):
płytka z podstawkami do procesorów, uniemożliwiająca pomyłkę i zapewniająca prawidłowy styk

A nie przyszło ci do głowy sprawdzić czy działa na zwykłym samym procku nawet podpiętym na pająka bezpośrednio do linii programatora albo w stykówce tylko od razu załamujesz ręce - nie widząc przyczyny być może w tej (sorki bez urazy kompletnie bezsensownej płytce) ? bo te płytki z podstawkami są do wywalenia na śmieci ... a dodatkowo często mają wlutowany głupawy kondensator 100nF pomiędzy linią RESET a GND - więc jeśli taki masz to od razu weź kombinerki i wytnij go w diabły - bo z nim zapomnij o poprawnym działaniu ATB USBasp. Tylko proszę nie pisz mi tu, że aaaa bo chiński usbasp mi działał ... to wybierz sobie wolisz kaszaniastego chińczyka który może przy byle okazji się sfajczyć i nie jest multinapięciowy czy porządny buforowany ATB USBasp który może działać z prockami które zasilać możesz dowolnie od +1,8V !!! aż do +5,5V bez żadnego tam przełączania czegoś. Noty Atmela mówią nawet żeby tego kondka nie dawać a jak już to albo go rozłączać zworką na czas programowania albo można go dać szeregowo z rezystorem 1k i 10K do VCC podciągającym do VCC. Ale już na takiej płytce - to jest MEGA KOMPLETNY NONSENS dawanie takiego kondensatora a wiem że tak bywa na tych durnych płytkach i początkujący je kupują nie wiedząc w co się pakują. Ale to nie jedyna wada tych kocich płytek - bo kto to słyszał żeby mając programator ISP bawić się przekładanie procków - to już kompletna masakra. To tak tytułem wyjaśnienia do takich płytek.

Zresztą zobacz sobie TEN poradnik od tego momentu

https://youtu.be/CX9r0GwkFU0?t=341

------------------------ [ Dodano po: 10 minutach ]

darek_op napisał(a):
Zmniejszyłem SCK i teraz

i bardzo dobrze - na pewno masz ten durny kondensator 100nF na tej płytce

Poza tym zamiast załamywać ręce - rzuć tą płytkę do kosza na śmieci i weź że płytkę stykową i podłącz do niej procka i programator albo nawet na 4-5 kabelkach sam procek - w czym problem - sam byś zobaczył że WSZYSTKO ŚMIGA bez żadnego ale - jak można tego nie sprawdzić i tak się załamywać ???

------------------------ [ Dodano po: 11 minutach ]

darek_op napisał(a):
postępowałem zgodnie z zamieszczonymi informacjami, podmieniłem pliki na właściwe. Jedyna różnica to brak folderu \arduino-1.8.12\........ u mnie jest folder Arduino\........... Niestety nic to nie zmieniło


bo i tu pewnie coś źle robisz - zamiast tego - czy trudno pobrać tą najnowszą wersję arduino-1.8.12 i zrobić to co pokazałem - sorki ale teraz to mi ręce opadają

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 6 ] 

Strefa czasowa: UTC + 1


Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 0 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
Sitemap
Technologię dostarcza phpBB® Forum Software © phpBB Group phpBB3.PL
phpBB SEO