Kanał - ATNEL tech-forum
Wszystkie działy
Najnowsze wątki



Teraz jest 31 mar 2020, o 03:39


Strefa czasowa: UTC + 1





Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 18 ] 
Autor Wiadomość
PostNapisane: 9 sie 2019, o 18:05 
Offline
Nowy

Dołączył(a): 13 lip 2019
Posty: 23
Pomógł: 0

Witam. Mam problem niewiadomego pochodzenia tz. skonstruowałem układ taki jak na poniższym rysunku i działa on z zasilania od atb-usbasp. Niestety, kiedy chciałem go podłączyć z 12V (NA RYS VCC) przez dzielnik napięcia osobno dla zasilania i sygnału w dziwny sposób na pinie '3' pojawiało się napięcie. Układ działa tak, że po podaniu napięcia na syg. zapala się taśma LED, a po jego odłączeniu odliczany jest czas 10 sek. i dioda jest wyłączana. Proszę o pomoc w zdiagnozowaniu nieprawidłowości.

Obrazek

Tranzystor BD244C

Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.


Attiny13A taktowanie 128 kHz



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 9 sie 2019, o 19:08 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 23 paź 2014
Posty: 870
Lokalizacja: Trójmiasto
Pomógł: 164

Jak masz podłączony ten tranzystor? Emiter jest również podłączony do Vcc a pasek ledów do kolektora i do masy? Jeśli tak to nie dziw się że tranzystor się otwiera bo przecież złącze BE polaryzuje sie przy napięciu ~0,6V, a skoro emiter jest na 12V a baza podłączona jest do procka który wystawia 1 logiczną i jest zasilany 4V to poziom tej jedynki to również około 4V. To jakie jest napięcie BE tranzystora? 12 - 4 = 8 czyli tranzystor jest otwarty (oczywiście nadmiar napięcia się odłoży na rezystorze ograniczającym ale nie zmienia to faktu że w takim układzie tranzystor się nie zatka).
Pominę już fakt samego pomysłu by obniżać napiecie zasilania poprzez dzielnik bo to totalne nieporazumienie, jeszcze jakby tam po drodze był tranzystor wzmacniający to jeszcze mozna by przymknąć oko, ale tak to napięcie tam pływa niemiłosiernie i samo to może powodować problemy.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 9 sie 2019, o 19:25 
Offline
Nowy

Dołączył(a): 13 lip 2019
Posty: 23
Pomógł: 0

xentis napisał(a):
Jak masz podłączony ten tranzystor? Emiter jest również podłączony do Vcc a pasek ledów do kolektora i do masy? Jeśli tak to nie dziw się że tranzystor się otwiera bo przecież złącze BE polaryzuje sie przy napięciu ~0,6V, a skoro emiter jest na 12V a baza podłączona jest do procka który wystawia 1 logiczną i jest zasilany 4V to poziom tej jedynki to również około 4V. To jakie jest napięcie BE tranzystora? 12 - 4 = 8 czyli tranzystor jest otwarty (oczywiście nadmiar napięcia się odłoży na rezystorze ograniczającym ale nie zmienia to faktu że w takim układzie tranzystor się nie zatka).
Pominę już fakt samego pomysłu by obniżać napiecie zasilania poprzez dzielnik bo to totalne nieporazumienie, jeszcze jakby tam po drodze był tranzystor wzmacniający to jeszcze mozna by przymknąć oko, ale tak to napięcie tam pływa niemiłosiernie i samo to może powodować problemy.



W takim razie w jaki sposób podłączyć taśmę



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 9 sie 2019, o 19:28 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 23 paź 2014
Posty: 870
Lokalizacja: Trójmiasto
Pomógł: 164

Sam procesor zasil chociaż przez zwykły stabilizator napięcia 7805, a do sterowania taśmą zastosuj tranzystor NPN, i wtedy steruj podając 1 na zaświecenie, a 0 na wygaszenie.


Autor postu otrzymał pochwałę


Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 9 sie 2019, o 21:11 
Offline
Użytkownik

Dołączył(a): 05 sty 2015
Posty: 278
Lokalizacja: Mielec
Pomógł: 12

A nie masz stabilizatora?

Ledy przez tranzystor dajesz na zasilacz 12V z masa od tegoż zasilacza?

I z 12 lepiej dac stabilizator do uC.

Lepiej dac mosfeta TTL niz zwykly tranzystor.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 10 sie 2019, o 10:05 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 22 paź 2013
Posty: 1730
Lokalizacja: Lipsko
Pomógł: 117

mateusz186 napisał(a):
Mam problem niewiadomego pochodzenia

Mateusz (zakładam, że tak masz na imię) problem jest jak najbardziej WIADOMEGO POCHODZENIA - brak podstaw elektroniki. To co musisz wiedzieć tak na szybko co dotyczy takiego układu: jak działają tranzystory (nie bój się mosfetów), prawidłowe zasilanie procesorów, wydajność prądowa źródła zasilania.

_________________
http://www.sylwekkuna.com



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 10 sie 2019, o 17:12 
Offline
Nowy

Dołączył(a): 13 lip 2019
Posty: 23
Pomógł: 0

Dalem na zasilanie stabilizator, mikrokontroler zaczął się grzać razem ze stabilizatorem i się zawiesił.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 10 sie 2019, o 18:07 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 23 paź 2014
Posty: 870
Lokalizacja: Trójmiasto
Pomógł: 164

Masz jakiś miernik? Ten stabilizator na 5V? Sprawny? Dobrze podłączony?
Piszesz zdawkowe informacje, na podstawie których ciężko coś podpowiedzieć/pomóc.
Zrób zdjęcie jak masz to podłączone (ale tak by dobrze było widać gdzie co i z czym jest połączone), wrzuć tutaj, podaj symbole użytych elementów, zmierz, jak masz miernik, jakie napięcie wychodzi ze stabilizatora i wchodzi na procek. Wtedy można będzie coś powiedzieć.
Na chwilę obecną to można jedynie powróżyć...



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 14 sie 2019, o 17:55 
Offline
Nowy

Dołączył(a): 13 lip 2019
Posty: 23
Pomógł: 0

Chyba zlokalizowałem problem. Najprawdopodobniej jest to problem sterowania VCC a nie GND. Tylko nwm jak mogę go zniwelować. Muszę sterować niestety VCC. Jak w najprostszy sposób to zrobić aby nie pojawiało mi sie samoistnie na wejściu jakieś napięcie? Odnośnie powyżej opisanego grzania się AVR było to zwarcie.



Ostatnio edytowano 14 sie 2019, o 17:58 przez mateusz186, łącznie edytowano 1 raz

Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 14 sie 2019, o 17:57 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 22 paź 2013
Posty: 1730
Lokalizacja: Lipsko
Pomógł: 117

Jaki stabilizator? Schemat i foto zmontowanego układu mile widziane

_________________
http://www.sylwekkuna.com



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 14 sie 2019, o 18:06 
Offline
Nowy

Dołączył(a): 13 lip 2019
Posty: 23
Pomógł: 0

stabilizator 7805

Obrazek

tranzystor jest na 100% dobrze podłączony



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 14 sie 2019, o 18:49 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 22 paź 2013
Posty: 1730
Lokalizacja: Lipsko
Pomógł: 117

Chyba się nie rozumiemy. Prosząc o schemat i foto chciałem zobaczyć coś ty tam namieszał, ale widzę, że świetnie sobie sam dasz radę.
Pozdrawiam

_________________
http://www.sylwekkuna.com



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 14 sie 2019, o 19:00 
Offline
Nowy

Dołączył(a): 13 lip 2019
Posty: 23
Pomógł: 0

Za chwile dam zdjęcie ukłądu tylko go uporządkuje ponieważ na jednej płytce mam wiele układów.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 14 sie 2019, o 19:57 
Offline
Nowy

Dołączył(a): 13 lip 2019
Posty: 23
Pomógł: 0

Obrazek
Obrazek
Obrazek

Od lewej stablilzator, po prawej tranzystor



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 14 sie 2019, o 20:15 
Offline
Użytkownik

Dołączył(a): 05 sty 2015
Posty: 278
Lokalizacja: Mielec
Pomógł: 12

A ten układ działa?

Rezystor od gate mosfeta bym dał miedzy pin 3 a gate, jesli możesz to zmień na inny pin, tan po poprzednich próbach może być uwalony,
Zrób test diodą led na blink z tego pinu 3 uC

Masy są wszystkie wspólne?

Jak zasilasz uC bo widzę że na pin 5 idze out z 7805

A w pin 6 rezystor do masy.

Foto i połączenia niezgodne wpełni ze schematem.

Zamiast rezystora na pinie 8 daj kondensator 100nf.

.



Ostatnio edytowano 14 sie 2019, o 20:26 przez Szofer, łącznie edytowano 1 raz

Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 14 sie 2019, o 20:26 
Offline
Nowy

Dołączył(a): 13 lip 2019
Posty: 23
Pomógł: 0

rozumiem że chodzi ci o kondensator filtrujący odnośnie tego zasilania ze 7805



Ostatnio edytowano 14 sie 2019, o 20:33 przez mateusz186, łącznie edytowano 1 raz

Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 14 sie 2019, o 20:29 
Offline
Użytkownik

Dołączył(a): 05 sty 2015
Posty: 278
Lokalizacja: Mielec
Pomógł: 12

mateusz186 napisał(a):
masa jest wspólna. chodzi ci żebym dał rezystor pomiędzy bramkę a źródło?
Nie.

Bramke mosfets a pin 3 attiny



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 14 sie 2019, o 21:02 
Offline
Nowy

Dołączył(a): 13 lip 2019
Posty: 23
Pomógł: 0

a z tym kodem na początku tematu nie ma jakiegoś błędu?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 18 ] 

Strefa czasowa: UTC + 1


Kto przegląda forum

Użytkownicy przeglądający ten dział: Majestic-12 [Bot], MSN [Bot] i 5 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
Sitemap
Technologię dostarcza phpBB® Forum Software © phpBB Group phpBB3.PL
phpBB SEO