Kanał - ATNEL tech-forum
Wszystkie działy
Najnowsze wątki



Teraz jest 21 maja 2019, o 00:39


Strefa czasowa: UTC + 1





Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 9 ] 
Autor Wiadomość
PostNapisane: 24 gru 2018, o 14:17 
Offline
Nowy
Avatar użytkownika

Dołączył(a): 05 gru 2014
Posty: 6
Pomógł: 0

Witam. Chciałbym przerzucić się programowaniem Arduino na Eclipse. Mam z tym problem po ściągnięciu eclipse i zainstalowaniu dodatku arduino mam problem z kompilacją kodu. Podczas kompilacji eclipse nie może znaleźć zainkludowanych bibliotek. Wyskakuj mi komunikat "Anresolved inclusion"
Problem w tym, że nie widzi on nawet Arduino.h. Czy ktoś się z tym już spotkał? Ma ktoś pomysł co z tym zrobić?
Dodam, że programuje na płytce Arduino Due.
Poniżej screen eclipse:
Obrazek



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 24 gru 2018, o 14:58 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 13 paź 2011
Posty: 583
Lokalizacja: Zielona Góra
Pomógł: 64

A skonfigurowałeś środowisko? -tu masz video które powinno Ci pomóc - https://www.youtube.com/watch?v=TtPvkPpAx0E
Możesz też przetestować to środowisko Sloeber, wydaje się bardzie przyjazne w użytkowaniu.

_________________
.:Drive:.

pozdrawiam
phill2k



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 24 gru 2018, o 16:27 
Offline
Nowy
Avatar użytkownika

Dołączył(a): 05 gru 2014
Posty: 6
Pomógł: 0

Niestety nie pomaga. Ktoś inny pomysł?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 25 gru 2018, o 08:24 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 28 maja 2012
Posty: 458
Lokalizacja: ZGY/ZS
Pomógł: 30

Od siebie mogę polecić visual code z pluginem platformIO.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 25 gru 2018, o 23:20 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 13 paź 2011
Posty: 583
Lokalizacja: Zielona Góra
Pomógł: 64

fourfeeter napisał(a):
Niestety nie pomaga. Ktoś inny pomysł?

Ściągnąłem świeżutkiego Eclipse'a (wersja Eclipse IDE for C/C++ Developers), rozpakowałem, nie ściągałem żadnego plugina do Arduino bo już taki jest natywnie wbudowany, stworzyłem nowy projekt, skompilowałem bez problemu pusty szkielet. Pytanie, masz zainstalowane środowisko Arduino gdzieś na dysku i potrzebne narzędzia dla DUE?

_________________
.:Drive:.

pozdrawiam
phill2k



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 28 gru 2018, o 21:58 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 07 lut 2013
Posty: 600
Pomógł: 47

Tak jak pisał kolega phill2k masz gotowego skonfigurowanego eclipsa z Sloeber,
ściągnij rozpakuj i możesz działać.
Osobiście używam już od dłuższego czasu.

_________________
https://www.instagram.com/myfirstquadcopter/



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 30 gru 2018, o 23:30 
Offline
Nowy
Avatar użytkownika

Dołączył(a): 05 gru 2014
Posty: 6
Pomógł: 0

Vphill2k co masz na myśli jeżeli chodzi o
Cytuj:
potrzebne narzędzia dla DUE
?
Co do konfiguracji to;
Zainstalowałem płytkę DUE. Ale kompliator sypie też błędami przy innych płytach. Wygląda to tak jakby kompilator nie mógł znaleźć bibliotek. Kompilator krzyczy, że nie może zaimportować biblioteki Arduino.h.
W standardowym środowisku Arduino radzę sobie z DUE.
Kombinowałem z kilkoma wersjami Eclipse i efekt podobny. Czy może ktoś wie czy eclipse zapisuje gdzieś swoją konfigurację? Tak, żeby po kolejnym ściągnięciu eclipse miała standardowe ustawienia.
Ktoś praktykuje na Arduino DUE? Bo jest to procesor 32 bity i nie wszystkie biblioteki działają co na 8 bitowych Arduino. Miałem tak z timerami między innymi.
Druga sprawa czy może Eclipse i środowisko korzysta z bibliotek z tych samych miejsc? Czy te oba środowiska mają na siebie jakiś wpływ?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 31 gru 2018, o 00:49 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 08 wrz 2015
Posty: 254
Lokalizacja: Zamość
Pomógł: 5

fourfeeter napisał(a):
Kombinowałem z kilkoma wersjami Eclipse i efekt podobny. Czy może ktoś wie czy eclipse zapisuje gdzieś swoją konfigurację? Tak, żeby po kolejnym ściągnięciu eclipse miała standardowe ustawienia.

Wchodzisz w dokumenty i tam jest folder ".eclipse", kasując go od nowa trzeba wszystko ustawiać



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 31 gru 2018, o 12:57 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 31 mar 2015
Posty: 233
Pomógł: 15

Mam prośbę do Pawła, by zrobił poradnik jak przystosować ECLIPSE(nowe) do współpracy z ARDUINO. Mam z tym problem - jak powiązać Arduino IDE z ECLIPSE. Nowe projekty w eclipse - OK.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 9 ] 

Strefa czasowa: UTC + 1


Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 0 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
Sitemap
Technologię dostarcza phpBB® Forum Software © phpBB Group phpBB3.PL
phpBB SEO