Kanał - ATNEL tech-forum
Wszystkie działy
Najnowsze wątki



Teraz jest 1 mar 2024, o 11:12


Strefa czasowa: UTC + 1





Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 16 ] 
Autor Wiadomość
PostNapisane: 6 sty 2023, o 20:10 
Offline
Użytkownik

Dołączył(a): 23 lis 2016
Posty: 32
Pomógł: 0

Witam, potrzebuję pomocy w znalezieniu przyczyny, dlaczego timer2 w atmedze328p nie chce mi działać w trybie asynchronicznym. Mianowicie mam sobie pewien program, który początkowo był pisany na atmegę168p niestety program się rozrósł i atmega168p została podmieniona na 328p. W programie tym używam Timera2 w trybie asynchronicznym, na którym to mam napisaną obsługę zegara. Na Atmedze168p wszystko działało, zegar sobie elegancko chodził. Natomiast po przesiadce na 328p zaczął się problem, bo procesor nie chce wystartować, dopóki nie dotknę palcem jednej z nóg kwarcu. Jeśli już dotknę i proc wystartuje, to generalnie wszystko działa, poza zegarem. Ten stoi na amen. Przy kwarcu nie mam kondensatorów, ale i bez nich do tej pory wszystko działało. Poniżej konfiguracja Timer2 i obsługa jego przerwania. Czy tu leży problem? A może z tą atmegą jest coś nie tak? Proszę o pomoc.
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.


Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 6 sty 2023, o 20:34 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 27198
Lokalizacja: Szczecin
Pomógł: 1041

ja tylko tak na szybko podpowiem, że atmega168p to dokładnie to samo IDENTICO co atmega328p więc nie może ci tu działać a na m328p nie - a jeśli nie działa to szukaj przede wszystkim winy w sprzęcie i połączeniach - od tego bym zaczął.

poza tym po co piszesz takiego dziwoląga jak

Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.


przecież wystarczy samo

Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 6 sty 2023, o 20:58 
Offline
Użytkownik

Dołączył(a): 23 lis 2016
Posty: 32
Pomógł: 0

mirekk36 liczyłem, że się odezwiesz :) sei(); już poprawione. Natomiast co do 328p to wiem, że to dokładnie to samo co 168p i dlatego zgłupiałem po tym jak wymieniłem procka i przestało działać. Dosłownie nic poza przełożeniem procesora nie ruszałem. Ale jeszcze raz posprawdzam połączenia. Dziwne jest to zachowanie, że bez dotknięcia kwarcu procesor po resecie "wisi" i nie uruchomi się dopóki nie pomogę mu dotykając kwarc. Już drugi kwarc podstawiłem i jest to samo. Jeśli z kolei wyłączę (ASSR |= (1<<AS2);) to procesor po resecie rusza bezproblemowo.

Mała aktualizacja. Atmegę 168p mam w obudowie DIL. Atmegę328p mam w adapterze TQFP na DIL. Teraz przelutowałem zamiast 328p - atmegę 168p też w wersji tqfp i co ciekawe, program na niej też nie startuje. Wszelkie przejścia na adapterze posprawdzane miernikiem. Cuda normalnie.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 7 sty 2023, o 09:06 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 27198
Lokalizacja: Szczecin
Pomógł: 1041

Bo tak mi się wydawało, że jeśli to nie działa ci na m328p to i podobnie musiało się zachowywać na m168p ... masz może jakieś pajęczyny przewodów itp ... robisz to na płytce stykowej ? A jeśli na własnym PCB to pokaż tą płytkę PCB

------------------------ [ Dodano po: 2 minutach ]

Poza tym (teraz nie pamiętam szczegółów) ... ale sprawdź czy mają być te kondesatory do kwarca czy nie - bo może bez nich właśnie generator w procku nie chce startować poprawnie z tym kwarcem.

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 7 sty 2023, o 09:43 
Offline
Użytkownik

Dołączył(a): 25 lip 2013
Posty: 2561
Pomógł: 126

A pinout tqfp i dip jest identyczny?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 7 sty 2023, o 10:23 
Offline
Użytkownik

Dołączył(a): 13 lut 2012
Posty: 163
Pomógł: 10

Może się przyda:
AN2648 Selecting and Testing 32 KHz Crystal Oscillators for AVR® Microcontrollers:
http://atmel-studio-doc.s3-website-us-e ... B77BF860F4

Jak przejrzałem to ciekawostką jest, że moduł oscylatora w tych atmegach jest na 1.8-3.6V. Jak nic innego nie pomoże to może spróbować obniżyć napięcie?

Dodane po chwili:
Mirek ma rację.
Wyjaśnienie jest tutaj:
As a capacitive load will have a significant effect on the oscillator, you must not probe the crystal directly unless
you have high-quality equipment intended for crystal measurements. Standard 10X oscilloscope probes impose a
loading of 10-15 pF and will thus have a high impact on the measurements. Touching the pins of a crystal with a
finger or a 10X probe can be sufficient to start or stop oscillations or give false results...



Ostatnio edytowano 7 sty 2023, o 10:42 przez JarekK, łącznie edytowano 1 raz

Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 7 sty 2023, o 10:34 
Offline
Użytkownik

Dołączył(a): 23 lis 2016
Posty: 32
Pomógł: 0

micky pinout wersji dil i tqfp jest inny, ale nie tu leży problem. Wszystko sprawdzane dwa razy, wszystko działa oprócz kwarcu. Poza tym przelutowałem tą 328p na 168p w tqfp a one mają już wyprowadzenia identyczne. Generalnie wersje DIL tych procesorów działają poprawnie z tym kwarcem. Problem jest w momencie przejścia na analogiczne procesory w TQFP.

mirekk36 - Robię to na stykówce. I mam świadomość, że przewody i sama stykówka mogą zakłócać. Ale starałem się w okolicy kwarcu nie prowadzić żadnych przewodów, a sam kwarc przylutowałem do nóg procesora, aby pominąć stykówkę. Doszukałem się w erracie do a328p, że niektóre rewizje miały problemy z kwarcami 32768. Natomiast to nie wyjaśnia dlaczego nie działa też na 168p (TQFP). Wydaje mi się, że te kondensatory to może być dobry trop. Niestety nie mam takich małych pojemności, bo zawsze kwarce przy prockach działały mi bez nich.. Może uda mi się dzisiaj zakupić kondensatory, to dam znać czy to coś pomogło.

PS. dzięki za zainteresowanie moim problemem. Pozdrawiam

------------------------ [ Dodano po: 8 minutach ]

JarekK napisał(a):
Może się przyda:
AN2648 Selecting and Testing 32 KHz Crystal Oscillators for AVR® Microcontrollers:
http://atmel-studio-doc.s3-website-us-e ... B77BF860F4

Jak przejrzałem to ciekawostką jest, że moduł oscylatora w tych atmegach jest na 1.8-3.6V. Jak nic innego nie pomoże to może spróbować obniżyć napięcie?


Dziękuję, tak na pierwszy rzut oka bardzo ciekawa lektura. Zaraz się z nią zapoznam.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 7 sty 2023, o 15:18 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 27198
Lokalizacja: Szczecin
Pomógł: 1041

diquan napisał(a):
Wydaje mi się, że te kondensatory to może być dobry trop.


Przeczytaj lepiej to co wyżej podał ci kolega (jest tu nawet napisane o tym co ty robisz czyli o dotykaniu kwarca):
JarekK napisał(a):
As a capacitive load will have a significant effect on the oscillator, you must not probe the crystal directly unless
you have high-quality equipment intended for crystal measurements. Standard 10X oscilloscope probes impose a
loading of 10-15 pF and will thus have a high impact on the measurements. Touching the pins of a crystal with a
finger or a 10X probe can be sufficient to start or stop oscillations or give false results...


I zrozum, że tu bez kondensatorów nie ruszysz.

diquan napisał(a):
Niestety nie mam takich małych pojemności, bo zawsze kwarce przy prockach działały mi bez nich..

Każdy ale to KAŻDY początkujący, który twierdzi, że "a mi działa" w końcu ma w życiu chociaż jedną sytuację że NIE DZIAŁA, i dopiero wtedy zaczyna rozumieć, po co są informacje w notach PDF. Nie mówię tego żeby tu ironizować czy ciebie pouczać - no ale jak przeczytałem to twoje zdanie, że nie masz takich kondków bo ci zawsze działa bez nich - no to niestety aż troszkę ręce rozłożyłem ze zdumienia. No tak nie można panie kochany - ale co zrobić uczymy się całe życie ... i wyciągniesz z tego mam nadzieję na przyszłość wnioski odpowiednie.

Pamiętaj jak się bawisz prockami do których podłączasz kwarce - to nie możesz nie mieć w swoich zasobach, kondensatorów ceramicznych np 18pF albo 22pF albo 15pF albo każdego z nich po trochu ... Przejrzyj sobie w necie jakiekolwiek schematy różnych generatorów na zwykłych bramkach logicznych to może cię to natchnie - tam ZAWSZE trzeba użyć takich kondków - żeby generatorki zaczęły w ogóle swoją pracę.

Ja np bardzo często w swoich różnych poradnikach wspominam , że owszem - na stykówce na szybko można zwykle uruchamiać procka z kwarcem zewnętrznym i zwykle zadziała on bez kondensatorów. Ale nie wyobrażam sobie oddać gotowego urządzenia do produkcji bez dodania takich kondensatorów, nie wyobrażam też sobie nie mieć ich pod ręką - gdyby właśnie generator nie chciałby mi się wzbudzić - bo po prostu to jest PIERWSZA myśl i wybór - co sprawdzić.

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 7 sty 2023, o 16:59 
Offline
Użytkownik

Dołączył(a): 23 lis 2016
Posty: 32
Pomógł: 0

Mirku dawno temu na pewnym forum na "e" twierdziłeś co innego odnośnie kondensatorów przy kwarcu. Ale nie istotne. Ja rozumiem, że każdy się uczy całe życie. Do tej pory nie były potrzebne w moich aplikacjach, bo kwarce ruszały z kopyta, pomimo to zawsze projektując płytkę zostawiam pod nie miejsce. To, że nie mam kondensatorów to nie znaczy, że w ogóle ich nie używam. Po prostu mi się skończyły. Natomiast już się zaopatrzyłem w pojemności od 8,2pF do 33pF i teraz najlepsze. Dalej nie działa! Ale rozwiązanie znalazłem. Tak mi się wydaje.

Jako, że skończyły mi się pomysły, co do jasnej ... jest nie tak, to wpadłem na pomysł, że mam inny skończony projekt na atmedze328p w TQFP, która również korzysta z kwarcu zegarkowego bez kondensatorów. To urządzenie działa nieprzerwanie już od dłuższego czasu. Więc wymyśliłem sobie, że podmienię procesor, zaprogramuję tym wsadem który był w urządzeniu, ustawie fuse bity i zobaczymy. Przecież musi działać. Programowanie i wszystko poszło ok. Jakie było moje zdziwienie, kiedy okazało się, że procek bez dotknięcia palcem kwarcu nie rusza. Szok. No więc stwierdziłem, że to musi być wina procesora. Ale jeszcze większy szok przeżyłem, jak wlutowałem stary procesor (ten z którym nic nie robiłem poza wylutem i na którym wszystko działało). Po wlutowaniu - UWAGA! Nie działa. Trzeba dotknąć palcem kwarc, wtedy procek rusza. Nie pomaga dodawanie kondensatorów itp. Poza tym do tej pory urządzenie działało bez nich. Więc nie pozostało mi nic innego jak wlutowanie nowego kwarcu. I Bingo! Urządzenie działa.
Drugim testem jaki wykonałem, to okroiłem swój program tak aby zmieścił się do megi8 w TQFP, którą gdzieś tam dawno temu nabyłem, pozmieniałem odpowiednio rejestry i co. Wszystko działa.
Także moim zdaniem trafiłem na jakieś felerne atmegi (podróbki?), które nie wiem w jaki sposób, ale uszkadzają kwarce. Co najlepsze, to gdyby nie wykorzystanie właśnie kwarcu, to procesor normalnie działa.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 7 sty 2023, o 17:26 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 27198
Lokalizacja: Szczecin
Pomógł: 1041

diquan napisał(a):
Mirku dawno temu na pewnym forum na "e" twierdziłeś co innego odnośnie kondensatorów przy kwarcu.

Twierdziłem że działa - do wszelkich testów - ale nigdy do wersji produkcyjnej i ciekawe że akurat słuchasz i czytasz to co chcesz usłyszeć a nie to co trzeba, niestety.

diquan napisał(a):
Także moim zdaniem trafiłem na jakieś felerne atmegi (podróbki?),

Podróbki - tak z tym można się zgodzić bo pełno jest tego na rynku - zależy gdzie kupowałeś procki - bo jeśli na aliexpress to masz pewniaki podróbki, w Polsce to najlepiej kupować u sprawdzonych sprzedawców jak np www.tme.pl a nie tam gdzieś na allegro

diquan napisał(a):
które nie wiem w jaki sposób, ale uszkadzają kwarce

ale to - to już wniosek z kosmosu ;) prędzej zdarzają się niestety wadliwe kwarce - i to nie tylko zegarkowe, a nie że żarłoczny procek je psuje ;) no bez przesady ;)

Najważniejsze że ruszyło a kwarce panie kochany i tak dokładaj - ale przypadkiem nie większe niż 22 pF

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 7 sty 2023, o 17:44 
Offline
Użytkownik

Dołączył(a): 13 lut 2012
Posty: 163
Pomógł: 10

Też mi się zdarzało uszkodzić kwarca, nie wiem może przy lutowaniu.
Poza podróbkami atmeg, jeszcze pozostał trop modułu oscylatora.
W atmegach 168P/328P jest X32K_1v8_ULP na napięcie 1.8V do 3.6V.
W atmedze 8 jest X32K_2v7 na napięcie 2.7-5.5V.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 7 sty 2023, o 18:30 
Offline
Użytkownik

Dołączył(a): 23 lis 2016
Posty: 32
Pomógł: 0

Mirku nie obrażaj się czy nie unoś, bo nie to jest moim celem, Ty twierdziłeś że do wszelkich testów działa i że nie zawracasz sobie nimi głowy czasami w gotowych projektach. To było dawno temu. Ja wtedy się z Tobą zgadzałem w tym stwierdzeniu i zgadzam się nadal. Mi również do wszelkich testów ale i w gotowych urządzeniach wszystko działało bez użycia kondensatorów, chociaż mam z tyłu głowy, że czasami może być potrzeba ich zastosowania, dlatego też zawsze zostawiam na nie miejsce na płytce docelowej. Szanuję Cię za Twoją wiedzę i sposób w jaki ją potrafisz sprzedać. Także bez obrazy. I nie czytam tylko tego co chce przeczytać. Co do uszkadzania kwarcu przez procek - dla mnie też to jest kosmos i gdybym sam tego nie doświadczył to twierdził bym podobnie jak Ty, że głupoty ktoś gada. Ale jak mi wytłumaczysz fakt, że kwarc, który działał i którego nie ruszałem - do wymiany procka działał. Wymieniłem procek nie działa, wstawiłem procek na którym wszystko działało i co - nie działa, a kwarc ten sam. Podmieniam kwarc - działa. Mało tego, to operacje tą powtórzyłem jeszcze raz, żeby mieć pewność. I co kolejny kwarc uszkodzony. No to 3 próba nowy kwarc (działa) wylut działającego procka i po ostygnięciu ponowne jego wlutowanie, aby wykluczyć wpływ lutowania na kwarc, który mimo wszystko jest blisko nóg procesora. Wszystko działa, więc to nie to. Podejrzewam, że gdybym miał "dobre" avrki, to pewnie by działały od kopa bez cudowania z kondensatorami. TME mam pod nosem ;) niestety kiedy ostatnio u nich byłem, nie mieli interesujących mnie procków. W ogóle ostatnimi czasy jest problem z procesorami czy to avr czy stm. Więc zamówiłem na allegro - ostatni raz.
JarekK - zgodnie z Twoim wcześniejszym postem, zalutowalem świeży procesor, nowy kwarc i wszystko uruchomiłem na 3,3V. To było zanim jeszcze robiłem próby z podmianami procków w urządzeniu. Niestety efekt był ten sam. Także twierdze, że trafiłem na podróbki i to ich wina.
To taka przestroga dla innych, aby uważać co się kupuje. Pozdrawiam



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 7 sty 2023, o 19:12 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 27198
Lokalizacja: Szczecin
Pomógł: 1041

diquan napisał(a):
Mirku nie obrażaj się czy nie unoś, bo nie to jest moim celem, Ty twierdziłeś że do wszelkich testów działa i że nie zawracasz sobie nimi głowy czasami w gotowych projektach. To było dawno temu. Ja wtedy się z Tobą zgadzałem w tym stwierdzeniu i zgadzam się nadal. Mi również do wszelkich testów ale i w gotowych urządzeniach wszystko działało bez użycia kondensatorów, chociaż mam z tyłu głowy, że czasami może być potrzeba ich zastosowania, dlatego też zawsze zostawiam na nie miejsce na płytce docelowej. Szanuję Cię za Twoją wiedzę i sposób w jaki ją potrafisz sprzedać. Także bez obrazy.

Ale uwierz mi, że ja się nie obrażam i ty też się nie obrażaj ... ja tylko zawsze i jasno daję do zrozumienia - że docelowo zawsze powinno się po inżyniersku robić zgodnie z zaleceniami producenta i bronię tego zdania i stwierdzenia i zawsze będę bronił ... zrozum to jak ktoś mi tu pisze na forum, że działa BEZ czegoś tam na zasadzie "bo mi tak działało" to zawsze będę to piętnował bo forum czytają setki osób a ja nie chcę żeby początkujące osoby wynosiły stąd taką poszarpaną wiedzę - rozumiesz mój punkt widzenia? To o to chodzi ...

Co do tego że trafiłeś na podróbkę to tak jak pisałem zgadzam się i sam po wielokroć pisałem o podróbkach i o tym, że nie warto kupować wszystkiego co chińskie bo kosztuje 2 dulary (to nie do ciebie) tylko takie ogólne stwierdzenie - bo ludziska w dzisiejszych czasach ogólnie tak mówiąc - zachłystują się chińskim a przez to też później nie ma scalaków w normalnej sprzedaży jak obecnie niestety...

I masz też rację, że szalenie ciężko teraz kupić procki jakiekolwiek - sam to wiem doskonale bo z tego powodu chociażby nie możemy obecnie produkować naszych słynnych zestawów ATB i innych modułów. Wolę nie produkować niż właśnie szukać gdzieś na gwałt części i trafiać na chińskie badziewie - bo później klienci nie wybaczą, że moduły działają w kratkę albo w ogóle nie działają

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 7 sty 2023, o 19:49 
Offline
Użytkownik

Dołączył(a): 23 lis 2016
Posty: 32
Pomógł: 0

mirekk36 napisał(a):
Ale uwierz mi, że ja się nie obrażam i ty też się nie obrażaj ... ja tylko zawsze i jasno daję do zrozumienia - że docelowo zawsze powinno się po inżyniersku robić zgodnie z zaleceniami producenta i bronię tego zdania i stwierdzenia i zawsze będę bronił ... zrozum to jak ktoś mi tu pisze na forum, że działa BEZ czegoś tam na zasadzie "bo mi tak działało" to zawsze będę to piętnował bo forum czytają setki osób a ja nie chcę żeby początkujące osoby wynosiły stąd taką poszarpaną wiedzę - rozumiesz mój punkt widzenia? To o to chodzi ...

Rozumiem i nie mam do Ciebie o to pretensji.

Cytuj:
Wolę nie produkować niż właśnie szukać gdzieś na gwałt części i trafiać na chińskie badziewie


Miejmy nadzieję, że szybko wrócą czasy, gdzie kupienie avr'ka nie było tak problematyczne jak teraz.

Gdzieś w swoich zasobach powinienem jeszcze mieć starą poczciwą atmegę32, zakupioną zanim nastały czasy wszechobecnych podróbek, więc lekko skoryguję program i użyję tego procka. Na szczęście jeszcze jestem na etapie prototypownia więc nie wiele "pary" muszę poświęcić na zmianę procka. Pozdro



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 7 sty 2023, o 22:52 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 27198
Lokalizacja: Szczecin
Pomógł: 1041

to daj znać z ciekawości jak pójdzie później na oryginalnym m32 - zawsze to jakieś nowe doświadczenia

Powodzenia życzę ;)

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 8 sty 2023, o 00:44 
Offline
Użytkownik

Dołączył(a): 23 lis 2016
Posty: 32
Pomógł: 0

mirekk36 napisał(a):
to daj znać z ciekawości jak pójdzie później na oryginalnym m32 - zawsze to jakieś nowe doświadczenia


Tak więc, atmega32 na pająku poskładana, program częściowo zmodyfikowany - tzn poprawione rejestry timerów, kwarc podłączony, w przerwanie wrzucona zmiana stanu portu do którego podpiąłem leda. I wszystko działa jak należy. Dioda sobie miga z częstotliwością 1sek. Wystartowało z kopyta bez cudowania. Z ciekawości jeszcze podłączyłem na próbę kwarce które były dobre, a po spotkaniu z atmegą168p i 328p z allegro przestały takie być. I na tych kwarcach również Atmega32 nie chciała działać dopóki nie dotknęło się ręką kwarcu. Także zagadkę uważam za rozwiązaną. Człowiek całe życie się uczy a i tak umrze głupi ...

Pozdrawiam i dzięki za zainteresowanie.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 16 ] 

Strefa czasowa: UTC + 1


Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 2 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
cron
Sitemap
Technologię dostarcza phpBB® Forum Software © phpBB Group phpBB3.PL
phpBB SEO