Kanał - ATNEL tech-forum
Wszystkie działy
Najnowsze wątki



Teraz jest 1 paź 2020, o 05:20


Strefa czasowa: UTC + 1





Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 6 ] 
Autor Wiadomość
PostNapisane: 11 wrz 2020, o 22:14 
Offline
Użytkownik

Dołączył(a): 01 sty 2013
Posty: 162
Pomógł: 0

Hej Potrzebuję napisać krótki program na attiny 44
Utworzyłem nowy projekt w Workspace
i napisałem taki program:


Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.



Po kompilacji mam błędy jakby kompilator nie znał definicji rejestrów i przerwań :
Obrazek
../main.c:32:6: warning: 'TIMER0_COMPA_vect' appears to be a misspelled signal handler, missing __vector prefix [-Wmisspelled-isr]

Zauważyłem, że kompilator po naciśnięciu ctr + nazwa przrewania (ISR( TIMER0_COMP_vect ) ) lub spacja przekierowuje mnie do pliku iom16.h
Nie jestem pewny czy to dobry plik jest zalinkowany ponieważ w jego zasobach faktycznie nie są zdefiniowane
wszystkie rejestry.
Dodam jeszcze, że przekopiowałem jeszcze raz całego Eclipsa wg NAJNOWSZEGO poradnika Mirka, ścieżki mam dobrze ustawione do Atmel Toolchain
kompilacja na inne procesory przebiega bezproblemowo
Ktoś mógłby podpowiedzieć co się mogło stać?

Oczywiście patrzyłem do noty i nazwy wszystkich rejestrów jakich użyłem, w ATtiny 44 istnieją.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 11 wrz 2020, o 23:31 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 29 sty 2015
Posty: 77
Pomógł: 3

Skąd taka nazwa wektora? Czy nie powinno być czasem TIM0_COMPA_vect lub TIM0_COMPB_vect dla ATTiny44.
To może być problem z podlinkowaniem nieodpowiedniego pliku nagłówkowego.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 12 wrz 2020, o 05:44 
Offline
Użytkownik

Dołączył(a): 01 sty 2013
Posty: 162
Pomógł: 0

No właśnie tak podejrzewam, jednak nie wiem dla czego eclipse nie chce mi zalinkować właściwych plików nagłówkowych.
We właściwościach projektu mam ustawione target hardware attiny44, jednak w pliku io.h mam aktywne tylko
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.


wszystko inne jest wyszarzone.

Nie wiem gdzie jeszcze i co zmienić, żeby eclipse rozpoznało mi właściwy procesor.


W makefile też wszystko wygląda ok :
-mmcu=attiny44



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 12 wrz 2020, o 08:00 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 25879
Lokalizacja: Szczecin
Pomógł: 979

Jarosław J napisał(a):
We właściwościach projektu mam ustawione target hardware attiny44, jednak w pliku io.h mam aktywne tylko

i dlatego masz te problemy...

stwórz nowy projekt a najlepiej nowy workspace na chwilę, jak będziesz tworzył nowy projekt to nie zmieniaj domyślnego procka ATmega16 podczas tworzenia projektu ! Tak jak zawsze mówię w poradnikach - żeby na tym etapie nie wybierać jeszcze docelowego procka.

Gdy projekt już stworzysz - to stwórz main.c i napisz pusty szkielet programu, skompiluj żeby tylko poszło

i DOPIERO teraz - we właściwościach projektu zmień procka na ATtiny44 ... zrób clean projektu i skompiluj

wszystko powinno już być dobrze


Autor postu otrzymał pochwałę

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 12 wrz 2020, o 08:09 
Offline
Użytkownik

Dołączył(a): 01 sty 2013
Posty: 162
Pomógł: 0

Dziękuję Mirku. Zadziałało.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 12 wrz 2020, o 08:39 
Offline
Użytkownik

Dołączył(a): 25 lip 2013
Posty: 2251
Pomógł: 106

W przypadku problemów zawsze możesz spróbować skompilować kod w MkClipse. Wtedy będziesz mógł określić gdzie leży problem (kod czy środowisko)



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 6 ] 

Strefa czasowa: UTC + 1


Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 1 gość


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
Sitemap
Technologię dostarcza phpBB® Forum Software © phpBB Group phpBB3.PL
phpBB SEO