Kanał - ATNEL tech-forum
Wszystkie działy
Najnowsze wątki



Teraz jest 26 sty 2022, o 23:36


Strefa czasowa: UTC + 1





Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 8 ] 
Autor Wiadomość
PostNapisane: 8 cze 2020, o 17:40 
Offline
Nowy

Dołączył(a): 28 lis 2017
Posty: 20
Pomógł: 0

Pomocy! Już straciłem nadzieję i nie mam bladego pojęcia co robić. Buduję tracker do solara który ma działać godzinowo. Na "stykówce" wszystko śmiga. Na moich wypocinach nie chce.. Co ciekawe po podłączeniu do złącza KANDA mkAVR Calculator wykrywa uC, da się zaprogramować. Po wpięciu wyświetlacza nie działa nic. Jak podepnę lcd po kablach żeby sprawdzić jak to będzie działać przy podłączonym programatorze podczas programowania wyświetlacz mignie kilka razy i nic więcej się nie dzieje (podświetlenie). Sprawdziłem wszystkie połączenia zwarcia itd i wszystko wskazuje na to że jest w porządku. Zrobiłem testowy programik do migania wyświetlaczem i tez nie działa. tak jakby po wpięciu wyświetlacza wszystko siadało... Już nie mam pomysłów. uC to Atmega 328P. Coś ewidentnie go zawiesza, ale dziwną rzeczą jest to że się normalnie programuje

Tu program docelowy:

Składnia: [ Pobierz ] [ Ukryj ]
język basic4gl
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.


Tu testowy
Składnia: [ Pobierz ] [ Ukryj ]
język basic4gl
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.


ObrazekObrazekObrazek



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 8 cze 2020, o 18:29 
Offline
Użytkownik

Dołączył(a): 14 sie 2016
Posty: 905
Pomógł: 39

Nie zrozum mnie źle, ale zacząłbym od nauki lutowania - luty masz przegrzane do granic możliwości, widać również lutowanie bez topnika(samą cyną)
To że niema zwarć, nie znaczy że będzie działać prawidłowo.
Przy tak niskich napięciach/prądach występujących w układzie, połączenia muszą być zrobione prawidłowo.
Takie coś może przejdzie na napięciu sieciowym, ale tutaj zapomnij.

_________________
Moje porady są błędne,nie czytać,zbanować od razu.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 8 cze 2020, o 18:44 
Offline
Nowy

Dołączył(a): 28 lis 2017
Posty: 20
Pomógł: 0

Harry napisał(a):
Nie zrozum mnie źle, ale zacząłbym od nauki lutowania - luty masz przegrzane do granic możliwości, widać również lutowanie bez topnika(samą cyną)
To że niema zwarć, nie znaczy że będzie działać prawidłowo.
Przy tak niskich napięciach/prądach występujących w układzie, połączenia muszą być zrobione prawidłowo.
Takie coś może przejdzie na napięciu sieciowym, ale tutaj zapomnij.


A to bardzo możliwe, być może w tym tkwi problem, myślałem że skoro przejścia są, zwarć nie ma to będzie grać. Trza się nauczyć xD



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 8 cze 2020, o 21:09 
Offline
Użytkownik

Dołączył(a): 02 gru 2015
Posty: 512
Pomógł: 25

Nie obraź się ale zajrzyj https://atnel.pl/instrukcja-atb-rev-1-04.html zobacz jak zrobić prawidłowe zasilanie procesora jak podłączyć wyświetlacz (chodzi o podświetlenie ) zobacz też okolice kwarcu .

Poczytaj na blogu Mirekk36 artykuł o drganiach styków i jak prawidłowo podciągać przyciski.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 9 cze 2020, o 11:42 
Offline
Użytkownik

Dołączył(a): 05 gru 2017
Posty: 401
Lokalizacja: Puck
Pomógł: 7

Witaj Sev3n

Nie chcę dolewać oliwy do ognia ale nad schematem również popracuj
bo masz zwarte VCC z GND i ten schemat niema prawa działać
rzuciło mi się to w oczy głębiej nie wnikałem



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 9 cze 2020, o 14:46 
Offline
Użytkownik

Dołączył(a): 14 sie 2016
Posty: 905
Pomógł: 39

Nie wspominając o rozłożeniu ścieżek do pinów LCD - nałożone na siebie.

_________________
Moje porady są błędne,nie czytać,zbanować od razu.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 12 cze 2020, o 14:51 
Offline
Nowy

Dołączył(a): 28 lis 2017
Posty: 20
Pomógł: 0

To znaczy? Już wszystko jasne, nauczyć się lutować i ogarnąć zalislanie, ale o co chodzi z tym że ścieżki nałożone?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 12 cze 2020, o 15:12 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 11 sie 2015
Posty: 205
Lokalizacja: UK
Pomógł: 10

Sev3n napisał(a):
o co chodzi z tym że ścieżki nałożone?


Zakładam, że chodzi o nałożone na siebie połączenia na schemacie (nie ma niby kropek, które by je łączyły - niemniej, gdyby tak było to układ by nie działał).
No i tak jak wyżej koledzy pisali, przy pinach zasilania LCD zrobione jest zwarcie (na schemacie).

_________________
MMT Technologies



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 8 ] 

Strefa czasowa: UTC + 1


Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 1 gość


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
Sitemap
Technologię dostarcza phpBB® Forum Software © phpBB Group phpBB3.PL
phpBB SEO