Kanał - ATNEL tech-forum
Wszystkie działy
Najnowsze wątki



Teraz jest 27 paź 2020, o 07:10


Strefa czasowa: UTC + 1





Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 8 ] 
Autor Wiadomość
PostNapisane: 14 lut 2020, o 21:35 
Offline
Nowy

Dołączył(a): 26 lis 2019
Posty: 6
Pomógł: 0

Witam wszystkich serdecznie. To mój pierwszy post na forum.

Do tej pory ze wszystkim walczyłem sam z reguły ze skutkiem, który mnie zadowalał. Niestety trafiłem na problem, z którym przegrywam walkę. Dodam, że mam książki Mirka niebieską i zieloną, ale nie znalazłem odpowiedzi na mój problem, chyba że odpowiedzią będą unie....ale po kolei:
Stworzyłem typ strukturalny jak poniżej:
typedef struct {
uint8_t godz_wl;
uint8_t min_wl;
uint8_t godz_wyl;
uint8_t min_wyl;
uint8_t pwm_max;
uint8_t pwm_min;
uint8_t wschod;
uint8_t zachod;
long czas_pracy;
uint8_t stan;
uint32_t licznik_min;
uint32_t licznik_max;
}parametry_kanalu;

do tego zmienna - tablica :
parametry_kanalu kanal[10];
wszystko ładnie śmiga mogę się odwoływać do poszczególnych zmiennych w kolejnych kanałach itd..

problem zaczyna się, gdy podobną zmienną chciałbym stworzyć w pamięci eeprom
czyli np:
parametry_kanalu kanal_ee[10] EEMEM;

niestety tutaj akcje :
eeprom_write_block(&kanal[1], &kanal_ee[1], sizeof(parametry_kanalu));
eeprom_write_block(&kanal[6], &kanal_ee[6], sizeof(parametry_kanalu));*/

eeprom_read_block(&kanal[1], &kanal_ee[1], sizeof(parametry_kanalu));
eeprom_read_block(&kanal[6], &kanal_ee[6], sizeof(parametry_kanalu));

nie działają tak jak bym chciał
za to mogę się odwołać do eeprom_read_block(&kanal[1], &kanal_ee[10], sizeof(parametry_kanalu));

to zadziałało.
Więc pomyślałem że potworzę kolejne zmienne jak poniżej:
parametry_kanalu kanal_ee[1] EEMEM;
parametry_kanalu kanal_ee[2] EEMEM;
parametry_kanalu kanal_ee[3] EEMEM;

niestety Eclips okazał się sprytniejszy i mi na to nie pozwala....

Pytanie jaką pójść drogą aby w pamięci eeprom stworzyć taką zmienną tablicową typu strukturalnego?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 14 lut 2020, o 21:57 
Offline
Użytkownik

Dołączył(a): 25 lip 2013
Posty: 2269
Pomógł: 106

Oglądałeś poradniki Mirka dot Eepromow?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 14 lut 2020, o 22:08 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 25953
Lokalizacja: Szczecin
Pomógł: 980

dokładnie - zobacz to:

https://www.youtube.com/watch?v=W7f0EnDzS_M
https://www.youtube.com/watch?v=ix0EBtdiviY

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 14 lut 2020, o 22:17 
Offline
Nowy

Dołączył(a): 26 lis 2019
Posty: 6
Pomógł: 0

O!!! nie trafiłem na nie do tej pory :) Dziękuję odezwę się czy rozwiązałem problem.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 14 lut 2020, o 23:05 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 25953
Lokalizacja: Szczecin
Pomógł: 980

A jak nie to śmiało pytaj ale PROSZĘ jak wklejasz kod to włącz poprawne formatowanie na forum ok? Masz przecież poradnik na forum jak to robić - zobacz ;) topic7402.html

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 15 lut 2020, o 10:56 
Offline
Nowy

Dołączył(a): 26 lis 2019
Posty: 6
Pomógł: 0

Witam ponownie, temat z grubsza opanowany.
Z pojedynczą strukturą lub kilkoma o różnych nazwach nie mam problemu w zapisie i odczycie Do EEPROMa
Problem pojawił się jak chciałem kilka czy killkanaście takich samych struktur tak żeby można było potem dostęp indeksować w np w pętli,ale jak to Mirku mówisz w poradnikach pokolei sprawdzać kompilować i do czegoś się dochodzi. Tak więc popełniłem taki krótki program testowy i w zasadzie wszystko działa tylko.....mam chyba nie najlepszy sposób inicjalizacji takiej zmiennej.
Ogólnie chciałbym aby przy programowaniu procka poszły jednorazowo do eproma dane początkowe ale przy sposobie jak niżej wszystko działa tylko zgłasza mi warningi o braku nawiasów więc coś pewnie nie jest zgodnie ze sztuką

Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 15 lut 2020, o 11:19 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 09 gru 2014
Posty: 1540
Pomógł: 269

Spróbuj tak:
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.


Autor postu otrzymał pochwałę


Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 15 lut 2020, o 11:35 
Offline
Nowy

Dołączył(a): 26 lis 2019
Posty: 6
Pomógł: 0

Super poszło :) czasami najprostsze pomysły są najtrudniejsze. Nawet coś tak próbowałem ale chyba jakiś przecinek połknąłem i wywalił błąd. Teraz jest ok :) Reszta śmiga. Dziękuję wszystkim za pomoc.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 8 ] 

Strefa czasowa: UTC + 1


Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 0 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
Sitemap
Technologię dostarcza phpBB® Forum Software © phpBB Group phpBB3.PL
phpBB SEO