Kanał - ATNEL tech-forum
Wszystkie działy
Najnowsze wątki



Teraz jest 18 paź 2019, o 12:41


Strefa czasowa: UTC + 1





Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 22 ] 
Autor Wiadomość
PostNapisane: 3 maja 2019, o 13:27 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 24817
Lokalizacja: Szczecin
Pomógł: 927

i ultra szybki poradnik tekstowo ilustrowany ;)

Obrazek

Mam nadzieję, że się przyda ;)

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 3 maja 2019, o 13:36 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 13 cze 2016
Posty: 54
Lokalizacja: Katowice
Pomógł: 1

Nooo, pięknie w jednym miejscu :)) jak zwykle strzał w 10! :) Wieczorkiem biorę się za Eclipse :D

Wysłane z mojego POCOPHONE F1 przy użyciu Tapatalka



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 3 maja 2019, o 13:52 
Offline
Nowy

Dołączył(a): 03 gru 2014
Posty: 23
Pomógł: 2

Super. To będzie naprawdę pomocne. Dzięki.

Wysłane z mojego SM-G900F przy użyciu Tapatalka



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 3 maja 2019, o 18:27 
Online
Użytkownik
Avatar użytkownika

Dołączył(a): 15 lut 2017
Posty: 276
Lokalizacja: Gliwice
Pomógł: 23

Świetny poradnik. Takie podsumowanie będzie bardzo przydatne.
Co do wyłączania sprawdzania pisowni to wg mnie lepiej zainstalować słownik języka polskiego.
W załączniku wrzucam odpowiedni plik oraz zrzut w jaki sposób go skonfigurować.
Plik "slownik.txt" należy rozpakować w dowolne miejsce i wskazać jego położenie.

Obrazek


Załączniki:

Aby zobaczyć załączniki musisz się zalogować. Tylko zalogowani użytkownicy mogą oglądać i pobierać załączniki.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 3 maja 2019, o 20:23 
Offline
Użytkownik

Dołączył(a): 25 lip 2013
Posty: 1900
Pomógł: 88

Dzięki Mirku i dzięki Zealota! Brak jeszcze info nt Gadgeta, bez, którego nie wyobrażam sobie pracy. Wprawdzie na codzień używam MkClipse'a ale czasami może się i Eclipse przyda ;)



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 4 maja 2019, o 08:52 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 02 mar 2014
Posty: 123
Lokalizacja: Staszów
Pomógł: 5

I ja uprzejmie dziękuję.
Przyda się, szczególnie mi jako początkującemu.

Odnoszę wrażenie, że jakby ciężko tu na forum było wesprzeć Autora choćby wdzięcznym słowem za wykonaną pracę.
Nie dotyczy to oczywiście zasłużonych, doświadczonych forumowiczów.
Ale początkujący? Dlaczego się wahają? Nie czują potrzeby? Że niby się należy z urzędu?
Może dlatego, że wszystko to dobro nam tu podawane jest za darmo.

_________________
Ad augusta per angusta



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 5 maja 2019, o 14:17 
Offline
Nowy

Dołączył(a): 05 maja 2019
Posty: 2
Pomógł: 0

Dzień dobry, przeszedłem cała konfigurację eclipsa z poradnikiem Pana Mirka jest naprawdę super. Wgrywałem swój pierwszy program za pomocą usbasp na atmega8(tak jak na poradniku). Problem wystąpił kiedy zmieniłem taktowanie w Eclipsie na 8 Mhz, zrobiłem : Clean... /usuołem wartość -B 8 w (other) i przy próbie wgrania programu z Eclipse dioda całkowicie zgasła.T araz gdy w mk calulator kilkam 'sprawdz AVR' wyskakuje komunikat: zdjecie ponizej.
Jak mieniłem taktowanie w samym mk calculator było ok, po zmianie w programie eclipse niestety microkontroler przestał być wykrywany i ten bład na screen shot.

Obrazek



Ostatnio edytowano 6 maja 2019, o 08:48 przez marek00130, łącznie edytowano 1 raz

Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 5 maja 2019, o 16:11 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 08 wrz 2015
Posty: 288
Lokalizacja: Zamość
Pomógł: 7

marek00130 napisał(a):
zdjecie ponizej.

Zdjęć nie widać, zobacz jak wstawiać fotki:
topic44.html



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 6 maja 2019, o 08:49 
Offline
Nowy

Dołączył(a): 05 maja 2019
Posty: 2
Pomógł: 0

dzięki, poprawione ;)



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 6 maja 2019, o 12:12 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 24817
Lokalizacja: Szczecin
Pomógł: 927

marek00130 napisał(a):
Jak mieniłem taktowanie w samym mk calculator było ok, po zmianie w programie eclipse niestety microkontroler przestał być wykrywany i ten bład na screen shot.


to zacznij lepiej od schematu i ew zdjęć jak masz to podłączone bo ewidentnie to co się dzieje nie jest winą programowania, wgrywania wsadu itp - tylko na 100% obstawiam złe połączenia ew zasilanie

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 20 maja 2019, o 11:10 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 22 lis 2012
Posty: 109
Lokalizacja: Radom
Pomógł: 2

Przy uruchomieniu Eclips 2019 wywala komunikatObrazek

_________________
http://januszp25.blogspot.com/



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 20 maja 2019, o 11:28 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 08 wrz 2015
Posty: 288
Lokalizacja: Zamość
Pomógł: 7

janusz napisał(a):
Przy uruchomieniu Eclips 2019 wywala komunikatObrazek
Odinstaluj jave i zainstaluj poprawną, masz np. eclipse 64bit, Java 32 lub odwrotnie. Najlepiej zainstaluj obie 64 o ile system obsługuje

Wysłane z mojego moto g(6) przy użyciu Tapatalka



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 23 maja 2019, o 10:55 
Offline
Tech-support
Avatar użytkownika

Dołączył(a): 14 lut 2014
Posty: 277
Lokalizacja: Kraków
Pomógł: 4

Dzięki Mirku

_________________
http://forum.atnel.pl/topic15633.html



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 15 wrz 2019, o 11:18 
Offline
Nowy
Avatar użytkownika

Dołączył(a): 15 wrz 2019
Posty: 2
Lokalizacja: Kalisz
Pomógł: 0

Witam wszystkich po raz pierwszy.
Doszedłem do rozdziału "Zajęcia praktyczne" w BB, niestety to mnie na razie przerasta. Obejrzałem poradniki o Eclipse, ale one są z 2014... Więc od tego czasu sporo się zmieniło w oprogramowaniu. W tym momencie zrobiłem wszystko co mogłem czytając forum. Jest zainstalowany nowy Eclipse 2019-06, jest MkAvrCalculator, jest AVRDude. Myślę, że problem tkwi w obsłudze Eclipse, zbyt dużej ilości opcji. Program nie tworzy sam pliku makefile ani hex'ów. Eclipse nie spytał mnie nigdzie jaki procesor będę programował, jaka będzie częstotliwość. Prawdopodobnie coś źle zaczynam.
Czy ktoś mógłby pomóc mi telefonicznie albo jakimś TeamViewer'em?

Obrazek



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 15 wrz 2019, o 11:24 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 08 wrz 2015
Posty: 288
Lokalizacja: Zamość
Pomógł: 7

@bestmlody: kliknij na nazwę projektu, czyli pierwszy, wtedy daj kompilacje
Avrplugin? Zainstalowany? Jak coś odezwij się na PW pomogę
Wysłane z mojego moto g(6) przy użyciu Tapatalka



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 15 wrz 2019, o 13:00 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 24817
Lokalizacja: Szczecin
Pomógł: 927

Poza tym na tym zrzucie ekranu brakuje #

#include

a nie

include

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 15 wrz 2019, o 13:12 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 08 wrz 2015
Posty: 288
Lokalizacja: Zamość
Pomógł: 7

@mirekk36: już się z nim zgadałem, jest ogólnie problem z systemem, bo nawet mkclipse wyłącza się, a w eclipse problem z avr-gcc.exe. wieczorem mamy się jeszcze dzwonić i spróbować temat ogarnąć

Wysłane z mojego moto g(6) przy użyciu Tapatalka



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 15 wrz 2019, o 17:45 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 24817
Lokalizacja: Szczecin
Pomógł: 927

Antywirus

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 15 wrz 2019, o 21:54 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 08 wrz 2015
Posty: 288
Lokalizacja: Zamość
Pomógł: 7

mirekk36 napisał(a):
Antywirus
Temat ogarnięty, zrobione, może działać w eclipse jak też i mkclipse.

Wysłane z mojego moto g(6) przy użyciu Tapatalka



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 16 wrz 2019, o 18:51 
Offline
Nowy
Avatar użytkownika

Dołączył(a): 15 wrz 2019
Posty: 2
Lokalizacja: Kalisz
Pomógł: 0

tak jest - wszystko działa :)
Tutaj wielkie dzięki dla Miśka, który poświęcił mi 3h swojej niedzieli. Łatwo nie było, dla laika nie do przebrnięcia.
Myślę, że jednak problem był z Toolchain'em. Dopiero po jego "zmodyfikowaniu", bo nie można nazwać tego instalacją, zaczęło wszystko działać.
Teraz mogę dalej czytać rozdział "Zajęcia praktyczne".



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 16 wrz 2019, o 20:40 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 08 wrz 2015
Posty: 288
Lokalizacja: Zamość
Pomógł: 7

@bestmlody: Po to jest forum, by pomagać, ogarniać tematy. Powodzenia w programowaniu



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 16 wrz 2019, o 23:04 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 24817
Lokalizacja: Szczecin
Pomógł: 927

bestmlody napisał(a):
tak jest - wszystko działa :)
Tutaj wielkie dzięki dla Miśka, który poświęcił mi 3h swojej niedzieli. Łatwo nie było, dla laika nie do przebrnięcia.
Myślę, że jednak problem był z Toolchain'em. Dopiero po jego "zmodyfikowaniu", bo nie można nazwać tego instalacją, zaczęło wszystko działać.
Teraz mogę dalej czytać rozdział "Zajęcia praktyczne".


Tylko na przyszłość proszę zakładaj nowy wątek z opisem własnego problemu, teraz mógłbyś kliknąć przycisk "POMÓGŁ" pod pomógł" pod postem kolegi Misiek_86, żeby otrzymał zasłużoną pigułkę forumową

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 22 ] 

Strefa czasowa: UTC + 1


Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 2 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
Sitemap
Technologię dostarcza phpBB® Forum Software © phpBB Group phpBB3.PL
phpBB SEO