Kanał - ATNEL tech-forum
Wszystkie działy
Najnowsze wątki



Teraz jest 21 lut 2024, o 08:45


Strefa czasowa: UTC + 1





Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 2 ] 
Autor Wiadomość
PostNapisane: 7 sty 2024, o 12:20 
Offline
Nowy
Avatar użytkownika

Dołączył(a): 19 lis 2016
Posty: 21
Pomógł: 0

Witam
Nie mogę sobie dać rady z prawidłowym odczytem danych
Chce odczytać dane wysłać na serial i odczekać np 1sek Problem w tym że dane docierają z 'opóźnieniem' tz pomiar dostaje co sekunde ale po 6-7 sekundach jest on prawidłowy
i niewiem gdze leży problem


proszę o zerkniecie w kod


Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 22 sty 2024, o 17:39 
Offline
Nowy
Avatar użytkownika

Dołączył(a): 19 lis 2016
Posty: 21
Pomógł: 0

problem prawdopodobnie jest bufor portu Serial zapełnia sie i musi być odczytany w całości
Temat już nie aktualny przeszedłem na inny czujnik
pozdrawiam



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 2 ] 

Strefa czasowa: UTC + 1


Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 1 gość


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
Sitemap
Technologię dostarcza phpBB® Forum Software © phpBB Group phpBB3.PL
phpBB SEO