Kanał - ATNEL tech-forum
Wszystkie działy
Najnowsze wątki



Teraz jest 17 cze 2024, o 14:00


Strefa czasowa: UTC + 1





Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 60 ]  Przejdź na stronę 1, 2  Następna strona
Autor Wiadomość
PostNapisane: 30 lip 2023, o 13:35 
Offline
Użytkownik

Dołączył(a): 09 lip 2019
Posty: 108
Pomógł: 11

Hej,
programuję sobie coś "na sucho" z wykorzystaniem ATNEL WIFI ESP (nie mam przy sobie sprzętu, żeby sprawdzić) - w dokumentacji jest następująca informacja dla komendy AT+UARTZ

AT+UARTZ=<BAUDRATE>,
<DATABITS: 5,6,7,8>,
<PARITY: n,e,o>, (n-NONE, e-EVEN, o-ODD)
<STOPBITS: 1,2>,
<FLOW CONTROL: 0,1,2,3><CR><LF>
<CR><LF>
OK<CR><LF>

ale poniżej z kolei
<PARITY: n,e,o> - bit parzystości: 0-NONE, 1-ODD, 2-EVEN

Pytanie - czy po przecinku dla parity bits ma się znaleźć kod litery 'n', czy kod cyfry '0'?
Założyłem niby to pierwsze - bo częściej się powtarza w dokumentacji, ale mam prośbę o potwierdzenie.

I jeszcze jedno dodatkowe pytanie - z jakiegoś powodu antywirus (Eset) rozpoznaje mi plik exe MkEspTool jako podejrzany i "wymiata" natychmiast z dysku - tutaj komunikat:

Info z Eseta:
7/27/2023 11:30:45 PM;Real-time file system protection;
file;C:\atnelApps\ESP_MkTool\MkESPtool.exe;Suspicious Object;
cleaned by deleting;

Plik po ściągnięciu i rozpakowaniu ze strony https://atnel.pl/mkesptool.html

Ktoś jeszcze może tak ma? Trochę się boję wyłączać antywira, żeby to sprawdzić :-)



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 30 lip 2023, o 17:12 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 06 mar 2015
Posty: 314
Lokalizacja: Czerwionka-Leszczyny
Pomógł: 22

Nie bój się wyłączyć antywira w takiej sytuacji.
Nie wiem jak ESET ale w ustawieniach powinieneś też mieć opcję typu: dopuszczaj, zezwalaj, dodaj do wyjątków itp. Możesz to zrobić w opcjach antywira ale nie wiem czy Eset to ma. Jeżeli nie masz nic takiego a potrafisz program pobrać z internetu bez żadnych problemów, to proponuję po pobraniu wyłączyć na chwilę internet, rozpakować, czy też zainstalować dany program i ponownie uruchomić komputer. Wtedy już po uruchomieniu, możesz włączyć antywira i to wszystko. I bez obaw o zarażenie PC-ta. W takich sytuacjach zawsze tak robię i nie mam z tym żadnych problemów.

_________________
http://www.avrboss.pl



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 30 lip 2023, o 18:07 
Offline
Użytkownik

Dołączył(a): 09 lip 2019
Posty: 108
Pomógł: 11

mario2015 napisał(a):
Nie bój się wyłączyć antywira w takiej sytuacji.
Nie wiem jak ESET ale w ustawieniach powinieneś też mieć opcję typu: dopuszczaj, zezwalaj, dodaj do wyjątków itp. [...].

OK - dzięki za informację - tak zrobię :-)

Jeszcze trochę pytań/wątpliwości mi się przyplątało czytając dokumentację i pisząc program. Może się przydadzą się też przy następnej rewizji dokumentu :-)

x. Dla komendy AT+WIFISTA parametry podane w dokumentacji są w następujący sposób:
AT+WIFISTA=<idx:0-4><"DISABLE","SSID">,["PASS"]<CR><LF>
czy po idx:0-4 nie powinno być przecinka?
tzn. komenda bedzie wyglądała na przykład tak:
AT+WIFISTA=0,"DISABLE"
czy
AT+WIFISTA=0"DISABLE"
?

x. Podobnie jak wyżej pytanie do komend:
AT+WIFISIP=<idx:0-4><"DISABLE","IP">,["MASK"],["GW"]<CR><LF>
AT+WIFISIP=<idx:0-4><"DISABLE","IP">,["MASK"],["GW"]
AT+TCPTO=<sock nr:0-1><"TIMEOUT">

x. Jeśli dobrze zrozumiałem wszystkie parametry które nie są liczbą (tzn. numer portu, timeout, wartość opcji 0,1,2,3 etc, ew. pojedynczym znakiem jak w poprzednim poście 'n') zawsze podawane są w cudzysłowach? (tzn. dotyczy to takich wartości parametrów jak np. "DISABLE", "MAX", "MIN", "TCP", "UDP", "SRV", "CLI" i tak dalej, oraz numerów IP, bramki, maski)

x. Być może coś mieszam, ale dla komendy AT+LOGO być może definicja formatu powinna być konsekwentna z pozostałymi komendami tzn. zamiast
AT+LOGO=<ONOFF><CR><LF>
powinno być chyba w dokumentacji
AT+LOGO=<OnOff: 0-1><CR><LF>
albo coś podobnego :-)

x. Czy jest jakiś minimalny czas od wysłania znaków wyjścia z trybu transparentnego ("+++"), czy po prostu trzeba poczekać na odpowiedź "+TRANSPARENT MODE: OFF" w takim przypadku? Jaki można bezpiecznie przyjąć timeout w takim przypadku? (tzn. na przykład, kiedy układ coś robi aktualnie, czy może się przytrafić, że potrwa to parę sekund?)

x. Który z trybów stawianych przez komendę "AT+WIFIMODE" jest domyślny (tzn. fabryczny, lub po przywroceniu ustawień fabrycznych komendą AT+Z)?

x. Czy da się jakoś pobrać aktualną konfigurację zapisane komendą AT+UFOTAIP?. Na przykład jeśli coś sobie namieszam i ustawię coś innego - żeby przywrócić do oryginalnego stanu



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 31 lip 2023, o 07:09 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 27255
Lokalizacja: Szczecin
Pomógł: 1041

moscow napisał(a):
Pytanie - czy po przecinku dla parity bits ma się znaleźć kod litery 'n', czy kod cyfry '0'?
Założyłem niby to pierwsze - bo częściej się powtarza w dokumentacji, ale mam prośbę o potwierdzenie.


Jak wiadomo wszystko się jeszcze mocno zmienia i niestety tu pozostała jak widać mocna nieścisłość w dokumentacji - muszę to poprawić. A zrobiłem już tak żeby wygodnie można było podawać literki zamiast zer i jedynek. Dlatego teraz przykład ustawiania prędkości to:

Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.


------------------------ [ Dodano po: 10 minutach ]

moscow napisał(a):
I jeszcze jedno dodatkowe pytanie - z jakiegoś powodu antywirus (Eset) rozpoznaje mi plik exe MkEspTool jako podejrzany i "wymiata" natychmiast z dysku - tutaj komunikat:


eeeh panowie panowie ;) a tyle razy o tym wszędzie mówię - szczególnie często temat pojawia się na naszym discordzie. Na szczęście akurat masz bardzo dobry program ESET ja też go używam i jest to jeden z najlepszych - ale nie tam pod kątem liczby wykrywanych wirusów bo teraz to już się na to nie patrzy przy porównywaniu antywirusów ale jest najlepszy pod kątem ustawień. I niestety - jak macie antywirusy no to zajmując się programowaniem MUSICIE czy tego chcecie czy nie nauczyć się obsługi takich programów.

ok jeszcze raz na spokojnie powtórzę - NIE TRZEBA WCALE WYŁĄCZAĆ ANTYWIRA bo to bez sensu. Nie trzeba też robić żadnych wykluczeń czy wyjątków. Wystarczy wyłączyć JEDNĄ GŁUPAWĄ funkcję w każdym antywirze ... nazywa się ona często troszkę inaczej ale jej nazwa sprowadza się zawsze do:

"WYKRYWANIE POTENCJALNYCH ZAGROŻEŃ"

i to jest bzdura nad bzdurami - szczególnie dla osób które same tworzą swoje softy na PC ... Wystarczy tą jedną głupią opcję wyłączyć - ona nie ma nic wspólnego z normalną ochroną antywirusową i normalnym działaniem antywirusa. Za to przestaje "mu się wydawać" mówię o antywirusie że coś jest potencjalnym zagrożeniem i chlastać takie programy bo to doprowadza przynajmniej mnie do furii jak mi antywir coś bez mojej wiedzy wycina z dysku! Rozumiałbym, że nie dopuszcza do uruchomienia, że raportuje ale kasować z dysku i do kwarantanny? bzdura

proszę bardzo:

Obrazek

------------------------ [ Dodano po: 12 minutach ]

aaa i jeszcze niżej wyłączone są także "Potencjalnie niebezpieczne aplikacje"

Podejrzane - ok można zostawić - ale POTENCJALNIE??? z tym słowem potencjalnie to są najczęściej kretyńskie opcje antywirusów które niosą więcej badziewia niż korzyści

------------------------ [ Dodano po: 14 minutach ]

moscow napisał(a):
Jeszcze trochę pytań/wątpliwości mi się przyplątało czytając dokumentację i pisząc program. Może się przydadzą się też przy następnej rewizji dokumentu

x. Dla komendy AT+WIFISTA parametry podane w dokumentacji są w następujący sposób:
AT+WIFISTA=<idx:0-4><"DISABLE","SSID">,["PASS"]<CR><LF>


Tak oczywiście że zjadłem przecinek i tu powinien być:

Cytuj:
AT+WIFISTA=<idx:0-4>,<"DISABLE","SSID">,["PASS"]<CR><LF>


------------------------ [ Dodano po: 24 minutach ]

Poza tym właśnie uwzględniłem te przecinki ale też dla niektórych ważnych i trudniejszych komend dodałem PRZYKŁADY ich wywołań itp - proszę rzucić okiem i spokojnie jak coś pisać i zgłaszać jeśli coś jest mocno nie tak.

Oczywiście nie ma co zgłaszać rzeczy których nie ma - bo jeszcze DUŻO ich się pojawi z mojej strony - ale wszystko po kolei i na spokojnie

Na DZISIAJ jest już w tym celu nowsza wersja programu "Atnel WiFi Tools" v1.0.14 i w jego zakładce INFO można klikać i mieć już nowsze wersje instrukcji w plikach *.chm i *.pdf

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 3 sie 2023, o 17:22 
Offline
Użytkownik

Dołączył(a): 09 lip 2019
Posty: 108
Pomógł: 11

Dzięki za wyjaśnienia :-) - trochę dalej zacząłem się bawić i znów pytania się pojawiły (aktualnie mam wersję firmware 1.07)

1. Czy otwieranie portów poniżej 80tego jest może w jakiś sposób zablokowane?
AT+SOCKCFG=1,"TCP","SRV",80
działa mi poprawnie
AT+SOCKCFG=1,"TCP","SRV",23 (zrobiłem też kilka prób dla innych portów 79 i niżej) daje przyładowy komunikat:
AT+SOCKCFG=1,"TCP","SRV",79
+SOCK_1:DISABLED

OK

2. Czy wysłanie komendy
AT+SOCKCFG=1,"DISABLE"
powinno zamknąć od razu ten port?
W moim przypadku połączenie pozostaje otwarte. Nawet jak rozłączę terminal, to potem mogę się znów połączyć. Dopiero wysłanie "AT+RST" powoduje, że na ten socket nie można już wjechać.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 4 sie 2023, o 09:43 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 27255
Lokalizacja: Szczecin
Pomógł: 1041

moscow napisał(a):
1. Czy otwieranie portów poniżej 80tego jest może w jakiś sposób zablokowane?

TAK

moscow napisał(a):
powinno zamknąć od razu ten port?

NIE - dopiero po restarcie jest efekt - ale gdyby to było aż tak potrzebne to można byłoby to zmienić - tylko musiałbym mieć jakieś uzasadnienie

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 4 sie 2023, o 10:53 
Offline
Użytkownik

Dołączył(a): 09 lip 2019
Posty: 108
Pomógł: 11

mirekk36 napisał(a):
moscow napisał(a):
1. Czy otwieranie portów poniżej 80tego jest może w jakiś sposób zablokowane?

TAK

moscow napisał(a):
powinno zamknąć od razu ten port?

NIE - dopiero po restarcie jest efekt - ale gdyby to było aż tak potrzebne to można byłoby to zmienić - tylko musiałbym mieć jakieś uzasadnienie

OK, dzięki za wyjaśnienie :-) Co do zamyknia portu - jest może jakiś inny sposób na wymuszenie zamknięcia połączenia TCP ze strony uC poza resetem?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 4 sie 2023, o 12:29 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 27255
Lokalizacja: Szczecin
Pomógł: 1041

moscow napisał(a):
Co do zamyknia portu - jest może jakiś inny sposób na wymuszenie zamknięcia połączenia TCP ze strony uC poza resetem?

A ja się pytałem o uzasadnienie tej potrzeby

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 4 sie 2023, o 13:04 
Offline
Użytkownik

Dołączył(a): 09 lip 2019
Posty: 108
Pomógł: 11

mirekk36 napisał(a):
moscow napisał(a):
Co do zamyknia portu - jest może jakiś inny sposób na wymuszenie zamknięcia połączenia TCP ze strony uC poza resetem?

A ja się pytałem o uzasadnienie tej potrzeby


Myślałem o następującym scenariuszu. Klient łączy się nie na stałe, tylko na chwilę, żeby wymienić informacje z serwerem, którym jest uC. Jeśli jest to mój klient (napisana przeze mnie aplikacja), to problemu nie ma, ale jeśli podłączy się ktoś inny (powiedzmy terminalem) w tej samej sieci i nie zautoryzuje się poprawnie w określonym czasie, to połączenie jest odrzucane po timeoucie, żeby zwolinić slot (tych jak rozumiem jest 5).



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 4 sie 2023, o 13:55 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 27255
Lokalizacja: Szczecin
Pomógł: 1041

a widzisz - dlatego pytałem o uzasadnienie - więc zajrzyj proszę teraz do instrukcji do komendy AT+TCPTO ... bo taki scenariusz realizują również serwery http i jest to konfigurowalne dla TCP jako KeepAlive


Autor postu otrzymał pochwałę

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 4 sie 2023, o 14:34 
Offline
Użytkownik

Dołączył(a): 09 lip 2019
Posty: 108
Pomógł: 11

mirekk36 napisał(a):
a widzisz - dlatego pytałem o uzasadnienie - więc zajrzyj proszę teraz do instrukcji do komendy AT+TCPTO ... bo taki scenariusz realizują również serwery http i jest to konfigurowalne dla TCP jako KeepAlive

OK - dzięki - popróbuję :-)



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 5 sie 2023, o 22:20 
Offline
Użytkownik

Dołączył(a): 09 lip 2019
Posty: 108
Pomógł: 11

Jeszcze na jedną minę się wpakowałem, ale Mirek naprowadził mnie bezpośrednio w korespondencji mailowej.
Okazało się, że jest ograniczenie dotyczące konfiguracji socketa UDP - działają porty równe 1000 lub wyższe - piszę tutaj jakby komuś miało się przydać.

Jak już wszystko ruszyło - muszę przyznać, że genialnie to działa w trybie współpracy z MkBootloaderem. Wgrywanie programu szybko i bezpośrenio z Eclipse (dla 500kbps poniżej 2 sekund przy 7kB wsadu + jakieś 3 sekundy inne operacje). Jednocześnie podłączony PuTTy, gdzie można sobie pracować komendami AT w terminalu. Równolegle może być też podłączona jakaś aplikacja, która jest podłączona do tego samego portu. Jak się coś przytnie, albo palec się omsknie, to hardwareowy reset załatwia sprawę. Sprzęt sobie leży na elegancko na szafce w domu, a lapka można sobie bez kabli używać w ogródku przełączając się z jednego zestawu do innego zmieniając tylko adres IP (jak ma się więcej niż jeden ATB-ESP)

Wygoda fantastyczna takiej pracy!!! :-)

Poniżej komplet komend AT, które użyłem do konfiguracji w trybie MkBootloader3:

Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.

PS. No i warto oczywiście uważać jaką prędkość UARTa się używa - 115200 przy zegarze 16MHz to nie jest najlepszy wybór - o tym też zapomniałem :-)



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 6 sie 2023, o 10:49 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 27255
Lokalizacja: Szczecin
Pomógł: 1041

fajne podsumowanie do konfiguracji na potrzeby MkBootloadera ;) ale też miło słyszeć - że to działa i jest taki pozytywny odbiór.

jedno tylko muszę sprostować:
moscow napisał(a):
Okazało się, że jest ograniczenie dotyczące konfiguracji socketa UDP - działają porty równe 1000 lub wyższe

To nie jest żadne ograniczenie socketa UDP ;) ... żadne. Po prostu trzeba sobie zdawać sprawę, że niezależnie czy korzysta się z UDP przy okazji ESP , czy pisząc własne programy na komputer albo telefon - to nie jest zalecane używanie portów poniżej 1000 nie ze względu na to że to się zepsuje - tylko ze względu na to, że porty te są często zarezerwowane na różne ważne usługi działające w różnych systemach, windows, linux, android, iOS itp itd. Użycie zatem tych portów poniżej 1000 może prowadzić, że ktoś nie wiedząc o tym fakcie będzie próbował robić swoją komunikację a ona albo w ogóle nie będzie mu działała albo będą się działy jakieś dziwne rzeczy. Jednocześnie w takich sytuacjach człowiek nieświadomy tego faktu doprowadza też do kłopotów działania takich usług ;)

To tak samo jak np w sieciach nie można nadawać dwóm urządzeniom no dwóm komputerom tego samego adresu IP. Tzn można ;) ale no któryś z nich albo oba będą miały problemy z komunikacją. I też tego nie można nazwać ograniczeniem adresacji IP.

Mam nadzieję, że to teraz będzie jaśniejsze ;)

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 8 sie 2023, o 17:57 
Offline
Użytkownik

Dołączył(a): 02 gru 2015
Posty: 547
Pomógł: 27

Witam,
Czy już ruszyła wysyłka modułów Atnel Wifi Esp?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 8 sie 2023, o 20:59 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 27255
Lokalizacja: Szczecin
Pomógł: 1041

tonygryps napisał(a):
Witam,
Czy już ruszyła wysyłka modułów Atnel Wifi Esp?


jasne - ruszyła, tylko Paweł troszkę się nie wyrabia - z ilością zamówień, trzeba spokojnie czekać albo pisać do niego maila

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 14 sie 2023, o 20:28 
Offline
Użytkownik

Dołączył(a): 16 lis 2013
Posty: 30
Pomógł: 2

Czy działa wam komenda AT+GETNTPTM bo u mnie na firmware 1.09 nie chce zwrócić czasu. Mam tylko odpowiedź OK. Wcześniej oczywiście wykonana została poprawnie komenda AT+NTPSTART
Nie wiem czy ja coś robię nie tak, czy też komenda nie jest jeszcze zaimplementowana.

Mirku, czy nie dobrze by było aby wśród zapamiętanych serwerów NTP był serwer głównego Urzędu Miar np: tempus1.gum.gov.pl
Szczegóły: https://www.gum.gov.pl/pl/dla-biznesu/u ... Zegar.html



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 15 sie 2023, o 05:15 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 27255
Lokalizacja: Szczecin
Pomógł: 1041

jarekt napisał(a):
czy też komenda nie jest jeszcze zaimplementowana.

Jest zaimplementowana od samego początku, ale zawsze jak zadajesz pytanie to pisz proszę której wersji firmware używasz

jarekt napisał(a):
Mirku, czy nie dobrze by było aby wśród zapamiętanych serwerów NTP był serwer głównego Urzędu Miar

Owszem na stałe będą zaimplementowane serwery takie jakie są obecnie - i widać je po starcie - chyba że nie aktualizowałeś sobie firmware - a jeśli nie to szkoda, bo zawsze trzeba instalować nowszy

natomiast docelowo każdy będzie mógł sobie sam ustawiać swoje serwery czasu.

Jeśli ci nie działa na dzisiaj to być może na chwilę wyłączyłem to pokazywanie czasu więc już za chwilę puszczam aktualizację firmware 1.10 zatem proszę pobierz ją sobie i sprawdź.

Powinno być tak jak na rysunkach poniżej:

Obrazek

a w konsoli zobaczysz obecne serwery:

Obrazek

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 15 sie 2023, o 13:21 
Offline
Użytkownik

Dołączył(a): 16 lis 2013
Posty: 30
Pomógł: 2

mirekk36 napisał(a):
Jest zaimplementowana od samego początku, ale zawsze jak zadajesz pytanie to pisz proszę której wersji firmware używasz

No przecież pisałem, że była to wersja 1.09

Wgrałem też najnowszą wersję firmware v.1.10 ale bez efektu. Dalej nie wyświetla czasu, choć zgłasza wykonanie komendy poprawnie:

Obrazek

Wyłączenie Eseta i zapory nic nie daje. Macie jakieś pomysły gdzie szukać przyczyny?
Mirku, czy dzieje się coś istotnego w kodzie komendy AT+GETNTPTM po wyświetleniu stringu "OK"?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 15 sie 2023, o 19:11 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 27255
Lokalizacja: Szczecin
Pomógł: 1041

jarekt napisał(a):
Dalej nie wyświetla czasu, choć zgłasza wykonanie komendy poprawnie:

To może oznaczać tylko jedno - albo twój router albo twój dostawca internetu blokuje pakiety z serwerów czasu ... łatwo to sprawdzić, wystarczy odpalić moduł w innej lokalizacji jeśli możesz spróbować.

jarekt napisał(a):
Wyłączenie Eseta i zapory nic nie daje

Bo to nie ma nic wspólnego z pobieraniem czasu przez moduły, przecież one same wysyłają zapytania do internetu. A tak się zdarza, że niektórzy dostawcy blokują takie pakiety - no albo jak mówię może nawet twój router jest tak ustawiony

------------------------ [ Dodano po: 2 minutach ]

ale ja ze swojej strony jeszcze będę próbował też to sprawdzać, chociaż u mnie w dwóch różnych lokalizacjach i przy różnych dostawcach (praca-DSL z Orange), (dom-UPC)

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 17 sie 2023, o 12:50 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 27255
Lokalizacja: Szczecin
Pomógł: 1041

jarekt napisał(a):
Wgrałem też najnowszą wersję firmware v.1.10 ale bez efektu.

Przepraszam, wykryłem babola - niestety to moja wina że nie działało - tzn mam nadzieję, bo udało mi się tą systuację odtworzyć a dzięki temu chyba naprawić ... U mnie to działało bo używałem że tak powiem swojego trybu debugowego ... przepraszam za kłopot

w następnym firmware 1.11 powinno to już śmigać i wtedy proszę daj znać ok?

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 17 sie 2023, o 20:19 
Offline
Użytkownik

Dołączył(a): 16 lis 2013
Posty: 30
Pomógł: 2

Jak tylko wgram nowy firmware, a pewno podzielę się uwagami.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 18 sie 2023, o 06:56 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 27255
Lokalizacja: Szczecin
Pomógł: 1041

jarekt napisał(a):
Jak tylko wgram nowy firmware, a pewno podzielę się uwagami.


ok już jest! ;)

Obrazek

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 18 sie 2023, o 19:01 
Offline
Użytkownik

Dołączył(a): 16 lis 2013
Posty: 30
Pomógł: 2

Teraz działa dobrze. Zarówno komenda GETNTPTM działa jak w dokumentacji jak i wyświetla się aktualny czas podczas startu układu.

Zauważyłem jeszcze bug w wyświetlaniu daty krótkiej. Ma być sierpień.

Obrazek



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 18 sie 2023, o 20:24 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 27255
Lokalizacja: Szczecin
Pomógł: 1041

jarekt napisał(a):
Zauważyłem jeszcze bug w wyświetlaniu daty krótkiej. Ma być sierpień.

O żesz w mordkę! to ja ślepota nie widziałem tego - masakrung!!!! dzięki za uwagę - no i znowu coś trza poprawić - przepraszam lecę popracować nad wyprowadzką BUG'a ;)

------------------------ [ Dodano po: 4 minutach ]

no i mam BUG'a .... hehehe gdyby był styczeń to wyświetliłoby miesiąc zerowy ;) ... oczywiście w kolejnym firmware 1.12 będzie już ok i śliczne dzięki za wyłapanie tego - bo już dużo czasu minęło, wiele osób też to odpalało a nikt jak na razie poza Tobą nie zwrócił uwagi na ten koci błąd

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 20 sie 2023, o 17:41 
Offline
Użytkownik

Dołączył(a): 09 lip 2019
Posty: 108
Pomógł: 11

Właśnie wpadłem na pomysł (nie wiem, czy najmądrzejszy ;-) ), żeby uruchomić bootloader przez ATB-WIFI-ESP z ATmega64m1 (ATB-CAN-SHIELD-M1), ale jakby ten procek nie był wykrywany przez MKBootleadera (wersja 3.0.44). Z AT90CAN128 wszystko poszło bez pudła. Coś przeoczyłem może? Czy faktycznie nie ma tego procka? Jeśli faktycznie - czy byłaby szansa dodać wsparcie? :-)



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 21 sie 2023, o 01:21 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 27255
Lokalizacja: Szczecin
Pomógł: 1041

moscow napisał(a):
Właśnie wpadłem na pomysł (nie wiem, czy najmądrzejszy ;-) ), żeby uruchomić bootloader przez ATB-WIFI-ESP z ATmega64m1 (ATB-CAN-SHIELD-M1), ale jakby ten procek nie był wykrywany przez MKBootleadera (wersja 3.0.44). Z AT90CAN128 wszystko poszło bez pudła. Coś przeoczyłem może? Czy faktycznie nie ma tego procka? Jeśli faktycznie - czy byłaby szansa dodać wsparcie? :-)


Przykro mi ale absolutnie nie dam rady zrobić dla procków z serii M1 czyli z CAN i LIN - one mają dziwnego UART'a - obsługuje się go mocno inaczej - musiałbym specjalnie od nowa rzeźbić kod źródłowy itp itd - sorki nie dam rady

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 22 sie 2023, o 07:49 
Offline
Użytkownik

Dołączył(a): 09 lip 2019
Posty: 108
Pomógł: 11

mirekk36 napisał(a):
Przykro mi ale absolutnie nie dam rady zrobić dla procków z serii M1 czyli z CAN i LIN[...]

OK - jakoś przeżyję :-)
Jeszcze jedno w takim razie pytanko: czy w MK Clipse da się jakoś wybrać interfejs sieciowy z którego łączymy się do ATB ESP WiFi tak jak W MK Bootloader 3 i innym oprogramowaniu? Na jednym komputerze akurat domyślnie wybiera mi się nie ten interfejs co trzeba, tylko jakiś VPNowy i nie mam możliwości wyszukania modułów.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 22 sie 2023, o 19:31 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 27255
Lokalizacja: Szczecin
Pomógł: 1041

moscow napisał(a):
czy w MK Clipse da się jakoś wybrać interfejs sieciowy z którego łączymy się do ATB ESP WiFi tak jak W MK Bootloader 3 i innym oprogramowaniu? Na jednym komputerze akurat domyślnie wybiera mi się nie ten interfejs co trzeba, tylko jakiś VPNowy i nie mam możliwości wyszukania modułów.

No to by się kiedyś przydało naprawić tzn dodać

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 8 wrz 2023, o 15:05 
Offline
Użytkownik

Dołączył(a): 12 kwi 2012
Posty: 106
Pomógł: 0

Panie Mirku,
na kiedy przewiduje pan upublicznienie schematów modułów:
- ATNEL AIR ESP
- ATNEL AIR ESP-12X/07S/OLED



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 9 wrz 2023, o 06:04 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 27255
Lokalizacja: Szczecin
Pomógł: 1041

andrzej381 napisał(a):
Panie Mirku,
na kiedy przewiduje pan upublicznienie schematów modułów:
- ATNEL AIR ESP
- ATNEL AIR ESP-12X/07S/OLED

Już dawno są upublicznione i opisane - szkoda że kolega nie zagląda na stronę atnel.pl. Nadmienię tylko że nie ma dwóch różnych schematów do ATNEL AIR ESP jest jeden bo oba wymienione moduły to jest dokładnie to samo.

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 60 ]  Przejdź na stronę 1, 2  Następna strona

Strefa czasowa: UTC + 1


Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 23 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
Sitemap
Technologię dostarcza phpBB® Forum Software © phpBB Group phpBB3.PL
phpBB SEO