Kanał - ATNEL tech-forum
Wszystkie działy
Najnowsze wątki



Teraz jest 7 lip 2022, o 10:44


Strefa czasowa: UTC + 1





Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 3 ] 
Autor Wiadomość
PostNapisane: 20 cze 2022, o 22:10 
Offline
Użytkownik

Dołączył(a): 09 sty 2021
Posty: 66
Pomógł: 0

Witam mam chciałem po raz pierwszy uruchomić UART na Atmedze328P, ale Eclipse nie wykrywa mi rejestrów. Próbowałem kopiowa ich nazwy wprost z noty katalogowej i wstawiać w miejsce liczby n 0, 1 ale to też nic nie daje. Eclipse pokazuje błąd np: "UBBRH undeclared (first use in this function)". Jakie są prawidłowe nazwy tych rejestrów?

aktualny kod:

Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 21 cze 2022, o 15:38 
Offline
Nowy

Dołączył(a): 14 maja 2020
Posty: 2
Pomógł: 0

Jeżeli chodzi o 16-bitowy rejestr UBRR, to w Atmedze328 masz rejestr UBRR0, zatem będą to odpowiednio (8-bit) rejestry UBRR0H i UBRR0L. Tak samo rejestrem danych będzie UDR0.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 27 cze 2022, o 22:25 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 25 sty 2014
Posty: 178
Pomógł: 24

W Eclipse blisko zakładki console jest zakładka AVR Device Explorer i tam też znajdziesz nazwy rejestrów które kompilator "rozumie".



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 3 ] 

Strefa czasowa: UTC + 1


Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 0 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
Sitemap
Technologię dostarcza phpBB® Forum Software © phpBB Group phpBB3.PL
phpBB SEO