Kanał - ATNEL tech-forum
Wszystkie działy
Najnowsze wątki



Teraz jest 27 sty 2022, o 01:11


Strefa czasowa: UTC + 1





Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 12 ] 
Autor Wiadomość
PostNapisane: 10 sty 2022, o 21:06 
Offline
Nowy

Dołączył(a): 22 sie 2018
Posty: 23
Pomógł: 0

Cześć wszystkim.

Piszę bo zostałem doprowadzony do ostateczności. Chciałem zacząć bawić się magic ledami WS1812b. W tym celu obejrzałem wszystkie poradniki Pana Mirka w tym temacie, wziąłem zestaw ATB i ruszyłem do boju podąrząjąc razem z nim przed najpierw słabe rozwiązanie aż do porządnej wstawki asemblerowej. Niestety na żadnym etapie nie udało mi się nawet minimalnie zaświecić jednego leda. Nie wiem co się dzieje i jak to ruszyć. Bardzo serdecznie proszę o pomoc. Nie wiem czy skiepściłem coś może przy ustawieniu taktowania procka lub może coś w kodzie. Wejście łańcuszka diod jest podłączone do portu PB0 natomiast zasilanie biorę z zestawu ATB. Nic więcej tu nie ma. Załączam screeny z mkAvrCalculatora, ustawień projektu w Eclipsie i wszystkie 3 pliki źródłowe (main.c, ws2812.c, ws2812.h).

Bardzo proszę o wskazówki, bo wyczerpały mi się pomysły.

Pozdrawiam, Przemek.

PS Jeśli dodałem post w złym miejscu, proszę moderatora o przeniesienie :)

Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.


Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.

Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.


ObrazekObrazekObrazekObrazekObrazekObrazek



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 10 sty 2022, o 23:48 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 26686
Lokalizacja: Szczecin
Pomógł: 1022

a czy wszystko jest dobrze podłączone ? chodzi o twoje magic ledy ?

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 10 sty 2022, o 23:54 
Offline
Użytkownik

Dołączył(a): 09 lip 2019
Posty: 58
Pomógł: 4

Trochę się bawiłem MagicLedami na bazie poradników Mirka. Możesz rzucić okiem na mój projekt - ten na pewno działał :-)
https://github.com/k-moskwa/kmAvrLedBar
Jeśli nie ruszy, to może znaczyć ze coś z połączeniami.

Liczba LED, port itp - konfiguracja w
https://github.com/k-moskwa/kmAvrLedBar ... ltConfig.h
Najprościej podłączyć przycisk do PINu zdefiniowanego w
https://github.com/k-moskwa/kmAvrLedBar ... ltConfig.h
( domyślnie PC1 )
Po naciśnięciu coś powinno zacząć się mienić.

FCPU 16 MHz



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 11 sty 2022, o 00:18 
Offline
Nowy

Dołączył(a): 22 sie 2018
Posty: 23
Pomógł: 0

Paine Mirku.
Wydaje mi sie że tak. Co tu może być źle podłączone? Załączam zdjęcia na których lepiej widać przewody połączeniowe. Dziękuje za odpowiedź.

ObrazekObrazek



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 11 sty 2022, o 08:52 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 29 sty 2015
Posty: 164
Pomógł: 9

Na płytce stykowej widzę kilka rezystorów. Jeśli ich nie potrzebujesz, pomiń płytkę stykową i podłącz ledy bezpośrednio do płyty z MCU. Zawsze to jedna zmienna wyeliminowana, gdzie może coś nie łączyć.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 11 sty 2022, o 09:12 
Offline
Nowy

Dołączył(a): 22 sie 2018
Posty: 23
Pomógł: 0

Płytka stykowa wyeliminowana, nie pomogło. :(



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 11 sty 2022, o 09:25 
Offline
Użytkownik

Dołączył(a): 02 gru 2015
Posty: 512
Pomógł: 25

Bardzo by tu pomógł analizator stanów logicznych np. takihttps://allegro.pl/oferta/analizator-stanow-logicznych-saleae-24mh-8-kanalow-9592707197 albo oscyloskop jak masz, podpinasz pod nóżkę procka i widzisz czy coś nadaje jaki przebieg bo jak procek nadaje to przecież możesz mieć uszkodzone te diody.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 11 sty 2022, o 10:23 
Offline
Nowy

Dołączył(a): 22 sie 2018
Posty: 23
Pomógł: 0

Czy to, że mam diody 2812 a nie 2812b ma duże znaczenie?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 12 sty 2022, o 17:33 
Offline
Nowy

Dołączył(a): 22 sie 2018
Posty: 23
Pomógł: 0

Zakupiłem analizator stanów logicznych, przebadałem układ i oto przebieg jaki zobaczyłem. Wydaje mi się że wszystko jest jak być powinno (co wskazywało by na uszkodzone diody) ale czy ktoś mógłby na to zerknąć bardziej fachowym okiem?
Dorzucam też eksport danych w pliku .csv

Obrazek



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 12 sty 2022, o 21:24 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 26686
Lokalizacja: Szczecin
Pomógł: 1022

to nie jest żadna dziwna przerwa tylko przekręcenie się pętli w asm żeby móc wysyłać kolejny bajt i w niczym nie przeszkadza

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 12 sty 2022, o 22:37 
Offline
Nowy

Dołączył(a): 22 sie 2018
Posty: 23
Pomógł: 0

mirekk36 napisał(a):
to nie jest żadna dziwna przerwa tylko przekręcenie się pętli w asm żeby móc wysyłać kolejny bajt i w niczym nie przeszkadza

Czyli czasy są okej?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 12 sty 2022, o 22:43 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 26686
Lokalizacja: Szczecin
Pomógł: 1022

wyglądają na OK
może masz pierwszą diodę UWALONĄ

podłącz się do drugiej

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 12 ] 

Strefa czasowa: UTC + 1


Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 1 gość


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
cron
Sitemap
Technologię dostarcza phpBB® Forum Software © phpBB Group phpBB3.PL
phpBB SEO