Kanał - ATNEL tech-forum
Wszystkie działy
Najnowsze wątki



Teraz jest 23 paź 2021, o 18:54


Strefa czasowa: UTC + 1





Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 26 ] 
Autor Wiadomość
PostNapisane: 23 sie 2021, o 22:05 
Offline
Nowy

Dołączył(a): 23 sie 2021
Posty: 14
Pomógł: 0

Dzień dobry
Prosiłbym o informację czy robię coś bardzo źle :)?
Posługuję się bluebookiem zakupionym w sklepie oraz ATB Ethernet też zakupionym w sklepie Atnel i walczę z postawieniem serwera na Atmega128 i 32.

Mam standardową płytkę ATMEGA128 z ze złączem ISP
https://www.futurlec.com/ATMEGA_Controller.shtml

Mam też standardową płytkę testową ze złączem ISP firmy AndTech
https://www.tme.eu/pl/details/evb5.1-at ... -atmega32/

I standardowy programator USBasp - bez problemu programuje nim wymienione wyżej płytki ze środowiska Eclipse.

I teraz gdy wkładam ATB Ethernet w złącze ISP zarówno na płytce Atmega32 jak i Atmega128 (tak jak na obrazku w firmie Atnel) i podpinam programator do ATB Ethernet to wywala mi błąd przy programowaniu. Zasilanie świeci poprawnie.

Obrazek

"Programer USBasp could not initialize the target software.

1)Wiem o tym, że pin nr.4 powinien być podpięte do SS i pin 3 do INT1 (Ethernet złącze ISP - zgodnie z bluebook), ale tak też próbowałem robiąc to na kabelkach i też nie idzie na obu płytkach - ale wydaje mi się, że do programowania te piny nie są potrzebne, tylko do samej pracy modułu Ethernet

2)Czy ja coś robię bardzo dziwnie :)? Czy to może wina programatora?

Pozdrowienia dla Pana Mirka z synem i zespołem i wszystkich męczących się po nocach z kabelkami :)))
Piotr Matys
p.matys@ideaton.pl



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 23 sie 2021, o 23:34 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 26550
Lokalizacja: Szczecin
Pomógł: 1018

Tak jak w Bluebooku ten dodatkowy pin to tylko SS(CS). A poza tym to proponuję spraawdzić gdzie jest MASA (GND) w tych płytkach na złączu KANDA bo już o zgrozo nie raz się przekonałem, że nie ma jej na pinach 10 i 8

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 24 sie 2021, o 10:22 
Offline
Nowy

Dołączył(a): 23 sie 2021
Posty: 14
Pomógł: 0

Dzień dobry
Dziękuję bardzo za poradę. Masa na obu płytkach była w porządku. Okazało się, że to stykologia. Za 20 próbą w końcu kabelki ułożyły się jakoś innaczej i działa. Zrobię innaczej to połączenie i powinno być ok.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 24 sie 2021, o 18:38 
Offline
Nowy

Dołączył(a): 23 sie 2021
Posty: 14
Pomógł: 0

Witam raz jeszcze
Przedstawię co wydarzyło się od ostatniego razu
0) Masy na złączu Kanda posprawdzane, jest poprawnie

1)udało się podłączyć Atmegę32 do stabilnego połączenia z programatorem za pomocą takiego szalonego przewodu
Obrazek
Na tym kablu przechodzi wgrywanie wsadu z Eclipsa, wykłada się na weryfikacji w tymże procesie

2)Zrobiłem kabelki bardziej ludzkie dla Atmega32 i atmega128
Obrazek
Obrazek

Na nich w ogóle nie działa wgrywanie :!: , podłączyłem piny CS i INT zgodnie z opisem na zdjęciach

3)zaprogramowałem zatem Atmege32 zgodnie z bluebook (serwer HTTP) normalnie przez ISP (wyjąłem ATB Ethernet, a potem włożyłem z powrotem). Ustawiłem odpowiednie IP w kodzie programu serwera zgodnie z tym co przydziela mój router (np. mój komputer ma 192.168.1.14 to dałem płytce Atmega 192.168.1.16).

Po podłączeniu do routera lampki na złaczu sieciowym ATB Ethernet ładnie migają, ale nie da się wejść przez przeglądarkę na 192.168.1.16. Po wejsciu na stronę www routera widać, że router nie widzi mojego urządzonka, natomast mój komputer elegancko tak.

I tu utknałem całkowicie!!!!!!!!
Panie Mirku pomocy!!! Może ja wyślę do Pana moje obie sztuki ATB Ethernet, moje płytki Atmega32 i Atmega128, mój programator. Jak tam coś nie styka, to może Pan wsadzi tą jedną moją ATB Ethernet w Pana płytkę testową Atnel ATB. I jak tam pójdzie ten serwer HTTP oraz da się ją programować przez złącze ATB Ethernet to kupię tą płytkę Atnel ATB u Pana w sklepie?
Chyba, że Pan ma jakieś inne propozycję mądrzejsze niż moja :)))).

Pozdrawiam
Piotr Matys



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 24 sie 2021, o 19:45 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 26550
Lokalizacja: Szczecin
Pomógł: 1018

Nie wiem za bardzo co odpisać i co poradzić bo kolega - hmmm pewnie z nerwów, podaje pełno sprzecznych ze sobą informacji. Najpierw że działa programowanie, później że nie działa w ogóle programowanie na tych bardziej ludzkich kabelkach a po chwili że kolega wgrał kod z Bluebooka - no to jak to z tym jest w końcu.

Poza tym proponuję się skupić na JEDNYM a nie chwytać w takiej sytuacji 300 srok za ogon, bo i ATmega32 i do tego ATmega128 na jakiejś przedziwnej płytce .. i co atmega128 też się zaprogramowała czy nie ?

---------------------------

Proponuję najpierw doprowadzić jedną rzecz do porządku czyli SAMO WGRYWANIE wsadu, dać sobie spokój na razie z tymi kabelkami CS i INT - zostaw je Pan na razie na boku i sprawdź czy w 100% działa wgrywanie wsadu i to z pełną weryfikacją. I nie chcę słyszeć o atmedze128 na tym etapie bo ją możesz Pan w ogóle źle podłączać (i obstawiam na 100% że z m128 właśnie tak jest) a nie będziemy rozwiązywali 100 problemów naraz ok? ;)

czekam zatem na info z doprowadzeniem wgrywania wsadów. A TYM BARDZIEJ nie rozumiem tego całego zamieszania i robienia dziwnych kabelków - jakby nie można było NAJPIERW po prostu wgrać normalnie wsad z Bluebooka - i jak już jest wgrany to wtedy sobie podłączać te dodatkowe sygnały - w czym problem? Po co się upierać i robić to na czas programowania gdy nic nie działa.

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 25 sie 2021, o 09:18 
Offline
Nowy

Dołączył(a): 23 sie 2021
Posty: 14
Pomógł: 0

Dzień dobry
Dziękuję bardzo za odpowiedź :).
Opis samego wgrywania:
1)jak podłączam programator bezpośrednio do złącza ISP na płytce Atmega128 i Atmega32 to wgrywa bezproblemu całość wsadu z weryfikacją
2)jak podłączam programator do złącza ISP na płytce ATB Ethernet, a płytke ATB Ethenet wkładam w złącze ISP na Atmega128 i Atmega32 to nie działa wgrywanie wsadu
3)jak były te moje dziwne kabelki to udawało się wgrać wsad, ale nie przechodziło weryfikacji. Przy czym samo wgrywanie wsadu nie działo to za każdym razem, musiałem wręcz kabelki trzymać w odpowiedniej pozycji.

A co do tego co Pan napisał na końcu :). Ja dokładnie tak zrobiłem po tym wszystkim jak Pan sugeruje, zeby zrobić: wgrałem wsad normalnie do procka, potem podłączyłem procek do ATB Ethenet, podłączyłem te dodatkowe linie. I nie działa wtedy ten serwer ATB Ethernet. Mi się wydaje, że to jest jakaś stykologia komiędzy ATB Ethenet, a moimi płytkami.....

Pozdrawiam
Piotr Matys



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 25 sie 2021, o 10:28 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 26550
Lokalizacja: Szczecin
Pomógł: 1018

No to się wyjaśniło, że masz przynajmniej poprawne wgrywanie wsadu, do m32 teraz można się skupić na tym dlaczego nie działa z ethernetem

Po pierwsze czy po podaniu zasilania na sam moduł ETHERNET nawet nie podłączony do procka, i podłączeniu kabla ethernet migają czasem obie diodki LED w gniazdku ethernet ?

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 25 sie 2021, o 11:04 
Offline
Nowy

Dołączył(a): 23 sie 2021
Posty: 14
Pomógł: 0

Dzień dobry
Tak, migają. Zielona świeci ciągle, a pomarańczowa miga co jakiś czas.

Pozdrawiam :), idziemy do przodu :)



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 25 sie 2021, o 11:13 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 26550
Lokalizacja: Szczecin
Pomógł: 1018

dobra czyli część PHY modułu ethernet jest sprawna w 100% - to ważne, jest OK.

W takim razie kolejny krok to połączenia z prockiem - skupmy się na m32, na razie m128 nas w ogóle nie interesuje i proszę nie pisz o m128 na razie ok ? żeby nie mieszać.

A zatem - połączenia m32 z atbe ethernet są proste jak koci drut, toż to czysta magistrala SPI, i wykorzystuje ona sygnały ISP przy okazji bo są te same w m32, (a w m128 są inne panie kochany dlatego mówię, że nie gadajmy na razie o m128)

Masz zatem linie: MOSI, MISO, SCK - współdzielone z liniami ISP - sprawdź je - przedzwoń czy mają styk piny np na module eth bezpośrednio z pinami procka

Dodatkowo są tylko dwie linie: CS (Chip Select) i wyjście INT z eth które trzeba podłączyć do wejścia INTx ... no właśnie - zajrzałeś do kodu do książki do którego wejścia? INT0? INT1? czy INT2 w m32 ?

to opisz dokładnie właśnie co do czego podłączasz

i ostatnia rzecz - pokaż fragment kodu w którym ustawiłeś swój adres IP. Tylko - ty ustawiasz w sumie sąsiedni adres IP obok swojego kompa załóżmy, czyli zapewne trafiasz w przestrzeń działania DHCP swojego routera - a ja nie wiem czy np twój router nie przydzielił tego adresu jakiemuś innemu urządzeniu, np dla telefonu domownika itp. Weź sprawdź jaki zakres ma DHCP i jeśli jest on np 1-100 to daj końcówkę np 220 a nie 16

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 26 sie 2021, o 12:25 
Offline
Nowy

Dołączył(a): 23 sie 2021
Posty: 14
Pomógł: 0

Dzień dobry
1)Działa serwer na Atmega32!!!!
2)Działa programowanie na po wtyknięciu programatora w ATB Ethernet
Teraz opiszę skąd wynikał problem, może innym się przyda:

Sprawdziłem stykologie lini MOSI, MISO itd po kolei z nóżkami procesora. Wszystko było ok, poza nóżką CS. Nie stykała do PB4. Okazało się, że na złączu ISP moich obu płytek pin4 podłączony jest do masy więc CS tak zwierało mi do masy. Wylutowałem zatem ten Pin4 ze złącza KAnda na mojej płytce, aby nie było połączenia z masą tylko z PB4 (dolutowałem osobno).

Dziękuję bardzo za naprowadzenie mnie Panie Mirku. Teraz przejdę do Atmega128. Dzięki wielkie!!

Mam też takie pytanko:
Czy da się zrobić aby wejść na to 192.168.1.18 z zewnątrz, spoza mojej lokalnej sieci?

Pozdrawiam
Piotr Matys



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 26 sie 2021, o 14:21 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 26550
Lokalizacja: Szczecin
Pomógł: 1018

Piotr123 napisał(a):
Czy da się zrobić aby wejść na to 192.168.1.18 z zewnątrz, spoza mojej lokalnej sieci?

Oczywiście, że się da - i to jest proste o ile ktoś zna się na konfigurowaniu swojego routera.

W najprostszym wypadku wystarczy ustawić DMZ (Demilitaryzed Zone) dla tego adresu IP i już - router wystawi go w całości poza NAT

W innym przypadku można wystawić na zewnątrz tylko wybrany port TCP albo UDP jeśli będziesz korzystał również z drugiego przykładu z Bluebooka gdzie pokazuję komunikację po UDP

No i oczywiście oba te sposoby udadzą się tobie o ile masz internet od takiego dostawcy co na zewnątrz nie ma NAT'a ;) Bo jak np masz internet przez kartę SIM od jakiegoś operatora to ni hu hu - żadna opcja ci nie pomoże, ale jak masz np Neostradę to będziesz miał jakiś stały aczkolwiek dynamicznie przydzielany adres IP a to już pozwoli dobijać się z dowolnego miejsca na świecie do twojej atmegi32

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 31 sie 2021, o 09:43 
Offline
Nowy

Dołączył(a): 23 sie 2021
Posty: 14
Pomógł: 0

Dzień dobry
Bardzo dziękuję Panie Mirku za poprzednią podpowiedź. Jestem już parę kroków dalej, czyli na zagadnieniu wyświetlenia zawartości zmiennej na serwerze.
To ten sam problem co w wątku:

post114633.html?hilit=ATB%20ethernet%20serwer#p114633

Tylko tam nie zostało to chyba do końca rozwiązane, albo ja czegoś nie rozumiem.
Tak jak kolegom z wątku po wpisaniu przy wypisywaniu na serwer pojawiają mi się te znaczki w postaci np:


а‰+ р!а‚/•““П“Я“м‹АЊб”$Ѓя АЂиoб@и”ИЂкoб@и”ИЂаoᔶѓэлП‚а`а”.ѓаjб”.†аl/”.ћ P6N‡аc/”.Љз`а@а”ИОё”мЂиoбHа”ИЯ‘П‘‘‘•‰г”$ЃЃа•Џ’џ’Ї’ї’П’Я’п’я’““П“Я“\K‰г”$€#фАаРаpА


Próbuje tak jak koledzy czyli np:

Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.


Próbowałem to w różnych odmianach i ciągle te szlaczki. Czy ktoś może pomóc?

Pozdrawiam
Piotr Matys



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 31 sie 2021, o 10:29 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 26550
Lokalizacja: Szczecin
Pomógł: 1018

Najpierw zrób przykłady z książki bo one działają

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 31 sie 2021, o 23:32 
Offline
Nowy

Dołączył(a): 23 sie 2021
Posty: 14
Pomógł: 0

Dzień dobry
Ma Pan na myśli przykłady z rozdziału "Sterownik urządzeń - protokół UDP"?
Bo rozdział "serwer Http" już przerobiłem i tam czegoś takiego nie spotkałem...

Pozdrawiam
Piotr Matys



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 31 sie 2021, o 23:53 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 26550
Lokalizacja: Szczecin
Pomógł: 1018

Cytuj:
Bo rozdział "serwer Http" już przerobiłem i tam czegoś takiego nie spotkałem...

No to skąd ty wziąłeś ten fragment kodu który wyżej pokazałeś ? Umieść zawartość swojego pliku main a w zasadzie tylko funkcję main() w której coś rzeźbisz - bo ewidentnie coś źle robisz ale co ? Skąd można wiedzieć - trzeba byłoby być jasnowidzem.

A kolejny rozdział jest jak sama nazwa wskazuje o UDP a nie TCP i HTTP

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 wrz 2021, o 12:28 
Offline
Nowy

Dołączył(a): 23 sie 2021
Posty: 14
Pomógł: 0

Dzień dobry
Bardzo dziękuje za chęć udzielenia pomocy spragnionemu wiedzy człowiekowi :).
Generalnie usiłuję wyświetlić liczbę uint8_t temp1=22 na ekran przez przeglądarkę w sieci lokalnej.

Wyswietla mi coś takiego:
Obrazek


Poniżej cały kod z bluebooka do serwera Http "Basic_web_server_example". Zaznaczyłem miejsce gdzie rzeźbie, to jest funkcja w której mieszam prosto z bluebook:

Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.


A to poniżej jest natomiast cały kod pliku "basic_web_server_example" z bluebooka - robię tam dodatkowo opcję programowania zdalnego przez moduł wifi Pana Mirka oraz jest tam zamieszczone ciało funkcji int_to_str z bluebooka.

Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.


Bardzo proszę o pomoc, bo mi te krzaczki wyświetla...dokładnie tak jak na forum tutaj:
post114633.html?hilit=ATB%20ethernet%20serwer#p114633

Pozdrawiam serdecznie
Piotr Matys



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 wrz 2021, o 14:26 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 26550
Lokalizacja: Szczecin
Pomógł: 1018

Przecież w liniach 92-95 masz przykład jak coś wysłać - ja nie wiem co ty robisz ? Nic z tego kodu nie wynika.

Dlatego mówiłem, zrób najpierw tak jak jest w książce i zobacz czy ci się wyświetla to co widzisz w tych liniach - a później sobie je zmodyfikuj a nie jakby hmmm wymyślasz jakieś kawałki własnego kodu oderwane w ogóle od tego co w książce.

Pokaż tę funkcję wysyłającą dane jak zamieniłeś teksty oryginalne z przykładu na swoje teksty ale bez dodawania żadnych nowych linii własnego kodu - na początek

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 3 wrz 2021, o 08:56 
Offline
Nowy

Dołączył(a): 23 sie 2021
Posty: 14
Pomógł: 0

Dzień dobry
Dziękuję bardzo za odpowiedź :)
No moje dwie funkcje wysyłające były w liniach 98 i 101 w poscie gdzie wklejałem kod. Ta z 98 była wykomentowana bo też nie działała :), próbowałem obie i jeszcze z 10 innych :).

Ja robiłem to co książce w rozdziale o serwerze. Z tym nie ma problemu, wyświetlało mi ok wszystko, zmieniałem sobie teksty, wstawiałem swoje zdjęcia, było ok. Ale w książce nie znalazłem przykładu jak wyświetlić na serwerze liczbę ze zmiennej.

A samego ciała funkcji fill_tcp_data_p nie zmieniałem w ogóle (jest prosto z maila od Pana :) z pliku ip_arp_udp_tcp.c a cały projekt nazywa się 20_ETH_server_www), zamieszczam ją orginalnie

Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.


Pozdrawiam
Piotr Matys



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 3 wrz 2021, o 11:50 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 26550
Lokalizacja: Szczecin
Pomógł: 1018

Piotr123 napisał(a):
A samego ciała funkcji fill_tcp_data_p nie zmieniałem w ogóle (jest prosto z maila od Pana z pliku ip_arp_udp_tcp.c a cały projekt nazywa się 20_ETH_server_www), zamieszczam ją orginalnie

Zobacz, że sam sobie mieszasz i to mocno, bo wyżej umieściłes fragment kodu w którym użyta jest funkcja

Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.


a nie

Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.


tak jak pokazałeś w ostatnim mailu a to jest OGROMNA różnica, wiesz dlaczego ? i czym róznią się obie funkcje ? Od tego zacznij

Po drugie skoro mówisz że przykład z książki ci działa czyli możesz wyświetlać stringi, przykładowa linijka z książki:

Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.


no to jak możesz mówić teraz, że nie wiesz jak liczbę wyświetlić ? że to nie zostało pokazane w książce. No na prawdę ... poćwicz jednak wcześniejsze wszystkie lekcje bo tak to daleko niestety, przykro mi ale daleko nie zajedziesz - jak będziesz próbował działać NA CZUJA bez zrozumienia co robisz. A w książce masz wcześniej przed tym rozdziałem pierdyliard przykładów jak zamieniać sobie liczbę na stringa, przecież. Więc jak możesz pisać, że tu nie pokazano jak wyświetlić liczbę - zawsze tak samo:

Bardzo cię proszę - zanim pójdziesz dalej, zajrzyj czy to do przykładu o UART w książce czy o LCD żeby zobaczyć jak się wyświetla liczby bo to zawsze ten sam sposób. A jako uzupełnienie - TERAZ koniecznie obejrzyj ten poradnik wideo żebyś zrozumiał podstawy:


_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 8 wrz 2021, o 18:07 
Offline
Nowy

Dołączył(a): 23 sie 2021
Posty: 14
Pomógł: 0

Dzień dobry
Bardzo dziękuję za naprowadzenie mnie, będę z tym walczył, tylko chwilowo brak czasu, jak tylko pójdzie to to napiszę :)

Pozdrawiam
Piotr Matys



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 30 wrz 2021, o 22:40 
Offline
Nowy

Dołączył(a): 23 sie 2021
Posty: 14
Pomógł: 0

Dzień dobry
No i poszło, bardzo dziękuję Panie Mirku za naprowadzenie mnie :).
Bardzo się cieszę z tego nowego ATNEL ESP-01m4, który mam nadzieję pojawi się w sklepie!!!!!!!

Pozdrawiam
Piotr Matys



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 1 paź 2021, o 00:05 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 26550
Lokalizacja: Szczecin
Pomógł: 1018

Piotr123 napisał(a):
Bardzo się cieszę z tego nowego ATNEL ESP-01m4, który mam nadzieję pojawi się w sklepie!!!!!!!

Na pewno się pojawi ;)

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 8 paź 2021, o 23:06 
Offline
Nowy

Dołączył(a): 23 sie 2021
Posty: 14
Pomógł: 0

Dzień dobry
Walczę teraz z automatycznym uaktualnianiem wartości z czujników na serwerze (bez odświeżania stronki). Czy ja dobrze myślę, że bibilotekę "MK_USART/mkuart.h" kupuje się razem z Green Bookiem"? Tak czy siak chciałem kupić Pana Green Booka ale upewniam się tylko, że tam będzie ta biblioteka? Czy jakoś innaczej mam ją kupić bo w sklepie jej nie widziałem?

Pozdrawiam serdecznie
Piotr



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 8 paź 2021, o 23:38 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 26550
Lokalizacja: Szczecin
Pomógł: 1018

W GB jest taka podstawowa wersja tej biblioteki - pisana tylko na UART0 i do celów dydaktycznych - z opisem tworzenia - żeby zrozumieć o co CHODZI. Natomiast dużo później niż książka GB ukazała się dość duża i porządna biblioteka Mk_MULITI_UART 2.0 oraz MK_MULTI_UART 2.0 AT (ta druga z super obsługą od razu komend AT) . Co ważne obie wersje biblioteki zawierają już PEŁNĄ obsługę komunikacji binarnej po uart i to z timeoutami - co nigdy nie było omawiane w żadnej książce. Dziwię się, że nie mogłeś znaleźć w sklepie skoro są te biblioteki w dziale oprogramowanie i biblioteki właśnie

Obrazek


tu biblioteki o których piszę tylko na drugiej stronie (trzeba na dole przełączyć stronę)
Obrazek

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 9 paź 2021, o 19:19 
Offline
Nowy

Dołączył(a): 23 sie 2021
Posty: 14
Pomógł: 0

Dzień dobry
Dzięki, widziałem je już dawno i wczoraj też tylko nie byłem pewny czy to to, czego potrzebuje. W Pana programie ATB WIFI config używam w tools narzędzia html2c converter i on po skonwertowaniu zalacza bibliotękę której nie mam, czyli MK_USART/mkuart.h. Rozumiem, że to ta :) i kupuję w takim razie tą Mk_MULITI_UART 2.0.

PS. Super Pan to barwnie prowadzi, zawsze żonie opowiadam i nawet moje 6-letnie dziecko już Pana doskonale kojarzy na tym koniu z Bonanzy :).
Pozdrawiam
Piotr



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 9 paź 2021, o 22:29 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 26550
Lokalizacja: Szczecin
Pomógł: 1018

Piotr123 napisał(a):
i nawet moje 6-letnie dziecko już Pana doskonale kojarzy na tym koniu z Bonanzy

hahahaha jak sobie przypomnę jak ten film kręciliśmy ;) kilka razy paliliśmy schemat - a w rękach trzymałem pasek od torby od laptopa - pomimo to - wygląda to jakbym w rzeczywistości na Quniu jechał :lol:

https://youtu.be/EwBJU6M1QW0?t=12

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 26 ] 

Strefa czasowa: UTC + 1


Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 0 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
Sitemap
Technologię dostarcza phpBB® Forum Software © phpBB Group phpBB3.PL
phpBB SEO