Kanał - ATNEL tech-forum
Wszystkie działy
Najnowsze wątki



Teraz jest 23 sty 2021, o 06:03


Strefa czasowa: UTC + 1





Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 4 ] 
Autor Wiadomość
PostNapisane: 13 sty 2021, o 17:03 
Offline
Nowy

Dołączył(a): 13 maja 2020
Posty: 2
Pomógł: 0

Jest to pierwszy mój post na tym forum.

Witam serdecznie wszystkich użytkowników i nie tylko.

Do rzeczy.

Jakiś czas temu nabyłem Oled z sterownikiem SSD1327, 128x128 .

Oczywiście znalazła się też biblioteka do Arduino , Oled sprawdzony działa.

Jak wiemy biblioteki Arduino są tak napisane żeby działały prawie ze wszystkim,
przez co są ogromne i zużywają zasoby.

Postanowiłem zrobić własną.



Szybkie przeszukanie internetu celem znalezienia pomocnych materiałów.
Znalazłem serie poradników Pana Mirka na temat Oled.

Wczoraj napisałem zarys biblioteki. Wyświetlacz udało mi się zainicjalizować i przesłać do niego obraz z bufora.

Jednak powstał problem ponieważ obraz powinien wypełnić cały ekran a wyświetla się, coś takiego.

Obrazek


Spędziłem nad tym wczoraj kilka godzin i nie wiem o co chodzi.

Prosiłbym co bardziej doświadczone osoby o rzucenie okiem i wskazanie mi błędu.

plik.h
Składnia: [ Pobierz ] [ Ukryj ]
język cpp
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.


plik.cpp
Składnia: [ Pobierz ] [ Ukryj ]
język cpp
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.


Nadmienię tylko że tak do kompilacji używam Arduino IDE.


Poz.

Jeżeli post jest napisany w złym dziale to proszę o przeniesienie.


Załączniki:

Aby zobaczyć załączniki musisz się zalogować. Tylko zalogowani użytkownicy mogą oglądać i pobierać załączniki.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 13 sty 2021, o 17:20 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 06 mar 2015
Posty: 142
Pomógł: 6

Przecież to co wyświetlasz na ekranie, to masz zapisane w tej tablicy uint8_t ssd1327_buf[2048]=...
Stwórz swoją tablicę i zobaczysz efekty.

_________________
http://www.avrboss.pl



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 13 sty 2021, o 23:02 
Offline
Nowy

Dołączył(a): 13 maja 2020
Posty: 2
Pomógł: 0

Dzięki za odp Mario

Ta tablica jest moja, jest w niej zapisane logo 128x128 i w teorri zakładłem że wyswietli się w całość

A jak widać ekran został podzielony 4x4

Ten oled jest zupełnie inny od ssd1306

dopisałem funkcję na wyświetlanie pixela

Sprawa wygląda teraz tak że
włączamy pixel
x0,y0 jest ok
x0,y1 jest x0,y3
x0,y63 jest ok
x0,y64 jest przepisany do następnej linii na x0,y1 itd:

czyli w rzeczywistość włącza się co 2 pixel w osi x
Ale takwynika z datasheet

problem polega na tym że nie wiem czemu ale

oled zostaje podzielony na 4 w osi Y

i po włączeniu pixela

x0,y0

włączają się pixele

x0,y32
x0,y64
x0,y96

nie mogę się doczytać dlaczego tak się dzieje



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 14 sty 2021, o 00:40 
Offline
Nowy
Avatar użytkownika

Dołączył(a): 05 lut 2015
Posty: 22
Pomógł: 1

Zajrzyj na blog https://msalamon.pl/oled-ze-skala-szarosci-na-ssd1327-cz-1/. Tam jest kilka zdań nt. tego sterownika. Sam kod jest pisany pod STM32, ale autor korzystał z biblioteki na Arduino.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 4 ] 

Strefa czasowa: UTC + 1


Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 0 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
Sitemap
Technologię dostarcza phpBB® Forum Software © phpBB Group phpBB3.PL
phpBB SEO