Kanał - ATNEL tech-forum
Wszystkie działy
Najnowsze wątki



Teraz jest 16 cze 2021, o 09:03


Strefa czasowa: UTC + 1





Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 29 ] 
Autor Wiadomość
PostNapisane: 25 lis 2020, o 22:41 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 26405
Lokalizacja: Szczecin
Pomógł: 1003

Może warto zobaczyć o co tu chodzi ? Wiem wiem - już wszystko wiadomo ale pomimo to - zapraszam ;)

Obrazek

Po przeczytaniu opisu na blogu dajcie proszę tutaj znać - co o tym myślicie ?

Nie ważne czy źle czy dobrze - za KAŻDE cenne i uzasadnione uwagi będę wdzięczny !

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 25 lis 2020, o 23:47 
Offline
Użytkownik

Dołączył(a): 25 lip 2013
Posty: 2406
Pomógł: 118

Super! Już nie mogę się doczekać.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 26 lis 2020, o 01:13 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 28 lis 2012
Posty: 278
Lokalizacja: Warszawa
Pomógł: 17

Działa i pomaga, szczególnie jak co chwilę zmieniasz kod. Robi robotę! SZACUN!!! :D
Mała rzecz, a tak cieszy :lol:

_________________
Pozdrawiam
Grzegorz



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 26 lis 2020, o 01:16 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 26405
Lokalizacja: Szczecin
Pomógł: 1003

buz11 napisał(a):
Działa i pomaga, szczególnie jak co chwilę zmieniasz kod. Robi robotę! SZACUN!!! :D
Mała rzecz, a tak cieszy :lol:


Ślicznie dziękuję za opinię z takich wstępnych testów ... Pozdrawiam

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 26 lis 2020, o 09:59 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 28 lis 2011
Posty: 155
Pomógł: 12

Bardzo fajny programik jak zwykle a kiedy można się spodziewać płytek i czy same programatory tez będzie można nabyć .



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 26 lis 2020, o 10:18 
Offline
Nowy
Avatar użytkownika

Dołączył(a): 05 lut 2015
Posty: 22
Pomógł: 1

Pobrałem, udało się bezproblemowo zintegrować z STMCubeIDE. Pierwsze wrażenie pozytywne.

Mam pytanie, czy (a raczej od kiedy) ATB STM SHIELD + ATNEL ST-Link v.2 będzie dostępny w sklepie?

I jeszcze pytanie z innej beczki (przepraszam, że w tym wątku), czy ruszyła już wysyłka papierowej wersji Orangebook'a?

Pozdrawiam



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 26 lis 2020, o 11:04 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 26405
Lokalizacja: Szczecin
Pomógł: 1003

gufim napisał(a):
a kiedy można się spodziewać płytek i czy same programatory tez będzie można nabyć .


roger napisał(a):
czy (a raczej od kiedy) ATB STM SHIELD + ATNEL ST-Link v.2 będzie dostępny w sklepie?


Tak jak wspominałem trzeba troszkę jeszcze poczekać, i chyba zorganizujemy akcję - zbiórkę na ich ew produkcję jeśli się zbierze odpowiednia liczba osób. Bo jak się spodziewacie, (a może nie) ... cena niestety nie będzie mogła być na poziomie takich płytek nukeo, discovery itp - które są produkowane w Chinach w milionach egzemplarzy. Cena raczej będzie w okolicach naszych obecnych modułów ATB CAN SHIELD z prockiem AT90CAN128, czyli sporo wyższa od nukleo.

Ale jeśli się zrobi zbiórkę chętnych i zbierze się odpowiednia liczba chętnych - to będzie można to potraktować tak jak projekty na PolakPotrafi i wtedy pewnie udałoby się nam obniżyć koszty i sporą część marży - jak dla inwestorów. Ale to damy znać - tylko jeszcze musimy porobić parę testów i przygotować fajną dokumentację całej pinologii - zworkologii na takim szildzie, żeby wygodnie można było działać.

Takie szildy w razie czego będą sprzedawane bez WLUTOWANYCH tych skierowanych w dół gniazd żeńskich - którymi się wtyka szilda w zestaw ATB, ale same gniazda luzem będziemy dodawać, no chyba że ktoś zaznaczy, że chciałby mieć wlutowane to wtedy już u nas będziemy je wlutowywać jak gotowe moduły przyjdą z fabryki. Dlaczego tak? Ano dlatego że SZILD musi działać wg naszych założeń nawet samodzielnie bez zestawu ATB w 100% (jeśli ktoś nie ma zestawu) i to już osiągnęliśmy ... wtedy będzie można sobie wlutować w te miejsca normalne pionowe goldpiny od góry - jak inne pozostałe.

Na 100% nie będzie samych programatorów luzem w sprzedaży - dlaczego? Dlatego, że one są podłączone teraz do krwioobiegu SZILDA nie tylko liniami SWD , nie tylko liniami UART ale jeszcze jest linia SWD i nRST dzięki czemu nie trzeba KABELKAMI nic łączyć - super wygoda użytkowania.

A jak ktoś będzie chciał mieć sam programator - to co za problem go odłamać , lekko pilniczkiem podziałać żeby nie było zadziorków - i nadal będzie można go stosować do szilda i do innych rzeczy tyle że już za pomocą kabelków jak coś ;)

roger napisał(a):
I jeszcze pytanie z innej beczki (przepraszam, że w tym wątku), czy ruszyła już wysyłka papierowej wersji Orangebook'a?

Książki miały trafić do nas DZISIAJ z drukarni ale wczoraj zadzwonili że mają mini opóźnienie i dopiero DZISIAJ wysyłają do nas - więc nakład trafi do nas dopiero w ten piątek i rozpoczynamy wysyłki w końcu ;)

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 26 lis 2020, o 21:07 
Offline
Użytkownik

Dołączył(a): 13 paź 2015
Posty: 264
Lokalizacja: Rybnik
Pomógł: 9

No No, już się doczekać nie mogę tego shielda.
A tak z innej beczki to pisze Pan kody źródłowe dla ARM na rejestrach czy z użyciem jakiejś biblioteki np. HAL lub innej?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 27 lis 2020, o 00:26 
Offline
Użytkownik

Dołączył(a): 05 sty 2015
Posty: 353
Lokalizacja: Mielec
Pomógł: 14

Witam.

Mirku u mnie coś takiego się dzieje, że przy pierwszym uruchomieniu programiku, ładują się same 2 foldery (jak na foto), później muszę odpalić jeszcze raz instalator i dopiero wtedy
"wkłada" do głównego folderu plik exe i dll,
później za każdym razem kiedy uruchamiam program to "wypluwa" komunikat o tym czy chce utworzyć workspace, nawet jeśli wskażę jakiś pusty folder.
Nie mam eclipsa pod STM jeszcze, ani utworzonego workspace przez eclipsa <-- może to jest powodem takiego zachowania MkSTM32prog?

system Win10Pro64

ObrazekObrazekObrazekObrazek

.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 27 lis 2020, o 04:51 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 26405
Lokalizacja: Szczecin
Pomógł: 1003

Szofer napisał(a):
Mirku u mnie coś takiego się dzieje, że przy pierwszym uruchomieniu programiku, ładują się same 2 foldery (jak na foto), później muszę odpalić jeszcze raz instalator i dopiero wtedy
"wkłada" do głównego folderu plik exe i dll,

No Qurczaki z tym mam jakiegoś BUG'a bo jesteś już drugą osobą u której się tak dzieje a ja nie umiem na razie zlokalizować problemu - ale będę walczył z tym jeszcze.

Odnośnie pytania o workspace to on nie pyta ciebie o ZAŁOŻENIE workspace tylko o to że nie skonfigurowano jeszcze żadnego workspace. I to jest normalne dlatego, że program powstał GŁÓWNIE po to aby działać z nim w STMCubeIDE czyli z tym eclipsem a nie w standalone tylko. Jak wskazujesz pusty folder to on widzi, że to żadne workspace i dlatego nie zapamiętuje że już raz to zrobiono.

------------------------ [ Dodano po: 1 minucie ]

Szofer napisał(a):
Mirku u mnie coś takiego się dzieje, że przy pierwszym uruchomieniu programiku, ładują się same 2 foldery (jak na foto), później muszę odpalić jeszcze raz instalator i dopiero wtedy
"wkłada" do głównego folderu plik exe i dll,


aaaa jeszcze jedno - POBIERZ proszę jeszcze raz instalkę ze strony atnel i sprawdź czy teraz też ci się tak dzieje ok? i daj znać proszę

------------------------ [ Dodano po: 36 minutach ]

ok nawet właśnie popełniłem nowszą poprawioną mocniej wersję - może już będzie poprawnie kopiował się sam tzn wszystkie potrzebne pliki

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 27 lis 2020, o 11:03 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 28 lis 2011
Posty: 155
Pomógł: 12

Cytuj:
Na 100% nie będzie samych programatorów luzem w sprzedaży - dlaczego? Dlatego, że one są podłączone teraz do krwioobiegu SZILDA nie tylko liniami SWD , nie tylko liniami UART ale jeszcze jest linia SWD i nRST dzięki czemu nie trzeba KABELKAMI nic łączyć - super wygoda użytkowania.


Szkoda że tak fajne narzędzie nie będzie dostępne jako osobny moduł :(



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 27 lis 2020, o 12:35 
Offline
Nowy

Dołączył(a): 09 paź 2020
Posty: 6
Pomógł: 1

Cytuj:
Szkoda że tak fajne narzędzie nie będzie dostępne jako osobny moduł


a po co? Możesz kupić sobie niedrogo oryginał ST-LINKa albo odłamać od Nucleo...



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 27 lis 2020, o 12:48 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 28 lis 2011
Posty: 155
Pomógł: 12

nick_czemnik napisał(a):
Cytuj:
Szkoda że tak fajne narzędzie nie będzie dostępne jako osobny moduł


a po co? Możesz kupić sobie niedrogo oryginał ST-LINKa albo odłamać od Nucleo...


Tak ale nie będzie to Atnel



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 27 lis 2020, o 14:09 
Offline
Nowy
Avatar użytkownika

Dołączył(a): 13 gru 2017
Posty: 7
Pomógł: 0

Szofer napisał(a):

Mirku u mnie coś takiego się dzieje, że przy pierwszym uruchomieniu programiku, ładują się same 2 foldery (jak na foto), później muszę odpalić jeszcze raz instalator i dopiero wtedy
"wkłada" do głównego folderu plik exe i dll,


Prawdopodobnie program antywirusowy wrzuca te pliki w kwarantannę i dlatego ich nie ma u mnie tak było po wyłączeniu programu antywirusowego działa prawidłowo.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 27 lis 2020, o 17:21 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 26405
Lokalizacja: Szczecin
Pomógł: 1003

wlodex napisał(a):
Szofer napisał(a):

Mirku u mnie coś takiego się dzieje, że przy pierwszym uruchomieniu programiku, ładują się same 2 foldery (jak na foto), później muszę odpalić jeszcze raz instalator i dopiero wtedy
"wkłada" do głównego folderu plik exe i dll,


Prawdopodobnie program antywirusowy wrzuca te pliki w kwarantannę i dlatego ich nie ma u mnie tak było po wyłączeniu programu antywirusowego działa prawidłowo.

Nie nie - już jest na to lekarstwo - pobierz najnowszą wersję 1.0.0.14 i daj znać czy teraz śmiga proszę, ok ? czekam na info.

------------------------ [ Dodano po: 1 minucie ]

gufim napisał(a):
nick_czemnik napisał(a):
Cytuj:
Szkoda że tak fajne narzędzie nie będzie dostępne jako osobny moduł


a po co? Możesz kupić sobie niedrogo oryginał ST-LINKa albo odłamać od Nucleo...


Tak ale nie będzie to Atnel


A na dodatek nasz ST-link jak wspominałem będzie miał ciekawego i to bardzo ciekawego FIUCZERA związanego z przyciskiem RESET i .... hmmmm (mały przeciek) REZUREKCJĄ ... ale nic więcej nie powiem ;) .... w porównaniu do oryginalnych ST-Linków - więc będzie i lepszy i mniejszy i jeszcze prawdopodobnie zrobimy obudowę 3D ;)

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 27 lis 2020, o 19:08 
Offline
Nowy

Dołączył(a): 30 sie 2014
Posty: 13
Pomógł: 0

Wykryłem mały błąd w STMCubeIDE korzystając z programu mirka.

Nie wszyscy wiedzą że można pogrupować sobie projekty według np. procka. klikamy w "projekt explorer" -> menu "select working set" klikamy "new" i wybieramy "resource" klikamy "next" i w "working set name" wpisujemy nazwe głównego katalogu i wybieramy które projekty będą w tym katalogu.

ObrazekObrazek

I tutaj pojawia się problem bo programik mirka kasuje główne katalogi i wszystkie projekty są widziane jako wszystkie.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 27 lis 2020, o 20:20 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 26405
Lokalizacja: Szczecin
Pomógł: 1003

Fakt nigdy nie korzystałem z "working set" ale

kisiel014 napisał(a):
I tutaj pojawia się problem bo programik mirka kasuje główne katalogi

No tu to chyba coś dziwnego kolega pisze. Mój program niczego nie kasuje w eclipse - żadnych plików a tym bardziej folderów.

Poza tym nic nie napisałeś kiedy on rzekomo kasuje? Przy integracji programu z Eclipse ? Wtedy tylko mój program dodaje własnego "Launchera" ew kasuje starego. A tak to nie DOTYKA nawet żadnych folderów czy plików żeby je kasować, przesuwać czy cokolwiek robić - więc kompletnie nie wiem o czym piszesz.

Ale też u ciebie jakoś inaczej wyglądają te hmmm nie wiem projekty ? czy ty masz w tym project explorerze same working sety ? Ja nawet nie umiem takiego stworzyć ;) a twój opis - hmmmm o tyle dziwny - chodzi mi o to:

kisiel014 napisał(a):
klikamy w "projekt explorer" -> menu "select working set" klikamy "new" i wybieramy "resource" klikamy "next" i w "working set name" wpisujemy nazwe głównego katalogu i wybieramy które projekty będą w tym katalogu.


Bo nie wiem co to u ciebie znaczy kliknąć w "project explorer" a później -> menu ... i jeszcze ciekawiej że później z menu wybieramy "select working set" ... gdzie to jest panie kochany ?

------------------------ [ Dodano po: kilkunastu sekundach ]

bo aż bym sprawdził te twoje dnoniesienia o rzekomym kasowaniu

------------------------ [ Dodano po: kilkunastu sekundach ]

a może ty nie używasz STMCubeIDE ? albo starszą wersję niż 1.4 ? A ja zacząłem od 1.4

------------------------ [ Dodano po: 3 minutach ]

U mnie dopiero gdzieś tutaj (jak na obrazku) jest to całe select ... i stworzyłem niby nawet jakiś workingset WSPÓLNE ale wcale nic mi się nie pojawiło w "Project Explorerze"

Obrazek

------------------------ [ Dodano po: 14 minutach ]

dobra udało mi się zrobić WIDOK tych working set'ów - proszę bardzo. I mogę bez mrugnięcia okiem wgrywać projekty za pomocą mojego programiku dokładnie tak samo jak wcześniej - klikając w ikonkę External Tools

oczywiście NIC nie jest kasowane - także niestety kompletnie nie wiem o czym kolega pisze

Obrazek

------------------------ [ Dodano po: 15 minutach ]

a przy okazji ;) fajne te working sety ;) Qurczę - że też wcześniej tego gdzieś nie podpatrzyłem ;)

ale może ty jeszcze coś innego robisz - to byś musiał bardzo dokładnie opisać krok po kroku jak ty tworzysz swoje working sety i dokładnie kiedy odczuwasz to rzekome kasowanie i dokładnie czego kasowanie

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 27 lis 2020, o 21:03 
Offline
Użytkownik

Dołączył(a): 05 sty 2015
Posty: 353
Lokalizacja: Mielec
Pomógł: 14

witam.
Mirku teraz u mnie już jest ok przy pierwszym uruchomieniu przekopiowało się wszystko,
pytanie o workspace przy pierwszym uruchomieniu anulowane i przy kolejnych juz to dodatkowe okienko nie wyskakuje,
ale z wersji 11 do 14 nie chciał się zrobić update, pobrałem ze strony i dopiero to dział.~

.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 27 lis 2020, o 21:20 
Offline
Nowy
Avatar użytkownika

Dołączył(a): 13 gru 2017
Posty: 7
Pomógł: 0

Witam wersja 1.0.0.14 działa poprawnie program antywirusowy nie kasuje plików.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 27 lis 2020, o 22:26 
Offline
Użytkownik

Dołączył(a): 08 mar 2014
Posty: 371
Lokalizacja: Głogów
Pomógł: 10

Świetne narzędzie, bardzo wygodne ale czy jest opcja z CubeIde wgrywania wsadu nie tą ikonką a jakimś skrótem klawiatury?
Np. w samym CubeIde kompilacje i debager można było uruchomić z klawiatury tj. F11.
Czy wgrywanie wsadu poprzez MkStMprog też będzie miało taką funkcję?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 27 lis 2020, o 22:46 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 15 lut 2017
Posty: 345
Lokalizacja: Gliwice
Pomógł: 30

Arek1111111111 napisał(a):
Czy wgrywanie wsadu poprzez MkStMprog też będzie miało taką funkcję?

To już przecież jest.
Należy przypisać skrót klawiaturowy dla "Runs the last launched external Tool" i będzie śmigać.
To jest magia Eclipse - narzędzie przemyślane do bólu, na wielu "płaszczyznach" :)



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 27 lis 2020, o 22:58 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 26405
Lokalizacja: Szczecin
Pomógł: 1003

Tak skróty klawiszowe to bezpośrednio w Eclipse można sobie poustawiać jak pisał Zelaota wyżej.

Panowie a możecie dać znać gdzieś na innych jeszcze forach gdzie bywacie - gdzie mowa o STM itp - i poprosić aby ludzie przetestowali ten programik - byłbym wdzięczny - bo im więcej osób przetestuje tym szybciej pozbędziemy się ew jeszcze jakichś błędów wieku dziecinnego w programie ;)

------------------------ [ Dodano po: 5 minutach ]

Wchodzisz w Window->Preferences i wybierasz po kolei jak są strzałki - na górze wpisujesz run last albo samo last i na dole gdzie strzałka w polu bindings klikasz sobie F11 a potem APPLY

Obrazek

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 28 lis 2020, o 11:14 
Offline
Nowy

Dołączył(a): 30 sie 2014
Posty: 13
Pomógł: 0

Mirku przepraszam może źle to opisałem. Oczywiście fizycznie nic nie usuwa z dysku, ja mam wszystko pogrupowane według poniższego zdjęcia i póki nie uruchomię jakieś kompilacji i wgrywania wszystko jest ok. A menu jest w tum miejscu:

Obrazek

Też mam wersje 1.5.0, a to się dzieje po ponownym uruchomieniu stm32cubeide i teraz już nie wiem czy to jest błąd tej wersji ty to od twojego programu.

Obrazek

A tak z twoim programikiem wgrywanie działa sto razy szybciej nie ma porównania. Super sprawa.

------------------------ [ Dodano po: 19 minutach ]

Ale fakt że przydałby się programator mirku twój, bo te chińskie to... a mam taki jeden z chin.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 28 lis 2020, o 11:56 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 26405
Lokalizacja: Szczecin
Pomógł: 1003

kisiel014 napisał(a):
Oczywiście fizycznie nic nie usuwa z dysku, ja mam wszystko pogrupowane według poniższego zdjęcia i póki nie uruchomię jakieś kompilacji i wgrywania wszystko jest ok. A menu jest w tum miejscu:

Tak tak - pisałem wyżej udało mi się znaleźć chociaż u mnie to nie trzy kropeczki tylko trójkącik w dół i spodobały mi się te workinkg sety ;) rewelacja.

Jak pisałem wyżej u mnie ładnie się wszystko wgrywa i working sety nie znikają .... ale sprawdzę dzisiaj na innym kompie i na wersji 1.5 bo wczoraj sprawdzałem na IDE 1.4

--------------------------------

Jeśli piszesz, że to się dzieje po ponownym uruchomieniu STMCubeIDE to sprawdź po prostu zwykłe wgrywanie - ale nie tym moim programem i wtedy uruchom ponownie IDE i sprawdź czy się nie rozwaliło ....

ale .... hmmm może się nie rozwala tylko trzeba po prostu od nowa włączyć w tym MENU widok tych working setów - bo tak można zrobić przecież w dowolnym momencie co też jest fajną opcją. Po tym teście będziesz wiedział czy ten widok znika od jendokrotnego zadziałania mojego programu czy zawsze u ciebie znika po restarcie.

Ja też zaraz sprawdzam.

Cieszę się, że programik się podoba ;)

tylko jak mówię - dajcie proszę znać na jakichś grupach fesjbokowych czy innych forach znać o tym programiku żeby więcej ludzi potestowało - to też będzie lepiej jak poprawki porobię i programik będzie śmigał też o wiele lepiej ok ?

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 28 lis 2020, o 14:39 
Offline
Użytkownik

Dołączył(a): 08 mar 2014
Posty: 371
Lokalizacja: Głogów
Pomógł: 10

Ślicznie dziękuje za pomoc z skrótami klawiaturowymi, Teraz jest super wygodnie.
Również jak koledzy pisali jest kilkakrotnie szybciej dzięki MkSTMprog :)



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 21 gru 2020, o 15:20 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 28 lis 2011
Posty: 155
Pomógł: 12

Witam a dalo by rade dorobic gdzies w ustawieniach zeby jak jest zaznaczony ptaszek auto close mozna bylo ustawic jak szybko ma sie zamknac naprzyklaf 500 ms 1 s 2 s



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 21 gru 2020, o 17:00 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 26405
Lokalizacja: Szczecin
Pomógł: 1003

gufim napisał(a):
Witam a dalo by rade dorobic gdzies w ustawieniach zeby jak jest zaznaczony ptaszek auto close mozna bylo ustawic jak szybko ma sie zamknac naprzyklaf 500 ms 1 s 2 s

Postaram się coś pomyśleć ;)

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 5 cze 2021, o 14:13 
Offline
Użytkownik

Dołączył(a): 13 paź 2015
Posty: 264
Lokalizacja: Rybnik
Pomógł: 9

Jak tam ST-LINK v2 od atnela? Zrezygnowano z tematu czy może po cichu powstaje książka? 8-)



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 5 cze 2021, o 14:27 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 26405
Lokalizacja: Szczecin
Pomógł: 1003

Tom92 napisał(a):
Jak tam ST-LINK v2 od atnela? Zrezygnowano z tematu czy może po cichu powstaje książka? 8-)

Nie nie - książka nie - ale nawet nie ma z czego wyprodukować naszych szildów czy programatorów - NIE MA PROCKÓW ARM/STM w sprzedaży :( totalna lipa

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 29 ] 

Strefa czasowa: UTC + 1


Kto przegląda forum

Użytkownicy przeglądający ten dział: Majestic-12 [Bot] i 2 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
Sitemap
Technologię dostarcza phpBB® Forum Software © phpBB Group phpBB3.PL
phpBB SEO