Kanał - ATNEL tech-forum
Wszystkie działy
Najnowsze wątki



Teraz jest 31 mar 2020, o 03:48


Strefa czasowa: UTC + 1





Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 14 ] 
Autor Wiadomość
PostNapisane: 1 sty 2019, o 20:23 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 25 mar 2013
Posty: 54
Pomógł: 0

Za każda zmiana z 0 na 1 dla parametrów kompilacji warunkowej w pliku konfiguracyjnym mk_gsm.h
dostaję błąd Symbol 'xxxx' could not be resolved
i wszystkie dotyczą definicji nazw zgromadzonych w tablicy atlist[] znajdującej się w pliku mk_atcmdlist.h


biorąc na przykład projekt 16 i chcą uruchomić male nie jestem wstanie tego zrobić
byłbym wdzięczny za pomoc



Ostatnio edytowano 2 sty 2019, o 13:36 przez tomasz1987, łącznie edytowano 1 raz

Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 sty 2019, o 01:31 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 25261
Lokalizacja: Szczecin
Pomógł: 951

to może pokaż dokładnie cały błąd z konsoli a nie oczekuj że ktoś się domyśli jaki on jest ?

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 sty 2019, o 10:25 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 25 mar 2013
Posty: 54
Pomógł: 0

Konsola wygląda ok I nie ma żadnych błędów
Co nie zmienia faktu że cała biblioteka
Mk_smtp.c ma błędy linkera
Wygląda to tak

Obrazek

Informacje o nim występują tylko w oknie Problems
Obrazek



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 sty 2019, o 10:55 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 25261
Lokalizacja: Szczecin
Pomógł: 951

Bo masz nieskonfigurowany do swoich potrzeb projekt po prostu. A robi się to za pomocą opcji w plikach nagłówkowych np w podstawowym mk_gsm.h

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 sty 2019, o 11:00 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 25 mar 2013
Posty: 54
Pomógł: 0

moja konfiguracja wygląda tak :
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.



proszę napisz co zrobiłem źle


używam :
Eclipse IDE for C/C++ Developers
Version: Mars.1 Release (4.5.1)
Build id: 20150924-1200



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 sty 2019, o 11:09 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 25261
Lokalizacja: Szczecin
Pomógł: 951

Chętnie bym pomógł ale nie wiem co ty źle zrobiłeś, skąd ja mogę znać twój projekt ? Jakich funkcjonalności z bibliotek używasz a jakich nie ? Poza tym nie miałbym pewnie czasu żeby nawet szczegółowo to analizować. Sam sobie możesz pomóc ... jak ? prosto

Po pierwsze odpal sobie oryginalny projekt z Pendrive (dowolny) i sprawdź czy się dobrze kompiluje a zobaczysz, że dobrze się kompiluje ... To po pierwsze.

Po drugie - jeśli wprowadzasz własne zmiany to obserwuj krok po kroku co się zmienia ...

i Po trzecie - masz Yellowbooka - to zajrzyj i poczytaj po kolei co i jak się konfiguruje, przecież opisuję też krok po najmniejszym kroczku cały spory projekt idąc od podstaw ...

--------------------

no chyba, że ci się oryginalny kod z Pendrive nie kompiluje poprawnie .... w co wątpię ale to napisz który

aha i jeszcze jedno - to co pokazujesz to nie są ŻADNE BŁĘDY kompilacji ... zawsze powtarzam z uporem maniaka - zaglądaj do zakładki CONSOLE a nie do Problems ... tyle że te nazwy typu _gts.... jak na szybko sprawdziłem to są właśnie opcje ale co robisz nie tak ? Nie mam pojęcia

mówię na początek skompiluj gotowy projekt z Pendrive bez żadnych zmian

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 sty 2019, o 11:13 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 25 mar 2013
Posty: 54
Pomógł: 0

to jest właśnie oryginalny projekt 14_ATB-MP-GSM
gdzie zmieniono tylko plik mk_gsm.h



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 sty 2019, o 13:35 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 25 mar 2013
Posty: 54
Pomógł: 0

Jak o "jakim linkeże piszes" ???
o taki m co podstawia wartość zamiast symbolu
projekt 14_ATB-MP-GSM po następującej zmianie
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.


w plikumk_gsm.h


w pliku mk_smtp.c występują błędy linkera wygląda to tak
Obrazek

a powinno :

Obrazek

dlatego że podczas kompilacji symbol _gtsmtpclr został odnaleziony na 18 miejscu w tablicy atlist[]
i linker wie co tam wstawić. //tu oczywiście co do schematu działania kompilatora mogę się mylić bo żaden ze mnie programista.
u mnie się tak nie dzieje

poprosiłem się o skompilowany projekt który rozwiąże mój problem
stwierdziłeś że nie masz czasu i napisałeś epopeję na temat zaglądania do książki
w której wcale nie opisujesz błędów linkera
ok rozumiem nie ma cię w biurze jesteś na wakacjach ale można napisać będę w biurze o 17 albo za miesiąc i wtedy jak znajdę chwilę to skompiluje dla ciebie projekt albo poproś kogoś na forum


tak więc jak by ktoś miał czas skompilować kilka projektów z YB z tymi ustawieniami w pliki mk_gsm.h

Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.



i wtedy mogli byśmy sprawdzić dlaczego u mnie nie działa



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 sty 2019, o 13:38 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 25261
Lokalizacja: Szczecin
Pomógł: 951

tomasz1987 napisał(a):
i napisałeś epopeję na temat zaglądania do książki

epopeję powiadasz .... no no ... to pisz dalej swoją epopeję dobry człowieku

------------------------ [ Dodano po: 2 minutach ]

tomasz1987 napisał(a):
w której wcale nie opisujesz błędów linkera

to co pokazałeś to nie są żadne błędy linkera jeśli w zakładce Console nie ma błędów ... no ale ... krótko, skoro ja piszę epopeje to nie ma co się wysilać i pomagać dalej bo po co ? ;) miłej zabawy i szczęśliwego nowego roku.

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 sty 2019, o 13:41 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 25 mar 2013
Posty: 54
Pomógł: 0

Wygląda jak byś my się kłócili a ja poprosiłem tylko o pomoc wydaje mi się bardzo dobrze opisując problem



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 sty 2019, o 13:44 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 25261
Lokalizacja: Szczecin
Pomógł: 951

tomasz1987 napisał(a):
stwierdziłeś że nie masz czasu i napisałeś epopeję na temat zaglądania do książki
w której wcale nie opisujesz błędów linkera
ok rozumiem nie ma cię w biurze jesteś na wakacjach ale można napisać będę w biurze o 17 albo za miesiąc i wtedy jak znajdę chwilę to skompiluje dla ciebie projekt albo poproś kogoś na forum

nie skądże ? ;) jaka kłótnia - ty wiesz po prostu lepiej ile ja mam czasu i mam pisać i robić to czego sobie jaśnie pan życzy ;) no ale tym bardziej panie kochany nie mam czasu, zarobiony jestem, nie ma mnie ;)

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 sty 2019, o 13:53 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 25 mar 2013
Posty: 54
Pomógł: 0

konsola jest czysta kompilacja przebiegła poprawnie



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 sty 2019, o 14:01 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 25 mar 2013
Posty: 54
Pomógł: 0

ok
dzięki za zainteresowane
zrobiłem tak
prawo klik
clean project
close project
open project
build project

consola:
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.



przejrzałem sporo tematów i w większości ludzie zmieniają tu Eclipse's C/C++ Build -> Settings
jest tez pewne prawdopodobieństwo że mam coś źle ustawione z Eclips

edit
nie chodzi mi o to że program nie działa i się nie kompiluje bo się kompiluje
tylko o to że w przypadku poprawnie skonfigurowanego projektu mam możliwość prawo-kliku i skoczenia do deklaracji
trochę to porostu źle ująłem



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 sty 2019, o 17:12 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 25 mar 2013
Posty: 54
Pomógł: 0

Człowieku :D
jesteś wielki, jestem niesamowicie wdzięczny za "zniknięcie" wszystkich czerwonych drażniących nie krzyżyków
problem leżał właśnie w ustawieniach indexera
po 100kroć dzięki

wiem że może dla niektórych jak projekt się kompiluje to jest wszystko ok ale mnie trochę inaczej uczono :P
i kazano poprawiać aż wszystkie worningi znikną :P nawet jak program działa.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 14 ] 

Strefa czasowa: UTC + 1


Kto przegląda forum

Użytkownicy przeglądający ten dział: Majestic-12 [Bot] i 4 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
Sitemap
Technologię dostarcza phpBB® Forum Software © phpBB Group phpBB3.PL
phpBB SEO