Kanał - ATNEL tech-forum
Wszystkie działy
Najnowsze wątki



Teraz jest 18 lis 2018, o 14:56


Strefa czasowa: UTC + 1





Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 37 ]  Przejdź na stronę 1, 2  Następna strona
Autor Wiadomość
PostNapisane: 4 lis 2018, o 11:27 
Offline
Nowy

Dołączył(a): 04 lis 2018
Posty: 18
Pomógł: 0

Panowie nie wiem gdzie robię błąd ale robię jak na filmiku pana Kardaś karze i na XP śmiga a na 10 nie chcę . Wyskakuje mi taki błąd ; Description Resource Path Location Type
undefined reference to `main' 00_led line 0, external location: c:\program files (x86)\atmel\avr tools\avr toolchain\avr\lib\avr5\crtm16a.o C/C++ Problem
O co w tym chodzi?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 4 lis 2018, o 11:28 
Offline
Użytkownik

Dołączył(a): 25 lip 2013
Posty: 1623
Pomógł: 78

Ścieżki ze spacjami?


Autor postu otrzymał pochwałę


Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 4 lis 2018, o 11:46 
Offline
Nowy

Dołączył(a): 04 lis 2018
Posty: 18
Pomógł: 0

Nie folder do projektów "workspace" bez spacji folder do Eklipsa "Eclips_Mars" tez brak spacji pierwszy program "00_led" .Gdzie mogłem jeszcze coś pomieszać?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 4 lis 2018, o 11:51 
Offline
Użytkownik

Dołączył(a): 25 lip 2013
Posty: 1623
Pomógł: 78

A toolchain? Spróbuj Mirkowy MkClipse - on ma/ściąga wszystko co potrzebne.


Autor postu otrzymał pochwałę


Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 4 lis 2018, o 12:00 
Offline
Nowy

Dołączył(a): 04 lis 2018
Posty: 18
Pomógł: 0

Toolchain z bloga Mirekk36 z Eclips od A do Z .Gdzie szukać MkClipse ?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 4 lis 2018, o 12:18 
Offline
Moderator zasłużony dla forum.atnel.pl
Avatar użytkownika

Dołączył(a): 18 lip 2012
Posty: 3223
Lokalizacja: Kraków - obok FAB5 ATMEL'a
Pomógł: 82

https://www.atnel.pl/oprogramowanie.html


Autor postu otrzymał pochwałę


Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 4 lis 2018, o 12:28 
Offline
Nowy

Dołączył(a): 04 lis 2018
Posty: 18
Pomógł: 0

Czyli jak rozumiem mam uczyć się na tym a o marsie zapomnieć?

------------------------ [ Dodano po: 11 minutach ]

Teraz taki błąd; avr-gcc" -Wl,-Map,Release/00_led.map -Wl,--undefined=MkBuildVersion -Wl,--undefined=MkBuildNumber -Wl,--undefined=MkBuildDate -Wl,--undefined=MkBuildTime -Wl,--gc-sections -mmcu=atmega16a -o "Release/00_led.elf" Release/main.o Release/mk_build.o
c:/program files (x86)/atmel/avr tools/avr toolchain/bin/../lib/gcc/avr/4.8.1/../../../../avr/lib/avr5/crtm16a.o:(.init9+0x0): undefined reference to `main'
collect2.exe: error: ld returned 1 exit status
----------------
ERROR



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 4 lis 2018, o 12:39 
Offline
Użytkownik

Dołączył(a): 25 lip 2013
Posty: 1623
Pomógł: 78

Nie, masz po prostu protestować. Żeby sprawdzić czy na MkClipse pójdzie. Nie pamiętam czy toolchain też miał być w ścieżce bez spacji-u ciebie akurat jest ze spacjami.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 4 lis 2018, o 12:57 
Offline
Nowy

Dołączył(a): 04 lis 2018
Posty: 18
Pomógł: 0

Coś namieszałem ! Czy ten folder x86 jest właściwy i tam mam instalować wszystko ? A nie na dysku c



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 4 lis 2018, o 14:41 
Offline
Użytkownik

Dołączył(a): 08 wrz 2015
Posty: 54
Pomógł: 0

Obejrzyj lepiej ten poradnik:
https://mirekk36.blogspot.com/2015/07/e ... m.html?m=1
Oraz później ten, jak będziesz robił tak jak pokazane musi działać, sam krok po kroku robiłem i działa
http://mirekk36.blogspot.com/2018/08/ec ... a.html?m=1



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 4 lis 2018, o 16:01 
Offline
Nowy

Dołączył(a): 04 lis 2018
Posty: 18
Pomógł: 0

Kolego robiłem i w xp gdze smiga jak trzeba a w 10 nie. Na razie wyszło ze Java miała błąd instalacji



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 4 lis 2018, o 17:56 
Offline
Użytkownik

Dołączył(a): 08 wrz 2015
Posty: 54
Pomógł: 0

Ja mam win10, u mnie przebiegło wszystko pomyślnie. AVRDUDE masz zainstalowany, podana poprawna ścieżka?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 4 lis 2018, o 19:38 
Offline
Nowy

Dołączył(a): 04 lis 2018
Posty: 18
Pomógł: 0

Koledzy 6 razy robione i lipa znowu brak pliku;;Description Resource Path Location Type
undefined reference to `main' 00_led_blik line 52, external location: \data2\home\toolsbuild\jenkins-knuth\workspace\avr8-gnu-toolchain\src\avr-libc\crt1\gcrt1.S C/C++ Problem

------------------------ [ Dodano po: 4 minutach ]

Ale działa na MkClips



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 4 lis 2018, o 20:39 
Offline
Użytkownik

Dołączył(a): 25 lip 2013
Posty: 1623
Pomógł: 78

Kolega to na linuxie ćwiczy?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 4 lis 2018, o 20:52 
Offline
Użytkownik

Dołączył(a): 08 wrz 2015
Posty: 54
Pomógł: 0

PoczatkujacyAdam napisał(a):

Teraz taki błąd; avr-gcc" -Wl,-Map,Release/00_led.map -Wl,--undefined=MkBuildVersion -Wl,--undefined=MkBuildNumber -Wl,--undefined=MkBuildDate -Wl,--undefined=MkBuildTime -Wl,--gc-sections -mmcu=atmega16a -o "Release/00_led.elf" Release/main.o Release/mk_build.o
c:/program files (x86)/atmel/avr tools/avr toolchain/bin/../lib/gcc/avr/4.8.1/../../../../avr/lib/avr5/crtm16a.o:(.init9+0x0): undefined reference to `main'
collect2.exe: error: ld returned 1 exit status
----------------
ERROR


Micky, czy przypadkiem on w pierwszym błędzie nie ma debug, nie wyłączył tego, najlepiej jak by napisał jak dokładniej to robi lub nagral filmik, ale coś mi się zdaje na zle ustawiobe ścieżki dostępu do plików.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 4 lis 2018, o 22:48 
Offline
Użytkownik

Dołączył(a): 25 lip 2013
Posty: 1623
Pomógł: 78

Nie wiem. Może zapomniał zapisać projekt?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 5 lis 2018, o 07:18 
Offline
Użytkownik

Dołączył(a): 14 sie 2016
Posty: 600
Pomógł: 24

Sprawdź czy np Defender albo inny antywir nie blokuje toolchaina. Czy Eclipse uruchamiasz z uprawnieniami admina?

Wysłane ze srajfona

_________________
Moje porady są błędne,nie czytać,zbanować od razu.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 5 lis 2018, o 12:08 
Offline
Nowy

Dołączył(a): 04 lis 2018
Posty: 18
Pomógł: 0

Eklips z uprawnieniami dmina a to blokowanie jak szukać niemam anty wirusa tylko ochrona widows



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 5 lis 2018, o 17:49 
Offline
Użytkownik

Dołączył(a): 08 wrz 2015
Posty: 54
Pomógł: 0

Pokaż jakie masz ścieżki do toolchine i avrdude. Najlepiej zrzut ekranu



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 5 lis 2018, o 17:59 
Offline
Nowy

Dołączył(a): 04 lis 2018
Posty: 18
Pomógł: 0

Panowie wyłączenie zapory nic nie dało próbuje od nowa
jak macie sugestie to jestem łakomy i dziękuje za wasze zainteresowanie!
ps. z tym szukaniem zapory systemu to gafa mam nadzieje że nikt nie zauważył.

------------------------ [ Dodano po: 30 minutach ]

Oto zrzuty jak coś jeszcze to pisać
ObrazekObrazekObrazekObrazekObrazekObrazekObrazekObrazek



Ostatnio edytowano 5 lis 2018, o 20:49 przez PoczatkujacyAdam, łącznie edytowano 1 raz

Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 5 lis 2018, o 20:25 
Offline
Użytkownik

Dołączył(a): 08 wrz 2015
Posty: 54
Pomógł: 0

@PoczatkujacyAdam: brak fotek, zobacz jak dodawać zdjęcia:
Dodawanie zdjęć

------------------------ [ Dodano po: 59 minutach ]

Włącz Eclipse, Help>About Eclipse i pokaż co tam masz, zdaje mi się że masz nie taką wersję jak potrzeba. Do tego w kodzie jak zobaczysz linia 52 jest błąd, więc przez to też możesz mieć problem



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 5 lis 2018, o 21:44 
Offline
Nowy

Dołączył(a): 04 lis 2018
Posty: 18
Pomógł: 0

Kolego man wszystko od nowa z poradnikiem na tablecie i do kompilacji niby ok a po kompilacji tak;
ObrazekObrazek



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 5 lis 2018, o 21:46 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 23658
Lokalizacja: Szczecin
Pomógł: 894

kolego - proszę - spójrz, że na te swoje screeny bo aż w oczy kuje!

Cytuj:
maint()


widziałeś ty kiedyś taką główną funkcję programu ? ;)

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 5 lis 2018, o 21:51 
Offline
Nowy

Dołączył(a): 04 lis 2018
Posty: 18
Pomógł: 0

tu masz helpa
Obrazek



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 5 lis 2018, o 21:54 
Offline
Tech-support
Avatar użytkownika

Dołączył(a): 26 sty 2016
Posty: 733
Lokalizacja: Kraków
Pomógł: 62

A po zmianie nazwy funkcji? Tak, jak radził Mirek?
Błąd oznacza, że nie masz w projekcie funkcji main (i słusznie, bo masz maint)



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 5 lis 2018, o 22:07 
Offline
Nowy

Dołączył(a): 04 lis 2018
Posty: 18
Pomógł: 0

Przepraszam poprawione przepraszam za zaśmiecenie forum Eclips ruszył bardzo jeszcze raz dziękuje za wszelką pomoc .Teraz zaczynam odkrywanie "C" może pójdzie bardziej strawnie niż ten Mars ,tylko temu w C zaczynam bo Bascom ma niewielu chce w nim pomagać a większość że to ślepa uliczka spróbuj w C lub Andurino. Więc padło na C mam filmiki Mirkak36 i jak na razie coś z nich łapie. Odnośnie błędu który popełniałem to chyba jak w eclipsie wgrywałem to nie zaznaczałem Plugin żeby się podświetlił tylko od razu kazałem zapisz.
A tak przy okazji Mirku K. bardzo fajne poradniki oby tak dalej nie wszyscy potrafią uczyć się z czytania jak ja, ja zawsze uczył się słuchając .



Ostatnio edytowano 5 lis 2018, o 22:27 przez PoczatkujacyAdam, łącznie edytowano 1 raz

Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 5 lis 2018, o 22:18 
Offline
Użytkownik

Dołączył(a): 08 wrz 2015
Posty: 54
Pomógł: 0

Zakup książkę BB - sam też raczkuje i będę ją brał. Chodzi o tą:
Książka BB



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 5 lis 2018, o 22:36 
Offline
Nowy

Dołączył(a): 04 lis 2018
Posty: 18
Pomógł: 0

Myślę o tym a to zależy od premii czy będzie lewy grosz na hobby płytka uniwersalna polutowana z podstawka dip 40 atmega16a kwarc 12Mhz i kilka drobiazgów dorabiam peryferia w zależności od potrzeb na płytce stykowej .



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 9 lis 2018, o 21:56 
Offline
Nowy

Dołączył(a): 04 lis 2018
Posty: 18
Pomógł: 0

Książka i mkAVRCalculator teraz tylko czekać aż przyjdzie i uczyć się,mam nadzieje że nie będę żałował wydanej kaski!!



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 9 lis 2018, o 23:27 
Offline
Użytkownik

Dołączył(a): 22 kwi 2017
Posty: 48
Lokalizacja: Piła
Pomógł: 2

Ja kasy na książkę nie żałuję, tylko czemu moja głowa tak wolno to przyjmuje, ale powoli od razu Krakowa nie zbudowali. Po przeczytaniu p. Mirka książki zaczynam rozumieć coś, a jej uzupełnienia czyli poradniki na YouTube bezcenne.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 37 ]  Przejdź na stronę 1, 2  Następna strona

Strefa czasowa: UTC + 1


Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 2 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
Sitemap
Technologię dostarcza phpBB® Forum Software © phpBB Group phpBB3.PL
phpBB SEO