Kanał - ATNEL tech-forum
Wszystkie działy
Najnowsze wątki



Teraz jest 31 mar 2020, o 11:44


Strefa czasowa: UTC + 1





Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 2 ] 
Autor Wiadomość
PostNapisane: 26 paź 2018, o 15:51 
Offline
Użytkownik

Dołączył(a): 02 cze 2014
Posty: 42
Pomógł: 0

Witam serdecznie.
Chciałbym wysłać przez UART liczbę. Napisałem funkcje zamieniającą liczbę na string, ale mi nie chce działać.
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.

Podczas kompilacji wychodzi mi błąd: warning: 's' is used uninitialized in this function.
Proszę o podpowiedź, gdzie mam błąd?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 26 paź 2018, o 16:31 
Offline
Użytkownik

Dołączył(a): 02 cze 2014
Posty: 42
Pomógł: 0

OK.
Dzięki za podpowiedź.
Teraz funkcja wygląda tak:
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.



Błąd który teraz przychodzi to:
warning: passing argument 1 of 'send_string' makes pointer from integer without a cast
oraz informacja:
note: expected 'char *' but argument is of type 'char'



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 2 ] 

Strefa czasowa: UTC + 1


Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 2 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
Sitemap
Technologię dostarcza phpBB® Forum Software © phpBB Group phpBB3.PL
phpBB SEO