Kanał - ATNEL tech-forum
Wszystkie działy
Najnowsze wątki



Teraz jest 17 lip 2018, o 16:08


Strefa czasowa: UTC + 1





Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 7 ] 
Autor Wiadomość
 Tytuł: Debug (log)
PostNapisane: 10 lip 2018, o 18:26 
Offline
Użytkownik

Dołączył(a): 19 lip 2013
Posty: 445
Pomógł: 25

Witam! Tablet Lenovo android 6.0 wczesniej bylo wszystko ok ,a teraz nie działa debugowanie. Pokazuje ,ze sie połączył
"Logger połączony z: LENOVO Lenovo TB3-850M"
"--------- beginning of main"
i to wszystko. Ten sam program wgrywam do innego urządzenia i działa normalnie.
Próbowałem wgrywać na nowo b4a-bridge szukam po ustawieniach w tablecie czy coś blokuje.
Program normalnie działa ,tylko nie ma żadnych logow. Pozostaje mi jeszcze zresetowanie tableta do ustawień fabrycznych ,ale z tym chciałbym sie wstrzymać.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
 Tytuł: Re: Debug (log)
PostNapisane: 10 lip 2018, o 20:06 
Offline
Nowy

Dołączył(a): 10 sty 2018
Posty: 18
Pomógł: 0

Witam
Jakiej używasz wersji B4A?, spróbuj użyć menagera SDK...może coś trzeba uaktualnić.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
 Tytuł: Re: Debug (log)
PostNapisane: 10 lip 2018, o 21:01 
Offline
Użytkownik

Dołączył(a): 19 lip 2013
Posty: 445
Pomógł: 25

sdk aktualizowałem,a b4a to 7.3. Dziwne jest to,ze to działało i z dnia na dzień przestało. Podejrzewam wine tabaleta albo windowsa. Spróbuje na innym kompie, tylko nie wiem jak z licencja.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
 Tytuł: Re: Debug (log)
PostNapisane: 10 lip 2018, o 21:45 
Offline
Nowy

Dołączył(a): 10 sty 2018
Posty: 18
Pomógł: 0

Trudno powiedzieć co jest powodem. Najlepiej jak byś przeszedł na B4A v8.30...rozwiązuje wiele problemów.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
 Tytuł: Re: Debug (log)
PostNapisane: 11 lip 2018, o 14:03 
Offline
Użytkownik

Dołączył(a): 19 lip 2013
Posty: 445
Pomógł: 25

No ,tylko trzeba zapłacić za nowa licencje :) Może jesienią wykupie. Na razie wakacje idą :) Tu raczej obstawiam winę tableta niż b4a ,bo na innych urządzeniach działa bez problemu. Dzięki za poświęcony czas.
Nie che zakładać nowego tematu dla drobnostki. Czym sie podmienia znaki w stringu ? Musze dwukropki podmienić na spacje. Bylo w jakimś poradniku ale nie pamiętam w którym ,a wszystkie przeglądać to za duzo.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
 Tytuł: Re: Debug (log)
PostNapisane: 11 lip 2018, o 14:31 
Offline
Nowy

Dołączył(a): 10 sty 2018
Posty: 18
Pomógł: 0

Możesz spróbować z czyszczeniem androida.. to faktycznie może być ten problem. Co do podmiany znaków to sprawdź dokumentację B4a, a dokładnie bibliotekę core...Tam chyba to było.

P.S
Jeszcze małe pytanko, jak odznaczysz okienko Filtruj (lewy dolny róg nad menagerem) to co dostajesz?...a i czy restartowałeś tableta (może to wystarczy).



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
 Tytuł: Re: Debug (log)
PostNapisane: 11 lip 2018, o 14:55 
Offline
Użytkownik

Dołączył(a): 19 lip 2013
Posty: 445
Pomógł: 25

Jak odznaczę filtuj to cały czas coś tam wyświetla i reaguje na wciśniecie jakiegoś buttona w apce. Wiec komunikacja jakaś jest.Tablet tak restartowałem. Wieczorem przywrócę go do fabrycznych ustawień i zobaczę co będzie.
edit
zresetowałem tablet i wróciło wszystko do normy.
Co do podmianki znaku w stingu to dla potomnych jak ktos na to trafi.
Składnia: [ Pobierz ] [ Ukryj ]
język basic4gl
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 7 ] 

Strefa czasowa: UTC + 1


Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 0 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
Sitemap
Technologię dostarcza phpBB® Forum Software © phpBB Group phpBB3.PL
phpBB SEO