Kanał - ATNEL tech-forum
Wszystkie działy
Najnowsze wątki



Teraz jest 26 wrz 2018, o 09:47


Strefa czasowa: UTC + 1





Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 5 ] 
Autor Wiadomość
PostNapisane: 16 lut 2018, o 00:06 
Offline
Użytkownik

Dołączył(a): 13 mar 2013
Posty: 69
Pomógł: 0

Witam
W ramach ćwiczeń i zabaw utworzyłem w MkClipse nowy projekt, wpisałem dosłownie parę linijek które miały sprawdzić poprawność podłączenia dwóch diod LED na zewnętrznej płytce zawierającej Atmega8, 11059000 i całość skompilowałem. Kompilacja przebiegła prawidłowo więc chciałem zrobić upload - i tu zaskoczenie - dostałem komunikat błędu:

Please wait ...avrdude_mk.exe: invalid file format '\Projekty' in update specifier
avrdude_mk.exe: error parsing update operation 'flash:w:D:\Projekty'

Jednocześnie podłączenia wydają się prawidłowe, MkAvrCalculator widzi procek i właściwie go identyfikuje. Programator oryginalny Atnelowski ATB-USBASP 4.0 ( który wykrywany jest jako USBASP_Clone, ale coś o tym w którymś poradniku było)
Byłbym bardzo zobowiązany za wyjaśnienie czy jest to mój błąd i jak go mogę wyeliminować.
Pozdrawiam
WTG



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 16 lut 2018, o 00:09 
Offline
Użytkownik

Dołączył(a): 14 sie 2016
Posty: 587
Pomógł: 22

A zapisałeś wcześniej?

_________________
Moje porady są błędne,nie czytać,zbanować od razu.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 16 lut 2018, o 00:26 
Offline
Użytkownik

Dołączył(a): 13 mar 2013
Posty: 69
Pomógł: 0

Harry napisał(a):
A zapisałeś wcześniej?


No nie, ale wydawało mi się ,że zapisywanie było wprawdzie istotne do kompilacji, ale w MkClipse jest to już niejako "etatowe", że projekt przy kompilacji jest zapisywany, otrzymując przy tym kolejny numerek skompilowanej wersji. Natomiast błąd występuje przy próbie zapisu skompilowanego projektu do procka.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 16 lut 2018, o 00:27 
Offline
Użytkownik

Dołączył(a): 14 sie 2016
Posty: 587
Pomógł: 22

A w nazwie ścieżki/pliku nie masz czasem spacji?


Autor postu otrzymał pochwałę

_________________
Moje porady są błędne,nie czytać,zbanować od razu.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 16 lut 2018, o 00:44 
Offline
Użytkownik

Dołączył(a): 13 mar 2013
Posty: 69
Pomógł: 0

Harry napisał(a):
A w nazwie ścieżki/pliku nie masz czasem spacji?


W nazwie pliku nie - projekt ma poetycką nazwę "test2". Pamiętając o przestrogach Mirka starałem się na to zwracać uwagę, ale żeby było śmieszniej, projekt jest w katalogu "Projekty AVR". Nic dodać, nic ująć . Jutro sprawdzę czy to w tym leży problem i dam znać

------------------------ [ Dodano po: 13 minutach ]

Oczywiście miałeś rację - po zmianie nazwy katalogu na "Projekty_AVR" poszło jak burza. Wielkie dzięki.
Pozdrawiam
WTG



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 5 ] 

Strefa czasowa: UTC + 1


Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 0 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
Sitemap
Technologię dostarcza phpBB® Forum Software © phpBB Group phpBB3.PL
phpBB SEO