Kanał - ATNEL tech-forum
Wszystkie działy
Najnowsze wątki



Teraz jest 31 mar 2020, o 02:28


Strefa czasowa: UTC + 1





Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 16 ] 
Autor Wiadomość
PostNapisane: 2 lut 2018, o 16:41 
Offline
Użytkownik

Dołączył(a): 17 mar 2017
Posty: 30
Pomógł: 0

Chciałem zmienić źródło taktowania w ATmega8 na zewnętrzny kwarc 8MHz.
Program odczytał ATmegę, ustawiłem zewnętrzny kwarc >8Mhz,dopiąłem kwarc do nóżek 9 i 10, po czym przy próbie odczytania pojawia się błąd. Identyczna sytuacja dla dwóch takich samym uC.
Obrazek

Przy zapisie z powrotem na wewnętrzny oscylator 1 Mhz też pojawia się błąd.

Obrazek



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 lut 2018, o 16:46 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 25261
Lokalizacja: Szczecin
Pomógł: 951

Bo źle podłączyłeś kwarca ? Bo kwarc jest uszkodzony? Sprawdzałeś inny kwarc ? jakiś dowolny ?

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 lut 2018, o 16:51 
Offline
Użytkownik

Dołączył(a): 17 mar 2017
Posty: 30
Pomógł: 0

Tak, trzy różne kwarce 8 Mhz.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 lut 2018, o 16:55 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 25261
Lokalizacja: Szczecin
Pomógł: 951

być może złe kabelki, połączenia między prockiem a programatorem - pokaż lepiej jak masz to podłączone - daj ze 2-3 jakieś wyraźne fotki to wtedy będzie można ci coś pomóc może bo robisz ewidentnie jakiś błąd

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 lut 2018, o 17:02 
Offline
Tech-support
Avatar użytkownika

Dołączył(a): 26 sty 2016
Posty: 931
Lokalizacja: Kraków
Pomógł: 83

A czy kolega do kwarcu dodał kondensatory 18pF pomiędzy nóżkami a GND?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 lut 2018, o 18:56 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 19 cze 2014
Posty: 807
Lokalizacja: Tam gdzie PYRY są
Pomógł: 64

Marhef napisał(a):
A czy kolega do kwarcu dodał kondensatory 18pF pomiędzy nóżkami a GND?

To nie to, kwarc ruszy bez kondensatorów...
Mi to bardziej wygląda na kwarc wpięty w płytkę stykową i kabelki z 10cm do procka. Ato już zadziałać nie może

_________________
IntegraMETEO
WordCLOCK
IntegraTOUCH



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 lut 2018, o 19:13 
Offline
Użytkownik

Dołączył(a): 17 mar 2017
Posty: 30
Pomógł: 0

Kondensatory 100 nF.
Kwarc oczywiście zaraz przy uC.
Prędzej coś źle robię w mkAVR Calculator.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 lut 2018, o 19:19 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 25261
Lokalizacja: Szczecin
Pomógł: 951

filipbaza napisał(a):
Kondensatory 100 nF.

100 nF przy kwarcu ?!?!?!?!?!?!?!?! ;) kolego ... kolego - aż szkoda mówić dalej

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 lut 2018, o 19:19 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 19 cze 2014
Posty: 807
Lokalizacja: Tam gdzie PYRY są
Pomógł: 64

filipbaza napisał(a):
Kondensatory 100 nF.


Za duuuuuużo, dużo za dużo... To już lepiej bez

_________________
IntegraMETEO
WordCLOCK
IntegraTOUCH



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 lut 2018, o 19:37 
Offline
Użytkownik

Dołączył(a): 17 mar 2017
Posty: 30
Pomógł: 0

Obrazek

Obrazek



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 lut 2018, o 19:48 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 19 cze 2014
Posty: 807
Lokalizacja: Tam gdzie PYRY są
Pomógł: 64

Nogi 21 22 nie zasilone?? Źle!!! Poza tym fotki bez komentarza?? Jaki kwarc? Pokaż mkavrcalc jak ustawiłeś fusy. I zabierz ten kondensator z resetu

_________________
IntegraMETEO
WordCLOCK
IntegraTOUCH



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 lut 2018, o 19:51 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 09 gru 2014
Posty: 1537
Pomógł: 267

Zacznij od tego:
https://youtu.be/LiQcVSPkT6M?t=1811



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 lut 2018, o 20:07 
Offline
Użytkownik

Dołączył(a): 17 mar 2017
Posty: 30
Pomógł: 0

skalarro napisał(a):
Nogi 21 22 nie zasilone?? Źle!!! Poza tym fotki bez komentarza?? Jaki kwarc? Pokaż mkavrcalc jak ustawiłeś fusy. I zabierz ten kondensator z resetu


Do odczytania uC chyba nie musi być koniecznie zasilania na AVCC, prawda?
Kwarc 8 Mhz.
Czemu zabrać kondensator z resetu?
Fusy przestawiałem tylko w zakładce fusy uproszczone, nic więcej.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 lut 2018, o 20:19 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 25261
Lokalizacja: Szczecin
Pomógł: 951

filipbaza napisał(a):
Do odczytania uC chyba nie musi być koniecznie zasilania na AVCC, prawda?

Chłopie - zajrzyj, że na bloga i przeczytaj:

http://mirekk36.blogspot.com/2012/04/mi ... lanie.html

szczególnie fragmenty w czerwonych ramkach z noty PDF

i zacznij pisać w końcu jasno a nie skrótami alfabetem morsa
Cytuj:
Kondensatory 100 nF.

o jakich kondensarotach pisałeś ? przy kwarcu ? ... jeszcze jeden taki skrót mega myślowy i poproszę cię o zadawanie pytań na innym forum ...

włóż chociaż odrobinę wysiłku w napisanie PRAWIDŁOWEGO pytania ... czy opisania problemu a nie jakieś skróty - jasny gwint wie - czy tobie chodziło o kondensatory (liczba mnoga była) przy kwarcu ? czy kondensator 100nF na resecie

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 3 lut 2018, o 13:34 
Offline
Użytkownik

Dołączył(a): 17 mar 2017
Posty: 30
Pomógł: 0

Coś nie łączyło na płytce stykowej. Przepiąłem wszystko w inne miejsce i już działa. Mogłem to zrobić przed założeniem posta...
Temat do zamknięcia.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 3 lut 2018, o 13:53 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 25261
Lokalizacja: Szczecin
Pomógł: 951

filipbaza napisał(a):
Mogłem to zrobić przed założeniem posta...

I TUTAJ masz 100% a nawet 10000% racji ... a przy okazji przekonujesz się sam co znaczą STYKÓWKI :) ... raz stykają a raz nie stykają i się traci KUPĘ czasu

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 16 ] 

Strefa czasowa: UTC + 1


Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 3 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
Sitemap
Technologię dostarcza phpBB® Forum Software © phpBB Group phpBB3.PL
phpBB SEO