Kanał - ATNEL tech-forum
Wszystkie działy
Najnowsze wątki



Teraz jest 26 wrz 2018, o 10:12


Strefa czasowa: UTC + 1





Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 8 ] 
Autor Wiadomość
PostNapisane: 8 lis 2017, o 15:03 
Offline
Nowy

Dołączył(a): 04 lis 2017
Posty: 7
Pomógł: 0

Witam,

chciałbym zapytać o możliwe przyczyny problemu z jakim się spotkałem. Otóż, wykonywałem ćwiczenie Multi_LED zauważyłem dziwne zachowanie wyświetlacza po wgraniu kodu (poprawiona wersja ze strony www z erratą). Umieszczam link do filmiku: https://1drv.ms/f/s!AsbngcmQryhM5yigqe0APwbdvA6e .
Wcześniej jednak wykorzystywałem swoją wersję programu, w której najpierw powoli multipleksowałem między wyświetlaczami w odstępie 1s z użyciem timera1 w trybie normal. Widząc, że to działa zmieniłem prescaler, aby uzyskać efekt stałego wyświetlania - tym razem działający poprawnie. Dodam, że timer1 z obliczeniami podanymi w książce odmierzał dokładnie 1s, więc zgar jest poprawnie ustawiony na 100% na 8Mhz. Byłbym wdzięczny za pomoc.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 8 lis 2017, o 15:13 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 23513
Lokalizacja: Szczecin
Pomógł: 885

Przed chwilą w innym wątku pytałeś o procek z którym chyba coś zrobiłeś nie tak - teraz zdaje się masz nowy i zapewne fusebitu JTAG sobie niefrasobliwie nie wyłączyłeś

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 8 lis 2017, o 16:51 
Offline
Nowy

Dołączył(a): 04 lis 2017
Posty: 7
Pomógł: 0

Przeprowadziłem taka samą konfigurację jak na tamtym procku, częstotliwośc 8MHz, Jtag wyłaczony w zakładce fusy uproszczone mkvrcalculator po wykonaniu odczytu. Inna konfiguracja timera (tym razem tryb normal timer1 + brak zapisywania tablicy do pamięci - działa poprawnie). Coś jeszcze może pomóc w znalezieniu przyczyny?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 8 lis 2017, o 18:30 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 23513
Lokalizacja: Szczecin
Pomógł: 885

coś zmieniłeś w kodzie ;) więc kto cię tam wie co kombinujesz ? ;)

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 8 lis 2017, o 19:24 
Offline
Nowy

Dołączył(a): 04 lis 2017
Posty: 7
Pomógł: 0

Cytuj:
zauważyłem dziwne zachowanie wyświetlacza po wgraniu kodu (poprawiona wersja ze strony www z erratą).



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 8 lis 2017, o 21:21 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 23513
Lokalizacja: Szczecin
Pomógł: 885

roolf napisał(a):
Cytuj:
zauważyłem dziwne zachowanie wyświetlacza po wgraniu kodu (poprawiona wersja ze strony www z erratą).

No i co ten wpis wg ciebie oznacza ?

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 8 lis 2017, o 21:23 
Offline
Nowy

Dołączył(a): 04 lis 2017
Posty: 7
Pomógł: 0

to że nie zmieniałem kodu



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 8 lis 2017, o 21:38 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 23513
Lokalizacja: Szczecin
Pomógł: 885

- sposób sprawdzenia tego kodu i działania wyświetlacza jest TAK prosty, że na prawdę warto powalczyć samemu, żebyś doszedł co tam źle robisz

zacznij, że po kolei

- sprawdź statycznie czy ci wyświetlacz działa i wszystkie segmenty
- sprawdź czy masz połączenia zgodne z definicjami w książce

no przecież to troszkę aż strach żeby ktoś zewnątrz za ciebie to sprawdzał - w takim ćwiczeniu DUŻO zależy od ciebie - a program nie zadziała jeśli go nie odpalisz poprawnie - to nie komputer PC - gdzie każdy ma taką samą elektronikę i system operacyjny

zadajesz pytanie jakby kompletnie oderwane od rzeczywistości troszkę - czytałeś rozdział ? rozumiesz co po kolei robimy w książce ?

czy tylko ot tak (bez przeczytania i zrozumienia) bierzesz kod , próbujesz odpalić a jak coś nie działa to ? ... to co ? wina kodu? procesora? zestawu? kompilatora ? ... nie sądzisz , że warto poszukać - a jeśli już zadać pytanie to jakoś je skonkretyzować ... opisać dokładnie co robisz - jakie masz połączenia i czy zgodne z kodem itp itd ... sprawdzić po raz setny albo i więcej jak trzeba to co sam robisz - bo jak inaczej chcesz żeby ci pomóc? na zasadzie jasnowidza ?

------------------------ [ Dodano po: 2 minutach ]

ok pokazałeś filmik - przynajmniej to

ale jeszcze raz mówię - sięgnij do książki do rozdziału - przeanalizuj - a jeśli coś ci się nie będzie zgadzało to opisz DOKŁADNIE co ? gdzie upatrujesz błędu .... ew czego nie rozumiesz, załącz kod na końcu może jakiego używasz - w przypadku kodu do tego rozdziału to już ok można go publikować

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 8 ] 

Strefa czasowa: UTC + 1


Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 0 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
Sitemap
Technologię dostarcza phpBB® Forum Software © phpBB Group phpBB3.PL
phpBB SEO