Kanał - ATNEL tech-forum
Wszystkie działy
Najnowsze wątki



Teraz jest 31 mar 2020, o 01:49


Strefa czasowa: UTC + 1





Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 10 ] 
Autor Wiadomość
PostNapisane: 24 paź 2017, o 23:25 
Offline
Nowy

Dołączył(a): 24 paź 2017
Posty: 6
Pomógł: 0

Witam, zaczynam dopiero przygodę z uC. Zakupiłem BLUEBOOKa i podążałem wg początkowych instrukcji.
Mam ATmege 328P-PU poprawnie podpiętą (sprawdzane kilka razy, bo wiem, że to częsta przyczyna), zasilanie z USBAVR (od atnela) w mkAVRCalculator wybrałem atmege328P (nie ma do wyboru 328p-PU), próbowałem wszystkich możliwych konfiguracji, za każdym razem następujący błąd:

avrdude.exe: set SCK frequency to 4000 Hz
avrdude.exe: error: programm enable: target doesn't answer. 1
avrdude.exe: initialization failed, rc=-1
avrdude.exe: AVR device initialized and ready to accept instructions
avrdude.exe: Device signature = 0x000000
avrdude.exe: Yikes! Invalid device signature.
avrdude.exe: Expected signature for ATMEGA8 is 1E 93 07

avrdude.exe done. Thank you.

Compiled special for http://forum.atnel.pl (v5.11.1)

Przeglądajac forum nie znalazłem odpowiedzi :(
Czy ktoś wie również jaka jest różnica między 328P a 328P-PU?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 25 paź 2017, o 00:11 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 23 paź 2014
Posty: 870
Lokalizacja: Trójmiasto
Pomógł: 164

Komunikat rc=-1 oznacza ni mniej ni więcej brak komunikacji programatora z prockiem. Najczęstsze przyczyny to:
- źle połączony procek z programatorem (niestykające przewody, brak zasilanie etc)
- ustawione złe taktowanie procka w stosunku do podłączenia (np procek może mieć ustawione taktowanie z zewnętrznego kwarcu, a nie masz takowego podłączonego)
- za wolne taktowanie (fabryczne procki mają ustawione taktowanie wewnętrznym generatorem RC 1Mhz, a takie taktowanie jest za wolne dla standardowej prędkości programatora. Żeby się dobrać do takiego procka w MkAvrCalculatorze musisz zaznaczyć "Auto SCK Speed" lub wybrać ręcznie wolniejsze działanie programatora, tzw Slow SCK czyli spowolnienie sygnału zegarowego programatora) Starsze programatory miały takową zworkę fizycznie na programatorze, której założenie powodowało że programator stawał się powolnym ślimakiem. W nowszych zworka została zastąpiona programową możliwością sterowania prędkości programowania poprzez wstawienie do linii komend avrduda odpowiedniego parametru np "-B 8"

hubss napisał(a):
Czy ktoś wie również jaka jest różnica między 328P a 328P-PU?
Różnica jest żadna, bo samo atmega 328P to nazwa kodowa procka, natomiast końcówka PU oznacza typ obudowy w jakiej jest wykonany czyli w Twoim wypadku PU - Plastic Dual Inline Package (PDIP) czyli poprostu DIP28 - rozwinięcie symboliki masz w nocie na samym początku po spisie treści.


Autor postu otrzymał pochwałę


Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 25 paź 2017, o 04:26 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 25261
Lokalizacja: Szczecin
Pomógł: 951

hubss napisał(a):
Czy ktoś wie również jaka jest różnica między 328P a 328P-PU?

to jest ten sam procek ;) tym się nie przejmuj

za to pokaż lepiej jakieś ze 2-3 wyraźne fotki jak ty to wszystko podłączyłeś na stykówce bo zapewne tu popełniłeś babola ale żeby pomóc to trzeba zobaczyć ;)

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 26 paź 2017, o 15:22 
Offline
Nowy

Dołączył(a): 24 paź 2017
Posty: 6
Pomógł: 0

Tutaj zdjęcia podłączenia. To jedyne kabelki męsko męskie jakie obecnie posiadam. Sprawdzałem brzęczkiem wszystkie kabelki są sprawne, zasilanie również jest.
ObrazekObrazek



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 26 paź 2017, o 20:52 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 25261
Lokalizacja: Szczecin
Pomógł: 951

pokaż pan to szerzej bo nie wiadomo czy stykówkę w ogóle dobrze podłączyłeś - nie widać też połączeń za bardzo - jakieś takie dwa wąskie zdjęcia że tak powiem

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 26 paź 2017, o 21:05 
Offline
Tech-support
Avatar użytkownika

Dołączył(a): 01 lis 2015
Posty: 1438
Lokalizacja: okolice Warszawa
Pomógł: 149

MOSI-BIALY
MISO-ŻÓŁTY
SCK_ZIELONY
wyglada OK. i w KANDA i na stykówce.
Ja staram się wpinać przewody dalej od procka.
Blaszki pod spodem płytki rozgięte nogą uc mogą nie łączyć z sąsiadującym tuż obok pinem przewodu.
albo coś innego jest problemem. ;)
czy połączone są szyny zasilania dolna i górna. (czasem lewa strona z prawą na łączeniu po środku)?

------------------------ [ Dodano po: 9 minutach ]

Jeżeli dobrze widzę - jeżeli we wtyku KANDA na zdjęciu jest widoczny środkowy zatrzask .
Bo przewody(taśma) na fotce wychodzą w przeciwną stronę niż te wpięte w programator. ?


Autor postu otrzymał pochwałę


Ostatnio edytowano 26 paź 2017, o 21:15 przez Daro69, łącznie edytowano 1 raz

Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 26 paź 2017, o 21:15 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 25261
Lokalizacja: Szczecin
Pomógł: 951

Daro69 napisał(a):
czy połączone są szyny zasilania dolna i górna. (czasem lewa strona z prawą na łączeniu po środku)?

dlatego pisałem wyżej o "szersze" zdjęcia ;)

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 29 paź 2017, o 21:07 
Offline
Nowy

Dołączył(a): 24 paź 2017
Posty: 6
Pomógł: 0

Dzięki za pomoc. Problem był w płytce stykowej. Brzęczek pokazywał, że wszystko OK ale po zmianie płytki w mkAVRCalculator wykrył.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 29 paź 2017, o 22:57 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 25261
Lokalizacja: Szczecin
Pomógł: 951

hubss napisał(a):
Dzięki za pomoc. Problem był w płytce stykowej. Brzęczek pokazywał, że wszystko OK ale po zmianie płytki w mkAVRCalculator wykrył.

Piękny wątek ;) pokazujący niewątpliwe "uroki" pracy na stykówkach i straty czasu ;)

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 30 paź 2017, o 10:25 
Offline
Użytkownik

Dołączył(a): 25 lip 2013
Posty: 2058
Pomógł: 97

Grunt, że się udało :)
Pokazany problem pokazuje też jedną bardzo ważną rzecz - nie ma takiego pomiaru, który by nie zakłócał mierzonego układu. Pomijam element wpływu podłączonego miernika, ale samego podłączenia/dociskania jego końcowek do mierzonych punktów. Zdarza się, że dociskając poprawiamy kontakt i wydaje nam sie, że wszystko jest w porządku.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 10 ] 

Strefa czasowa: UTC + 1


Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 3 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
Sitemap
Technologię dostarcza phpBB® Forum Software © phpBB Group phpBB3.PL
phpBB SEO