Kanał - ATNEL tech-forum
Wszystkie działy
Najnowsze wątki



Teraz jest 20 sie 2019, o 10:36


Strefa czasowa: UTC + 1





Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 6 ] 
Autor Wiadomość
PostNapisane: 25 sie 2017, o 07:38 
Offline
Nowy

Dołączył(a): 03 wrz 2015
Posty: 3
Pomógł: 0

Witam
Utworzyłem na partycji E:\ nowy folder workspace, pod nazwą "workspace_moj".
po uruchomienia ECLIPSE-MARS i pokazaniu nowego adresu folderu E:\workspace_moj napisałem program (swój) i podczas Build 'Release for project Skl_LCD' otrzymałem komunikat: "Aplikacja nie została właściwie uruchomiona (0xc0000142), kloknij przycisk PK, aby zakończyć aplikację".
W Konsoli otrzymałem następujący wpis:
08:33:18 **** Incremental Build of configuration Release for project Skl_LCD ****
make all
Building file: ../main.c
Invoking: AVR Compiler
avr-gcc -Wall -Os -fpack-struct -fshort-enums -ffunction-sections -fdata-sections -std=gnu99 -funsigned-char -funsigned-bitfields -mmcu=atmega32a -DF_CPU=8000000UL -MMD -MP -MF"main.d" -MT"main.o" -c -o "main.o" "../main.c"
make: *** [main.o] Błąd -1073741502

08:35:29 Build Finished (took 2m:10s.818ms)

Proszę o pimoc :( .
Orinoko



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 25 sie 2017, o 08:30 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 24681
Lokalizacja: Szczecin
Pomógł: 924

bo nie zainstalowałeś pewnie toolchaina albo masz jakiś koci antywir który ci go zeżarł

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 25 sie 2017, o 09:20 
Offline
Nowy

Dołączył(a): 03 wrz 2015
Posty: 3
Pomógł: 0

Witam ponownie.
Dzięki za odpowiedź. Noże to wirus, bo przez dwa miesiące wszystko było OK.
Mam jednak zainstalowany od kilku miesięcy antywirus KASPERSKY i jeżeli to wirus to go przepuścił.
Próbowałem zainstalować ponownie tookchain'a ale się nie da, więc wszystko ponownie zainstaluję po wcześniejszym odinstalowaniu.
Serdeczne dzięki za szybką reakcję na moją prośbę.
Z poważaniem
Orinoko



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 25 sie 2017, o 09:25 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 24681
Lokalizacja: Szczecin
Pomógł: 924

ja nie pisałem że wirus ci to zrobił tylko antywirus ci to mógł zrobić i tak się często dzieje - jak ludzie sobie włączają w antywirusach wszystkie opcje - np do wykrywania potencjalnych zagrożeń ... to CHLAST i po kompilatorze ... toż to zmora programistów. Jak chcesz być programistą to musisz się nauczyć obsługiwać dobrze programy antywirusowe i wyłączyć połowę ich czasem durnych funkcji. I nie mówię tu o konkretnym programie X czy Y tylko w ogóle o antywirusach

weź że go sobie wyłącz w ogóle np na 10 minut - zainstaluj toolchaina i zobacz czy działa

nie mówię że to na 100% ten przypadek u ciebie ale już tyyyyle razy na forum u ludzi było to powodem że szok - dlatego o tym piszę

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 25 sie 2017, o 10:15 
Offline
Nowy

Dołączył(a): 03 wrz 2015
Posty: 3
Pomógł: 0

Witam
Serdeczne dzięki za wszystko. OK
Z powazaniem
Orinoko



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 25 sie 2017, o 10:30 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 22 paź 2013
Posty: 1629
Lokalizacja: Lipsko
Pomógł: 116

Albo pozbyć się wszelkich antywirów i na to miejsce zainstalować sobie, np. Shadow defender. O regularnych backupach już nie wspomnę. Nie mam antywira od chyba 2003 roku i (odpukać) jeszcze żadnych problemów z wirusami. Troszkę zdrowego rozsądku, dyscypliny i nawet stary komp będzie śmigał jak szalony z programami do elektroniki :)

_________________
http://www.sylwekkuna.com



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 6 ] 

Strefa czasowa: UTC + 1


Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 0 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
Sitemap
Technologię dostarcza phpBB® Forum Software © phpBB Group phpBB3.PL
phpBB SEO