Kanał - ATNEL tech-forum
Wszystkie działy
Najnowsze wątki



Teraz jest 15 paź 2019, o 05:13


Strefa czasowa: UTC + 1





Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 1 ] 
Autor Wiadomość
PostNapisane: 4 sie 2019, o 19:38 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 17 lip 2013
Posty: 200
Lokalizacja: Kielce
Pomógł: 15

Szanowni Koledzy,

Pytanie dotyczy biblioteki z wątku https://forum.atnel.pl/topic10813.html

Jako, że w/g tego:

https://techdocs.altium.com/display/FPGA/NEC+Infrared+Transmission+Protocol

Nec koduje dane od LSB, więc ramkę z załącznika powinien odczytywać:

address 0x04; command 0x72

Natomiast w/g biblioteki zamieszczonej w tym wątku, odczytywane jest:

address 0x20, command 0x4E

Obrazek


Tak więc proszę o sprawdzenie czy moje rozumowanie jest poprawne i czy poniższe zmiany w kodzie są ok:

nec.c
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.


nec.h
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.


Załączniki:

Aby zobaczyć załączniki musisz się zalogować. Tylko zalogowani użytkownicy mogą oglądać i pobierać załączniki.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 1 ] 

Strefa czasowa: UTC + 1


Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 4 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
Sitemap
Technologię dostarcza phpBB® Forum Software © phpBB Group phpBB3.PL
phpBB SEO