Kanał - ATNEL tech-forum
Wszystkie działy
Najnowsze wątki



Teraz jest 21 kwi 2019, o 21:45


Strefa czasowa: UTC + 1





Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 14 ] 
Autor Wiadomość
PostNapisane: 23 lip 2013, o 11:36 
Offline
Nowy

Dołączył(a): 23 lip 2013
Posty: 13
Pomógł: 0

Dzień dobry. Po powrocie z wakacj, gdy postanowiłem znów pobawić się ze swoim atb 1.04 mój eclips postanowił zrobić mi na złość przestając działać :( oglądałem wszystkie odcinki związane z jego instalacją jednak nie udało mi się pokonać tej przeszkody:) a mianowicie przy próbie zgrania jakiegoś projektu przykładowo z książki ecclips zwraca mi taki komunikat

,,Launching C:\avrdude\avrdude -pm32 -cATB-FT232R -Uflash:w:12_Silnik_DC.hex:a
Output:
avrdude: invalid portname lpt1: use ft0 - ft9
avrdude finished"

Jak ktoś ma chwilkę i wie jak to naprawić :) będe wdzięczny.

------------------------ [ Dodano po: 6 minutach ]

zapomniałem dodać mkAVR Calculator normalnie widzi procesor :)

_________________
Michał R ^^



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 23 lip 2013, o 11:56 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 04 paź 2011
Posty: 8733
Pomógł: 336

Wygląda mi na to ze próbujesz programować przez FT-ATB na porcie LPT , ustaw w ustawieniach prawidłowy port com lub użyj programiku który robi konfig dla ATB-FT232


Autor postu otrzymał pochwałę

_________________
╔═════════════════╗
║.: https://forum.sunduino.pl



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 23 lip 2013, o 12:04 
Offline
Nowy

Dołączył(a): 23 lip 2013
Posty: 13
Pomógł: 0

nie pomogło ustawilem port COM3 tak jak pokazuje mkAVR Calculator i pokazuje sie coś takiego

Launching C:\avrdude\avrdude -pm32 -cATB-FT232R -PCOM3 -Uflash:w:12_Silnik_DC.hex:a
Output:
avrdude: invalid portname COM3: use ft0 - ft9
avrdude finished

_________________
Michał R ^^



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 23 lip 2013, o 12:12 

Pomógł: 0

No bo ATB ma być własnie na ft0, ustaw ft0 a nie jakieś tam comy.
Avrduda masz zainstalowanego, scieżki w eclissie do avrdude ustawione prawidłowo?


Autor postu otrzymał pochwałę


Góra
  
cytowanie selektywne  Cytuj  
PostNapisane: 23 lip 2013, o 12:16 
Offline
Nowy

Dołączył(a): 23 lip 2013
Posty: 13
Pomógł: 0

Dzięki wielkie :)

_________________
Michał R ^^



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 1 lis 2013, o 20:38 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 29 sie 2013
Posty: 137
Lokalizacja: śląskie
Pomógł: 13

Witam.

Podpinam się pod temat,bo po co pisać nowy jak po "ciężkich bólach" :) znalazłem gotową receptę.
Za co też kolegom bardzo dziękuję.

Miałem identyczny problem ale dzięki powyższym postom problem rozwiązany,
natomiast w związku z powyższym mam takie pytanie,dlaczego w Eclipsie trzeba właśnie ustawić port na f0 skoro ATBmanager
wykrywa i wyświetla mi port COM3? :o

Bardzo proszę o wyjaśnienia doświadczonych Kolegów.

_________________
sig off ;(



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 1 lis 2013, o 22:46 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 14 lis 2011
Posty: 1557
Lokalizacja: Przemyśl / Kraków
Pomógł: 56

COM3 jest to numer wirtualnego portu COM...

Jednak do programowania (również w calculatorze wszak) nie używamy portu COM, ale jednego z dodatkowych trybów scalaków FT232, jakim jest Bit-Bang. A do tego trybu numer portu COM jest mało przydatny, musimy mieć ID scalaka, które jest nadane przez sterownik w naszym komputerze, czyli ft0. Port COM wyświetlany przez ATB Manager może się przydać np w PuTTY.

Aaa i ATB Manager jest "deprecated" :)



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 1 lis 2013, o 22:58 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 29 sie 2013
Posty: 137
Lokalizacja: śląskie
Pomógł: 13

Dzięki Kolego za szczegółowe wyjaśnienie, co nie co poszerzyło mi to wiedzę bo jak pewno się domyślasz to dopiero "raczkuję" :oops:
w temacie.

Kurcze a straciłem mnóstwo czasu żeby dociec sedna sprawy,czyli w ostateczności i tak znaleźć tą inf. :)

_________________
sig off ;(



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 lis 2013, o 01:17 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 24279
Lokalizacja: Szczecin
Pomógł: 914

GwynBleidD napisał(a):
Aaa i ATB Manager jest "deprecated"


:lol: super określenie

a co do wyjaśnień - to widać, że niewielu użytkowników zestawów ATB śledzi bloga ale też forum... a przecież tu jest o wszystkim mowa:

http://mirekk36.blogspot.com/2013/10/re ... torze.html

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 lis 2013, o 09:04 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 29 sie 2013
Posty: 137
Lokalizacja: śląskie
Pomógł: 13

Witam.

Panie Mirku śledzi,śledzi tyle że to dla początkującego to jest ogrom materiału i może się wszystko pogmatwać,
szczególnie,że w tej materii należę do typu "CKM" :lol:
Dla ciekawych mogę przy okazji rozwinąć ten skrót. ;)



Pozdrawiam.

_________________
sig off ;(



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 lis 2013, o 14:09 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 14 lis 2011
Posty: 1557
Lokalizacja: Przemyśl / Kraków
Pomógł: 56

mirekk36 napisał(a):
:lol: super określenie


No niestety polskie tłumaczenie nie oddaje tak dobrze sensu... a szkoda ;)

Polecałbym gdzieś umieścić wielką czcionką oficjalne obwieszczenie o tym, że funkcjonalność ATB Managera została wsiąknięta przez Calculator (na spółkę z avrdude zawartym w Calculatorze) i nie jest już on potrzebny do niczego :)



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 1 cze 2014, o 23:12 
Offline
Nowy

Dołączył(a): 08 kwi 2014
Posty: 2
Pomógł: 0

SunRiver napisał(a):
Wygląda mi na to ze próbujesz programować przez FT-ATB na porcie LPT , [b]ustaw w ustawieniach prawidłowy port[/b] com lub użyj programiku który robi konfig dla ATB-FT232


Gdzie są te ustawienia?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 cze 2014, o 17:45 
Offline
Nowy

Dołączył(a): 08 kwi 2014
Posty: 2
Pomógł: 0

korm napisał(a):
SunRiver napisał(a):
Wygląda mi na to ze próbujesz programować przez FT-ATB na porcie LPT , [b]ustaw w ustawieniach prawidłowy port[/b] com lub użyj programiku który robi konfig dla ATB-FT232


Gdzie są te ustawienia?


juz wiem...

zaznacz swoj_plik_c_np_main.c ->Project ->Properties -> AVR -> AVRDude-> Programmer ->W_moim_przypadku_ATB_ft232 i teraz pod listą wyboru programatorów masz 'Override default port -P" tu wpisujesz to co mkcalculator tobie wykrył, u mnie ft0 i działa.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 25 sty 2019, o 12:24 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 31 gru 2014
Posty: 86
Pomógł: 2

no dzięki korm, do programowanie nie stosowałem przejściówki ATB-USB-RS232 aż w końcu musiałem no i zabolało (invalid portname lpt1: use ft0 - ft9) , nie spodziewałem się tego problemu, dzięki Tobie nie musiałem długo drapać się po głowie.

Uzupełnienie do mojego poprzedniego wpisu: kilka dni temu po modernizacji PC ponownie „wrzucałem” Eclipse Mars ora Photon, oglądając poradniki Mirka dotyczące Eclipse (precyzyjniej poradnik #0232 ECLIPSE MARS 8 minuta) szczegółowo omówiony jest proces definiowania programatora ATB-FT232R (przejściówka RS232) w Eclipse, proponuję zajrzeć.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 14 ] 

Strefa czasowa: UTC + 1


Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 0 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
Sitemap
Technologię dostarcza phpBB® Forum Software © phpBB Group phpBB3.PL
phpBB SEO