Kanał - ATNEL tech-forum
Wszystkie działy
Najnowsze wątki



Teraz jest 23 wrz 2019, o 08:16


Strefa czasowa: UTC + 1





Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 5 ] 
Autor Wiadomość
PostNapisane: 1 wrz 2019, o 10:18 
Offline
Nowy

Dołączył(a): 01 wrz 2019
Posty: 1
Pomógł: 0

Witam, konfigurowałem dziś eclipse tak aby móc na nim programować mikrokontrolery avr. Starałem się zrobić wszystko według poradnika Pana Mirka jednak przy próbie kompilacji testowego programu (miganie LED'em) w konsoli pojawia się błąd:
11:14:39 **** Incremental Build of configuration Release for project LED_BLINK ****
make all
'Building file: ../main.c'
'Invoking: AVR Compiler'
avr-gcc -Wall -Os -fpack-struct -fshort-enums -ffunction-sections -fdata-sections -std=gnu99 -funsigned-char -funsigned-bitfields -mmcu=atmega8 -DF_CPU=8000000UL -MMD -MP -MF"main.d" -MT"main.o" -c -o "main.o" "../main.c"
The current directory is invalid.
make: *** [main.o] Błąd 1

11:14:39 Build Finished (took 392ms)

Prawdopodobnie coś zrobiłem źle, jednak nie mam pojęcia co

Tutaj wrzucam kod:

#include <avr/io.h>
#include <util/delay.h>

int main(void){
DDRB |= (1<<PB2);
while(1){
PORTB ^= (1<<PB2);
_delay_ms( 500 );


}
}



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 1 wrz 2019, o 13:11 
Offline
Użytkownik

Dołączył(a): 24 sty 2012
Posty: 1404
Pomógł: 54

detmot5 napisał(a):
Witam, konfigurowałem dziś eclipse tak aby móc na nim programować mikrokontrolery avr. Starałem się zrobić wszystko według poradnika Pana Mirka jednak przy próbie kompilacji testowego programu (miganie LED'em) w konsoli pojawia się błąd:
11:14:39 **** Incremental Build of configuration Release for project LED_BLINK ****
make all
'Building file: ../main.c'
'Invoking: AVR Compiler'
avr-gcc -Wall -Os -fpack-struct -fshort-enums -ffunction-sections -fdata-sections -std=gnu99 -funsigned-char -funsigned-bitfields -mmcu=atmega8 -DF_CPU=8000000UL -MMD -MP -MF"main.d" -MT"main.o" -c -o "main.o" "../main.c"
The current directory is invalid.
make: *** [main.o] Błąd 1

11:14:39 Build Finished (took 392ms)

Prawdopodobnie coś zrobiłem źle, jednak nie mam pojęcia co

Tutaj wrzucam kod:

#include <avr/io.h>
#include <util/delay.h>

int main(void){
DDRB |= (1<<PB2);
while(1){
PORTB ^= (1<<PB2);
_delay_ms( 500 );


}
}

Pierwsza sprawa to wstaw poprawnie kod.
Eclipse podpowiada gdzie masz błąd:
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.

Pokaż jakie masz katalogi

_________________
Jestem początkujący i moje porady mogą być błędne



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 6 wrz 2019, o 07:04 
Offline
Użytkownik

Dołączył(a): 25 lip 2013
Posty: 1886
Pomógł: 88

Nie masz przypadkiem ścieżek z odstępami lub polskimi znakami?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 6 wrz 2019, o 09:31 
Offline
Użytkownik

Dołączył(a): 14 sie 2016
Posty: 672
Pomógł: 29

Albo sam Eclipse ma za długą ścieżkę.

_________________
Moje porady są błędne,nie czytać,zbanować od razu.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 7 wrz 2019, o 08:03 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 17 lip 2013
Posty: 200
Lokalizacja: Kielce
Pomógł: 15

A zapisałeś plik na dysku przed kompilacją?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 5 ] 

Strefa czasowa: UTC + 1


Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 0 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
Sitemap
Technologię dostarcza phpBB® Forum Software © phpBB Group phpBB3.PL
phpBB SEO