Kanał - ATNEL tech-forum
Wszystkie działy
Najnowsze wątki



Teraz jest 14 gru 2018, o 14:08


Strefa czasowa: UTC + 1





Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 3 ] 
Autor Wiadomość
PostNapisane: 8 gru 2018, o 14:23 
Offline
Użytkownik

Dołączył(a): 13 paź 2015
Posty: 70
Lokalizacja: Rybnik
Pomógł: 2

Witam,

Mam problem z regulacją jasności wyświetlacza. Wlutowałem fotorezystor 16-50k zamiast 16-39k. Czy regulacja jasności będzie działać przy takim fotorezystorze?

Uruchamiam lekcję 08_MATRIX_TEST_m328P i niezależnie czy świecę latarką po fotorezystorze czy zakryję go ciemną pokrywką to wyświetlacz świeci z taką samą jasnością. Nawet jak wyłącze PWM:
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.

To jest bez różnicy.

Mam szukać innego fotorezystora czy można to jakoś dopasować? Czytam kilka razy rozdział 1.10.3 o PWM z YB i nadal nie wiem co zmienić w programie aby dopasować mój fotorezystor.

Pozdrawiam.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 8 gru 2018, o 19:09 
Offline
Użytkownik

Dołączył(a): 05 gru 2017
Posty: 60
Pomógł: 2

Cześć Tom92

Jakiś czas temu też musiałem dobrać fotorezystor do regulacji jasności w matrixsie
Może moje zmiany i u Ciebie zadziałają i pomogą w projekcie

Obrazek


Masz troszkę większy fotorezystor 16-50k zamiast 16-39k to jest 11k różnicy,
więc zamiast rezystora 56k jaki jest na schemacie daj 10k mniej czyli 46k

jeszcze możesz pokombinować z kodem (regulacja jasności ) w pliku common.c
ale zapisuj sobie w komentarzu co zmieniłeś aby sobie nie namieszać i w razie czego
łatwo poprawić

Podaję kod gdzie jeszcze możesz dostroić jasność - PLIK - common.c


Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.


Autor postu otrzymał pochwałę


Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 10 gru 2018, o 22:31 
Offline
Użytkownik

Dołączył(a): 13 paź 2015
Posty: 70
Lokalizacja: Rybnik
Pomógł: 2

Wielkie dzięki miki53, co prawda jeszcze nie doszedłem w YB do tej funkcji ale już wiem jak działać.

Dziękuję bardzo za wyczerpującą odpowiedź.

Pozdrawiam.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 3 ] 

Strefa czasowa: UTC + 1


Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 0 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
Sitemap
Technologię dostarcza phpBB® Forum Software © phpBB Group phpBB3.PL
phpBB SEO