Kanał - ATNEL tech-forum
Wszystkie działy
Najnowsze wątki



Teraz jest 21 lis 2018, o 11:08


Strefa czasowa: UTC + 1





Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 22 ] 
Autor Wiadomość
PostNapisane: 9 wrz 2018, o 11:56 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 03 lip 2017
Posty: 129
Pomógł: 6

Witam, na podstawie bb odpaliłem program testowy, zapisując ówcześnie plik na karcie tak jak zalecono, przejściówkę podłączyłem mosi do mosi etc, zmieniłem w programie definicje pinów oraz fragment z pinem ss PB4 na PB2, efektem jest napis "open file error". Użyta przeze mnie przejściówka ma zarówno stabilizator jak i konwersje napięć. Rejestry od SPI dla atmeg32 i 328 są takie same. Sprawdziłem również inną kartę, efekt ten sam. Gdzie szukać błędu?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 10 wrz 2018, o 16:48 
Offline
Użytkownik

Dołączył(a): 02 gru 2015
Posty: 277
Pomógł: 18

Jeśli robisz to na atmega 32 to podciągnij pin PB4 programowo do vcc i ustaw jako wyjście bo to powoduje "niewłaściwe" ( jako slave )działanie SPI i stąd kłopot w nocie masz to opisane.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 10 wrz 2018, o 22:39 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 03 lip 2017
Posty: 129
Pomógł: 6

Tak właśnie jest napisane w bibliotece z bb

Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.


Używam atmegi328



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 10 wrz 2018, o 22:52 
Offline
Użytkownik

Dołączył(a): 14 sie 2016
Posty: 600
Pomógł: 24

Kartę masz na pewno jako FAT i nazwa pliku dużymi literami?

Wysłane ze srajfona

_________________
Moje porady są błędne,nie czytać,zbanować od razu.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 10 wrz 2018, o 23:23 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 03 lip 2017
Posty: 129
Pomógł: 6

W bb jest małymi literami, a w bibliotece
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.


Nie mniej próbowałem też wielkimi i dalej efekt ten sam, i jak sprawdzić czy "kartę mam jako FAT"?

We właściwościach jedna z kart ma napisane FAT, druga FAT32



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 11 wrz 2018, o 01:33 
Offline
Użytkownik

Dołączył(a): 14 sie 2016
Posty: 600
Pomógł: 24

DarkMajster napisał(a):
We właściwościach jedna z kart ma napisane FAT, druga FAT32

Czyli jest ok, ta pierwsza to fat16, albo VFAT, co praktycznie na jedno wychodzi.

_________________
Moje porady są błędne,nie czytać,zbanować od razu.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 15 wrz 2018, o 20:36 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 03 lip 2017
Posty: 129
Pomógł: 6

Czy ktoś wie, czy może problem jest w zamianie atmegi32 na 328?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 16 wrz 2018, o 09:21 
Offline
Użytkownik

Dołączył(a): 02 gru 2015
Posty: 277
Pomógł: 18

nie racze nie moim zdaniem masz problem z zasilaniem sprawdź je dobrze czy na pewno masz 5v bo to ma duże znaczenie. P.S daj zdjęcie na czym to odpalasz zdjęcie przejściówki .



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 16 wrz 2018, o 09:36 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 04 cze 2014
Posty: 752
Lokalizacja: pod Warszawą
Pomógł: 55

cześć
stosujesz funkcję włączania zasilania przed otwarciem pliku?
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.

_________________
Pomóżcie mi stanąć na nogi



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 16 wrz 2018, o 14:02 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 03 lip 2017
Posty: 129
Pomógł: 6

mczarny - a powinienem :D? Biblioteka prawie 1:1 z BB

ObrazekObrazek

Scalaki - LVC125A i stabilizator 3,3V



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 16 wrz 2018, o 18:18 
Offline
Użytkownik

Dołączył(a): 02 gru 2015
Posty: 277
Pomógł: 18

tego modułu używałem i u mnie działał pokaż jeszcze do czego to podłączasz i zmierz koniecznie napięcie zasilania i napisz.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 16 wrz 2018, o 19:31 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 04 cze 2014
Posty: 752
Lokalizacja: pod Warszawą
Pomógł: 55

DarkMajster napisał(a):
mczarny - a powinienem :D? Biblioteka prawie 1:1 z BB

Jak widzę to ten moduł nie ma tranzystora do włączenia i wyłączenia zasilania. Mnie się zdarzyło, podobne zachowanie na tym module
Obrazek
mało tego na jednej z kart po prostu wgrane pliki poszły w kosmos. Dorobiłem włączanie zasilania przed otwarciem plików i od tego czasu mam spokój.
Jak testowałeś program na ATB to tam masz układ włączenia zasilania więc.....

_________________
Pomóżcie mi stanąć na nogi



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 16 wrz 2018, o 20:28 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 03 lip 2017
Posty: 129
Pomógł: 6

Podłączam CS do CS, SCK do SCK, MOSI do MOSI, MISO do MISO...

mczarny - przed robieniem w programie czegokolwiek z kartą mam dopiero włączyć zasilanie dla modułu, a po wyłączyć?

Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 16 wrz 2018, o 21:09 
Offline
Użytkownik

Dołączył(a): 02 gru 2015
Posty: 277
Pomógł: 18

a w pliku mmc.c zmieniłeś linie 36,37,38?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 16 wrz 2018, o 21:13 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 03 lip 2017
Posty: 129
Pomógł: 6

Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.
?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 16 wrz 2018, o 21:31 
Offline
Użytkownik

Dołączył(a): 02 gru 2015
Posty: 277
Pomógł: 18

Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 16 wrz 2018, o 21:33 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 03 lip 2017
Posty: 129
Pomógł: 6

To tak, zmieniałem



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 16 wrz 2018, o 21:36 
Offline
Użytkownik

Dołączył(a): 02 gru 2015
Posty: 277
Pomógł: 18

w bibliotece PetitFs w pliku mmc.c?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 16 wrz 2018, o 22:23 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 03 lip 2017
Posty: 129
Pomógł: 6

Tak

Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 17 wrz 2018, o 13:08 
Offline
Użytkownik

Dołączył(a): 02 gru 2015
Posty: 277
Pomógł: 18

na co to wgrywasz zestaw, płytka stykowa ,jakiś własny projekt ? pokaż
i wrzuć plik hex sprawdzę u siebie czy działa.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 18 wrz 2018, o 22:57 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 03 lip 2017
Posty: 129
Pomógł: 6

Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.


atmega328, 16MHz, main.c kilka postów wyżej

wszystko na stykówce, sprawdzone


Załączniki:

Aby zobaczyć załączniki musisz się zalogować. Tylko zalogowani użytkownicy mogą oglądać i pobierać załączniki.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 19 wrz 2018, o 17:07 
Offline
Użytkownik

Dołączył(a): 02 gru 2015
Posty: 277
Pomógł: 18

U mnie twój kod działa na takim samym czytniku kart .

Obrazek

Więc sprawdź dobrze swoje połączenia i stykówkę.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 22 ] 

Strefa czasowa: UTC + 1


Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 2 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
Sitemap
Technologię dostarcza phpBB® Forum Software © phpBB Group phpBB3.PL
phpBB SEO