Kanał - ATNEL tech-forum
Wszystkie działy
Najnowsze wątki



Teraz jest 18 wrz 2019, o 08:28


Strefa czasowa: UTC + 1





Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 17 ] 
Autor Wiadomość
PostNapisane: 13 gru 2012, o 16:15 
Offline
Użytkownik

Dołączył(a): 19 paź 2012
Posty: 45
Pomógł: 0

Witam , o co chodzi z tą kompilacją. Eclips Indigo , Toolchain 3.4.
Obrazek

------------------------ [ Dodano po: 24 minutach ]

Dodam , że zmianie ścieżek do nowego toolchaina 3.4 komunikaty znikły natomiast pojawił się taki:

Obrazek


No właśnie w zakładce projektu, tam gdzie powinna być lista ukontrolerów ich tam nie ma. Dodam ,że podmieniłem plik de.innot.avreclipse.core_2.4.0.201203041437 tak jak w tutorialu, choć przypominam sobie że za pierwszym razem nie było tego pliku. Dodam ,że pierwszą wersję wziąłem z katologu ATMEL_Toolchain_3.4, dopiero później wziąłem tą nowszą wersję AVR_plugin_patch_jar. Choć to chyba nie robi żadnej różnicy. :?:

Wydzielono do nowego tematu. Zielony J.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 13 gru 2012, o 16:40 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 04 paź 2011
Posty: 8745
Pomógł: 336

pokaż okno konsoli całe po kliknięciu na BUILD


choć wydaje mi się że jak podświetlisz main.c i dasz CLEAR a potem BUILD to będzie OK

_________________
╔═════════════════╗
║.: https://forum.sunduino.pl



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 13 gru 2012, o 17:02 
Offline
Użytkownik

Dołączył(a): 19 paź 2012
Posty: 45
Pomógł: 0

Wyczyściłem projekt, który po zmianie ścieżek komplijue się , ale nie ma listy atmela w zakładce Target Hardware.

------------------------ [ Dodano po: 6 minutach ]

Niestety nie zauważyłem , po wgraniu zielonego paska występuje ten sam komunikat co na pierwszym obrazku, tylko że przetłumaczony po polsku.
**** Build of configuration Default for project 04_LCD ****

make all
make: *** Brak reguł do wykonania obiektu `all'. Stop.

**** Build Finished ****
No i ciągle nie ma listy ukontrolerów.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 13 gru 2012, o 17:31 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 04 paź 2011
Posty: 8745
Pomógł: 336

dobrze to teraz żeby mieć listę procków poszukaj na forum lub na blogu mirka.
http://www.mirekk36.blogspot.com/2012/1 ... chain.html

_________________
╔═════════════════╗
║.: https://forum.sunduino.pl



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 13 gru 2012, o 17:56 
Offline
Użytkownik

Dołączył(a): 19 paź 2012
Posty: 45
Pomógł: 0

Ja ten plik wgrałem , przecie pisałem to w poście wyżej



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 13 gru 2012, o 18:08 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 04 paź 2011
Posty: 8745
Pomógł: 336

może źle wgrałeś , bo niema możliwości żeby nie działało

masz go podmienić ... windows czasem dziwne rzeczy wyprawia

_________________
╔═════════════════╗
║.: https://forum.sunduino.pl



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 13 gru 2012, o 18:21 
Offline
Użytkownik

Dołączył(a): 19 paź 2012
Posty: 45
Pomógł: 0

Otóż to, po pierwsze w folderze plugins w eclipsie nie było takiego pliku, ale to mniejsza z tym, w każdym bądź razie wgrałem ten plik do tego folderu. I tak wygląda okno, chciałem powiedzieć że od samego początku nie było tej listy.

Obrazek



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 13 gru 2012, o 18:27 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 04 paź 2011
Posty: 8745
Pomógł: 336

to oznacza już tylko jedno

źle ci sie zainstalował sam plugin do AVR

odinstaluj i zainstaluj go na nowo następnie sprawdź poprawność działania z WinAVR2010xxxxx
jęśli działa prawidłowo lista jest i nie ma mowy żeby tego pliku nie było
potem zmień ścieżki na toolchain ATmela sprawdź lista bedzie taka jak teraz masz i podmień ten plik...


Dlatego że jego nieobecność nie jest możliwa w prawidłowej instalacji plugina AVR2.4

_________________
╔═════════════════╗
║.: https://forum.sunduino.pl



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 13 gru 2012, o 18:37 
Offline
Użytkownik

Dołączył(a): 19 paź 2012
Posty: 45
Pomógł: 0

Ok. biorę się do dzieła , bo kurna stoję w miejscu od paru godzin. Oczywiście dodam , zę po zmanie na ścieżki system jest lista:

Obrazek


ale spróbuję jeszcze raz wgrać ten nowy plugin AVR 3.4



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 13 gru 2012, o 18:39 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 04 paź 2011
Posty: 8745
Pomógł: 336

zobacz :

Obrazek

Po świeżej instalacji pluginu AVR do świeżego eclipse plik ten jest w folderze eclipse/plugins/

i ma takie parametry:

Obrazek

a po zmianie na poprawiony dla toolchaina ATMEL 3.4

Obrazek

_________________
╔═════════════════╗
║.: https://forum.sunduino.pl



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 13 gru 2012, o 19:05 
Offline
Użytkownik

Dołączył(a): 19 paź 2012
Posty: 45
Pomógł: 0

Nie wiem, co jest grane reinstalowałem na nowo plugina AVR3.4. Nic dalej nie widzi procków, mimo że w starym pluginie widział. Z tym, ze nawet w starym jak chciałem wgrać do mikrokontrolera to też krzyczał, ze nie ma listy ukontrolerów. Jescze raz wgrałem ten starszy toolchain z 2010 r oto zdjecie:

Obrazek

czyli jak widać brakuje plików tych do podmiany, czyli tu coś jest nie tak.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 13 gru 2012, o 19:10 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 04 paź 2011
Posty: 8745
Pomógł: 336

podmień na właściwy jest na moim droopboxie w folderze /pozostałe
https://www.dropbox.com/sh/cbeg0bzsf3lcjqz/dIbt2n-BXZ

------------------------ [ Dodano po: 1 minucie ]

jak ci nie zadziała to zainstaluj TeamViewer7 i łap mnie na czacie forumowym lub na jaberze

_________________
╔═════════════════╗
║.: https://forum.sunduino.pl



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 13 gru 2012, o 20:46 
Offline
Użytkownik

Dołączył(a): 19 paź 2012
Posty: 45
Pomógł: 0

Ok. znalazłem błąd w trakcie wgrywania plugina AVR 2.4 wystąpił jakiś błąd, dobrze kierowałeś. Dzięki.Trochę to czasu zajęło.

------------------------ [ Dodano po: 1 minucie ]

Teraz faktycznie są te pliki.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 13 gru 2012, o 21:14 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 04 paź 2011
Posty: 8745
Pomógł: 336

No widzisz ... na eclipse zęby zjadłem :) więc wiesz :)
i teraz powinno wszystko hulać :)

_________________
╔═════════════════╗
║.: https://forum.sunduino.pl



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 14 gru 2012, o 08:24 

Pomógł: 0

U mnie problemem okazał się winrar, który nie widzi długich ścieżek, bo Paczki od Suna i Mirka miałem zagrzebane dosyć głęboko ;), ale po użyciu 7zip ruszyło od strzała.
Miałem podobne problemy jak kolega wyżej, zainstalowany toolchain a eclipse go albo nie widział, albo nie było listy procesorów. Po podmianie plików zgodnie z kursem Mirka i użyciu 7zip ruszyło od strzała.



Góra
  
cytowanie selektywne  Cytuj  
PostNapisane: 14 gru 2012, o 16:02 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 04 paź 2011
Posty: 8745
Pomógł: 336

no niestety kiedys winrar był oki , a teraz kuleje i nie nadąża za konkurencją choćby w długości ścieżek ....

_________________
╔═════════════════╗
║.: https://forum.sunduino.pl



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 14 gru 2012, o 16:22 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 14 lis 2011
Posty: 1556
Lokalizacja: Przemyśl / Kraków
Pomógł: 56

Właściwie nie dziwi mnie to... Przecież nikt o zdrowych zmysłach nie kupuje licencji na WinRARa, więc nie mają za bardzo z czego go utrzymywać :)



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 17 ] 

Strefa czasowa: UTC + 1


Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 0 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
Sitemap
Technologię dostarcza phpBB® Forum Software © phpBB Group phpBB3.PL
phpBB SEO