Kanał - ATNEL tech-forum
Wszystkie działy
Najnowsze wątki



Teraz jest 20 sie 2018, o 11:27


Strefa czasowa: UTC + 1





Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 33 ]  Przejdź na stronę 1, 2  Następna strona
Autor Wiadomość
PostNapisane: 1 lut 2018, o 16:30 
Offline
Użytkownik

Dołączył(a): 31 sty 2018
Posty: 38
Lokalizacja: Tarnów
Pomógł: 0

Witam wszystkich forumowiczów. Nazywam się Grzesiek pochodzę z Tarnowa w Małopolsce, od kilku dni jestem fanem Pana Mirka zakupiłem programator ATB-USBASP ver 4.1 wraz z MkAvrCalculator.
Wiem wiem powinienem zacząć zakup od blue-booka ale na to przyjdzie czas jak to się mawia po dziesiątym ;) .Ale do brzegu programator działa miodzio razem z MkAvrCalculator jako nowicjusz nie miałem żadnego problemu z podłączeniem, opisy są tak dokładne że naprawdę tylko osoby nieumiejące czytać ze zrozumieniem mogą mieć z tym problem, bynajmniej takie jest moje osobiste odczucie. Wracając do rzeczy w MkAvrCalculator bardzo szybko bezproblemowo wykryłem kontroler na celowniku malutka attiny13a tak na początek, sprawdziłem taktowanie i pobrałem program MkClipse chciałem w końcu zobaczyć jak to maleństwo się ożywia :D skonfigurowałem program pod attiny13a i wgrywam pierwsze polecenia.Na początek chciałem ustawić na PB4 stan wysoki tak aby zapalić diodę led, wiec w Pisze tak
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.
Program się kompiluje i wgrywa bez błędu tak mi się bynajmniej wydaje bo w konsoli wygląda to tak:
Cytuj:
Please wait ...
avrdude_mk.exe: set SCK frequency to 93750 Hz
avrdude_mk.exe: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% -0.00s

avrdude_mk.exe: Device signature = 0x1e9007
avrdude_mk.exe: NOTE: FLASH memory has been specified, an erase cycle will be performed
To disable this feature, specify the -D option.
avrdude_mk.exe: erasing chip
avrdude_mk.exe: set SCK frequency to 93750 Hz
avrdude_mk.exe: reading input file "c:\\dioda\Release\dioda.hex"
avrdude_mk.exe: writing flash (76 bytes):

Writing | ################################################## | 100% 0.06s

avrdude_mk.exe: 76 bytes of flash written

avrdude_mk.exe: safemode: Fuses OK

avrdude_mk.exe done. Thank you.

Compiled special for http://forum.atnel.pl (v5.11.1)

**** [total upload time: 1 068 ms ] ****
i tu pojawia się rozczarowanie na PB4 nic się nie dzieje dioda się nie świeci sprawdzam wiec miernikiem a tu dalej nic czy szanowni Panowie zgromadzeni w tym oto miejscu podpowiedzą w czym tkwi problem ;) Nosze się z zamiarem zakupu książek ale będzie to miało sens jeśli uda mi się cokolwiek prostego zrobić, takiego jak np. ustawienie portu jako wysoki lub niski. Tu opis attiny13a na którym się opierałem:
Obrazek



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 1 lut 2018, o 16:39 
Offline
Nowy
Avatar użytkownika

Dołączył(a): 03 gru 2014
Posty: 18
Pomógł: 3

Witam
Myślę, że książka by się bardzo przydała, ale podpowiem, że błąd jest o tutaj a dokładniej w nawiasach:

Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 1 lut 2018, o 16:39 
Offline
Tech-support
Avatar użytkownika

Dołączył(a): 14 lut 2014
Posty: 251
Lokalizacja: Jaskółowo k. Warszawy
Pomógł: 7

Tu masz kolego rozwiązanie swojego problemu:
http://mirekk36.blogspot.com/2012/01/avr-porty-wewy-dir-podstawy.html

Dodam jeszcze że ważne jest jak podłączasz diodę.
Ale tam i w książce masz to wszystko opisane.

_________________
Testowanie WIFIrififi



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 1 lut 2018, o 16:52 
Offline
Nowy

Dołączył(a): 11 sty 2013
Posty: 18
Pomógł: 1

A nie czasami powinno być:
DDRB |= ( 1 << PB4 );
PORTB |=( 1 << PB4 );



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 1 lut 2018, o 17:00 
Offline
Użytkownik

Dołączył(a): 31 sty 2018
Posty: 38
Lokalizacja: Tarnów
Pomógł: 0

Kurde w sumie przez szybkość teraz tak mi to wyszło ale było to tak
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.
i nie działa właśnie, dioda jest dobrze podpięta i jak pisałem na mierniku tez nic się nie zmienia nawet jeśli ustawie stan jako niski
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 1 lut 2018, o 17:17 
Offline
Użytkownik

Dołączył(a): 08 lut 2016
Posty: 96
Pomógł: 2

Hej miło widzieć kogoś z moich okolic :)

Pokaż teraz jak po modyfikacja wygląda cały program chodzi o plik main.c. Wrzuć może jakieś zdjęcie jak to masz podłączone. Napisz jeszcze jak masz podłączony pin reset ? Masz zrealizowane podciąganie przez rezystor około 10k do VCC ?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 1 lut 2018, o 17:24 
Offline
Użytkownik

Dołączył(a): 31 sty 2018
Posty: 38
Lokalizacja: Tarnów
Pomógł: 0

coś takiego:
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.
Tak pin reset podciągnąłem do Vcc R= 10k. Vcc jest z programatora



Ostatnio edytowano 1 lut 2018, o 17:30 przez GrzesiekB, łącznie edytowano 1 raz

Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 1 lut 2018, o 17:27 
Offline
Użytkownik

Dołączył(a): 08 lut 2016
Posty: 96
Pomógł: 2

Ok wygląda na okej czyli powinieneś mieć stan wysoki na pinie PB4. Ok a jak masz podłączony ten reset ?

------------------------ [ Dodano po: 10 minutach ]

Ok pokaż jakieś zdjęcie.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 1 lut 2018, o 17:40 
Offline
Użytkownik

Dołączył(a): 31 sty 2018
Posty: 38
Lokalizacja: Tarnów
Pomógł: 0

Obrazek



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 1 lut 2018, o 17:48 
Offline
Użytkownik

Dołączył(a): 08 lut 2016
Posty: 96
Pomógł: 2

Ok a diodę masz poprawnie podłączoną dłuższą końcówką ANODĄ do pinu procesora czyli PB4, a katodę do GND ?
Zmieniałeś taktowanie procesora ?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 1 lut 2018, o 17:48 
Offline
Użytkownik

Dołączył(a): 24 kwi 2012
Posty: 69
Lokalizacja: Ostrów Wielkopolski
Pomógł: 6

A gdzie masz zainkludowany plik od attinny???

Upss!!! Asemblerowe nawyki dały znać... Głupoty napisałem



Ostatnio edytowano 1 lut 2018, o 17:55 przez woycek, łącznie edytowano 1 raz

Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 1 lut 2018, o 17:53 
Offline
Użytkownik

Dołączył(a): 08 lut 2016
Posty: 96
Pomógł: 2

woycek napisał(a):
A gdzie masz zainkludowany plik od attinny???


Pierwsze raz słyszę o czymś takim. Czy może to ktoś potwierdzić ?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 1 lut 2018, o 17:56 
Offline
Użytkownik

Dołączył(a): 31 sty 2018
Posty: 38
Lokalizacja: Tarnów
Pomógł: 0

Dioda na 100% poprawnie podłączona.
Czyli musi być osobna biblioteka dla attiny tak ? jeśli tak to czy muszę ja ściągnąć dla programu MkClipse czy wystarczy dodać?
Też mi się wydawało że wystarczy <avr/io.h>



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 1 lut 2018, o 17:58 
Offline
Użytkownik

Dołączył(a): 24 kwi 2012
Posty: 69
Lokalizacja: Ostrów Wielkopolski
Pomógł: 6

Nie!!! We właściwościach projektu ustawiasz procesor



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 1 lut 2018, o 18:05 
Offline
Użytkownik

Dołączył(a): 08 lut 2016
Posty: 96
Pomógł: 2

No ja już nie wiem co może być źle a wgrywasz program za pomocą mkAVCalculatora czy za pomocą Eclipse ?
Zmieniałeś taktowanie procesora ?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 1 lut 2018, o 18:09 
Offline
Użytkownik

Dołączył(a): 31 sty 2018
Posty: 38
Lokalizacja: Tarnów
Pomógł: 0

Tak to wygląda:
Obrazek
i po upload
Cytuj:
Please wait ...
avrdude_mk.exe: set SCK frequency to 93750 Hz
avrdude_mk.exe: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% 0.00s

avrdude_mk.exe: Device signature = 0x1e9007
avrdude_mk.exe: NOTE: FLASH memory has been specified, an erase cycle will be performed
To disable this feature, specify the -D option.
avrdude_mk.exe: erasing chip
avrdude_mk.exe: set SCK frequency to 93750 Hzavrdude_mk.exe: reading input file "c:\\dioda\Release\dioda.hex"
avrdude_mk.exe: writing flash (76 bytes):

Writing | ################################################## | 100% 0.06s

avrdude_mk.exe: 76 bytes of flash written

avrdude_mk.exe: safemode: Fuses OK

avrdude_mk.exe done. Thank you.

Compiled special for http://forum.atnel.pl (v5.11.1)

**** [total upload time: 1 002 ms ] ****



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 1 lut 2018, o 18:19 
Offline
Użytkownik

Dołączył(a): 08 lut 2016
Posty: 96
Pomógł: 2

Ok

A spróbuj uruchomić mkAVRCalculator i wgrać tego hex-a

Wybierz programator
Kliknij sprawdź podłączony AVR
Następnie daj ptaszka w Operacje AVR na Zapis
Następnie daj ptaszka na rodzaj pamięci Flash
Wskaż gdzie się znajduję rozpakowany plik .hex
A następnie kliknij wykonaj.

I daj znać jaki rezultat


Załączniki:

Aby zobaczyć załączniki musisz się zalogować. Tylko zalogowani użytkownicy mogą oglądać i pobierać załączniki.



Ostatnio edytowano 1 lut 2018, o 18:23 przez StaryAnoda, łącznie edytowano 1 raz

Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 1 lut 2018, o 18:22 
Offline
Tech-support
Avatar użytkownika

Dołączył(a): 14 lut 2014
Posty: 251
Lokalizacja: Jaskółowo k. Warszawy
Pomógł: 7

Obrazek
A jak podłączysz zasilanie do diody przed rezystor to dioda zapali się?

edit: zasilanie jest 3V czy 5V.
Jaka jest wartość rezystora przed diodą?

_________________
Testowanie WIFIrififi



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 1 lut 2018, o 18:25 
Offline
Użytkownik

Dołączył(a): 14 sie 2016
Posty: 562
Pomógł: 20

Pisał wcześniej że sprawdzał miernikiem.
Ja bym jeszcze przedzwonił stykówkę, bo może gdzieś coś nie styka.

_________________
Moje porady są błędne,nie czytać,zbanować od razu.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 1 lut 2018, o 18:28 
Offline
Tech-support
Avatar użytkownika

Dołączył(a): 14 lut 2014
Posty: 251
Lokalizacja: Jaskółowo k. Warszawy
Pomógł: 7

Harry napisał(a):
Pisał wcześniej że sprawdzał miernikiem.
Ja bym jeszcze przedzwonił stykówkę, bo może gdzieś coś nie styka.


Cytuj:
sprawdzam wiec miernikiem a tu dalej nic
z tego opisu, nie wiem co sprawdzał miernikiem.

_________________
Testowanie WIFIrififi



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 1 lut 2018, o 18:36 
Offline
Użytkownik

Dołączył(a): 31 sty 2018
Posty: 38
Lokalizacja: Tarnów
Pomógł: 0

Cytuj:
z tego opisu, nie wiem co sprawdzał miernikiem.

Sprawdzam miernikiem czy pojawia się stan wysoki na PB4

PITERK napisał(a):
A jak podłączysz zasilanie do diody przed rezystor to dioda zapali się?

Tak działa

Harry napisał(a):
Ja bym jeszcze przedzwonił stykówkę, bo może gdzieś coś nie styka.

na 3 stykówkach już sprawdzałem wydaje mi się ze brak styku odpada



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 1 lut 2018, o 18:39 
Offline
Tech-support
Avatar użytkownika

Dołączył(a): 14 lut 2014
Posty: 251
Lokalizacja: Jaskółowo k. Warszawy
Pomógł: 7

Zmień pin na PB3

------------------------ [ Dodano po: 2 minutach ]

Masz niezapisany projekt. Zapisz i spróbuj wgrać.

_________________
Testowanie WIFIrififi



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 1 lut 2018, o 18:46 
Offline
Użytkownik

Dołączył(a): 31 sty 2018
Posty: 38
Lokalizacja: Tarnów
Pomógł: 0

StaryAnoda napisał(a):
Ok

A spróbuj uruchomić mkAVRCalculator i wgrać tego hex-a

Wybierz programator
Kliknij sprawdź podłączony AVR
Następnie daj ptaszka w Operacje AVR na Zapis
Następnie daj ptaszka na rodzaj pamięci Flash
Wskaż gdzie się znajduję rozpakowany plik .hex
A następnie kliknij wykonaj.

I daj znać jaki rezultat


No i zadziałało tylko mały problem tylko 1 raz



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 1 lut 2018, o 18:49 
Offline
Użytkownik

Dołączył(a): 08 lut 2016
Posty: 96
Pomógł: 2

W sensie co to znaczy pierwszy raz ?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 1 lut 2018, o 18:56 
Offline
Użytkownik

Dołączył(a): 31 sty 2018
Posty: 38
Lokalizacja: Tarnów
Pomógł: 0

Zrobiłem to co opisałeś potem wgrałem program aby uruchomić stan wysoki dioda się zapaliła potem wgrałem program by zgasła i zgasła gdy 2 raz wgrałem znów program ze stanem wysokim dioda się nie zaświeciła



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 1 lut 2018, o 18:59 
Offline
Użytkownik

Dołączył(a): 08 lut 2016
Posty: 96
Pomógł: 2

A spróbuj rozpakować jeszcze raz i wgrać ten 'nowo' rozpakowany.


Autor postu otrzymał pochwałę


Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 1 lut 2018, o 19:01 
Offline
Użytkownik

Dołączył(a): 31 sty 2018
Posty: 38
Lokalizacja: Tarnów
Pomógł: 0

StaryAnoda napisał(a):
A spróbuj rozpakować jeszcze raz i wgrać ten 'nowo' rozpakowany.


Działa za każdym razem jesteś wielki dzięki
Mam jeszcze pytanie co zmieniłem tym plikiem ?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 1 lut 2018, o 19:11 
Offline
Użytkownik

Dołączył(a): 08 lut 2016
Posty: 96
Pomógł: 2

Słuchaj nie wiem być może w programie mkAVRCalculator nie zmieniłeś operacji z odczytu na zapis. I odczytałeś ten program który był w pamięci mikrokontrolera do tego pliku.

Proponuję zainstalować sobie Eclipse tak jak Mirek pokazuję na filmikach. Bo rozumiem, ze w programie MKClipse dalej nie działa poprawnie ?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 1 lut 2018, o 19:17 
Offline
Użytkownik

Dołączył(a): 31 sty 2018
Posty: 38
Lokalizacja: Tarnów
Pomógł: 0

No właśnie działa teraz każdy który wgram nawet sobie teraz miganie diadą zrealizowałem i super wszystko śmiga
ustawiłem przerwania na sekundę i dioda miga co sekundę przedtem nic się nie działo.
Teraz co wymyśle sobie w MkCLIPS to działa



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 1 lut 2018, o 19:24 
Offline
Użytkownik

Dołączył(a): 08 lut 2016
Posty: 96
Pomógł: 2

Ok to niewiele brakuję i będziesz oprogramowanie do łazików tworzył :)



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 33 ]  Przejdź na stronę 1, 2  Następna strona

Strefa czasowa: UTC + 1


Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 0 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
cron
Sitemap
Technologię dostarcza phpBB® Forum Software © phpBB Group phpBB3.PL
phpBB SEO