Kanał - ATNEL tech-forum
Wszystkie działy
Najnowsze wątki



Teraz jest 24 cze 2018, o 23:00


Strefa czasowa: UTC + 1





Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 51 ]  Przejdź na stronę 1, 2  Następna strona
Autor Wiadomość
PostNapisane: 3 gru 2017, o 19:29 
Offline
Użytkownik

Dołączył(a): 14 lis 2017
Posty: 86
Pomógł: 0

Poradnik 452, czy wgrywając demo MM z programu Magicmatrix za pomocą przycisku Upload za każdym razem konieczne jest podłączenie programatora i wgrywanie pliku BLS?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 3 gru 2017, o 21:27 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 23201
Lokalizacja: Szczecin
Pomógł: 863

to byłoby bez sensu ... nie po to jest wgrywany bootloader - żeby go za każdym razem wgrywać.

Wystarczy raz wgrać BLS a później samo już leci tylko bootloaderem, i tak pokazywałem to w poradnikach.

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 4 gru 2017, o 11:08 
Offline
Użytkownik

Dołączył(a): 14 lis 2017
Posty: 86
Pomógł: 0

mirekk36 napisał(a):
to byłoby bez sensu ... nie po to jest wgrywany bootloader - żeby go za każdym razem wgrywać.

Wystarczy raz wgrać BLS a później samo już leci tylko bootloaderem, i tak pokazywałem to w poradnikach.


Oczywiście, że bez sensu. :)

Jeszcze jedno pytanie z tym związane, czy bootloader (BLS) z programu MagicMatrix jest inny niż z programu MKBootloader?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 4 gru 2017, o 12:51 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 23201
Lokalizacja: Szczecin
Pomógł: 863

Krzycho69 napisał(a):
Jeszcze jedno pytanie z tym związane, czy bootloader (BLS) z programu MagicMatrix jest inny niż z programu MKBootloader?

Dla ATmega1284P tak - jest mocno inny - więc w takim wypadku trzeba wgrać sobie samemu oryginalny wygenerowany przez MkBootloader

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 4 gru 2017, o 15:11 
Offline
Użytkownik

Dołączył(a): 14 lis 2017
Posty: 86
Pomógł: 0

Tak myślałem, ponieważ próbowałem wgrać demo MM na AtMega 1284P, na którym mam wgrany bootloader z MKBotlooadera no i nie chcaiało iść.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 4 gru 2017, o 15:16 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 23201
Lokalizacja: Szczecin
Pomógł: 863

Krzycho69 napisał(a):
Tak myślałem, ponieważ próbowałem wgrać demo MM na AtMega 1284P, na którym mam wgrany bootloader z MKBotlooadera no i nie chcaiało iść.

Tak ale do własnych testów można sobie wgrać własny BLS i testować własne pomysły do woli ... Później jak widać łatwo można odtworzyć zegarek bez zmrużenia oka ;) tyle że za pierwszym razem z ponownym wgraniem zmodyfikowanego BLS'a przez program Magic Matrix

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 4 gru 2017, o 15:42 
Offline
Użytkownik

Dołączył(a): 14 lis 2017
Posty: 86
Pomógł: 0

I wszystko jasne. Pozdrawiam.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 4 gru 2017, o 19:04 
Offline
Użytkownik

Dołączył(a): 14 lis 2017
Posty: 86
Pomógł: 0

A ten program MK Terminal UDP na PC, czy był tworzony w poradnikach?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 6 sty 2018, o 11:03 
Offline
Użytkownik

Dołączył(a): 14 lis 2017
Posty: 86
Pomógł: 0

Ukończyłem budowę MM, wgrałem wersje demo oprogramowania, mam następujące pytania:
- w nocy wyświetlacz gaśnie, przyciemnianie jest za mocne , mam fotorezystor 16-50 k innego nie udało mi się kupić, czy wystarczy zmniejszyć rezystor R13 56 k?
- z jakiego serwera czasu GMT korzystacie, jestem na etapie poradników o dawcy czasu w module wifi mam ustawiony serwer 132.163.4.103
+ok=UDP,123,132.163.4.103, w jaki sposób sprawdzić za pomocą ATB WIFI Config czy czas jest pobierany?

------------------------ [ Dodano po: 41 minutach ]

[dimg]http://obrazkiforum.atnel.pl/thumb/18327/fb47c0a39eb2a5133d9a5513d0867795.jpg[/img]

------------------------ [ Dodano po: 44 minutach ]

Obrazek



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 6 sty 2018, o 12:01 
Offline
Użytkownik

Dołączył(a): 02 gru 2015
Posty: 49
Pomógł: 1

Super, gratulacje :)

Można wiedzieć czym przykleiłeś kwadraciki do tacki? Mi klej zostawił białe ślady (nalot).

Odnośnie foto rezystora, próbowałem 2 różnych foto rezystorów to o ile w normalnym oświetleniu widać różnicę w natężeniu światła matrycy. To w przypadku "nocy" gdy jest bardzo ciemno i niema, żadnego źródła światła to fotorezystor ma rezystancję rzędu megaomów, więc R13 (56k), w takim momencie można pominąć.
R13 jest istotny w normalnych warunkach oświetlenia (tak zaobserwowałem).

Ja w swoim projekcie uwzględnić będę chciał, że natężenie diod nie może spać poniżej pewnej wartości.

Pozdrawiam,
Tomek



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 6 sty 2018, o 14:47 
Offline
Użytkownik

Dołączył(a): 14 lis 2017
Posty: 86
Pomógł: 0

Kwadraciki przykleiłem małą kropelką kleju Patex 2-cyjanoakrylan etylu. Kwadraciki mam z białej (mlecznej) plexi , nia ma żadnego nalotu, a i trzyma mocno.

------------------------ [ Dodano po: 5 minutach ]

Obrazek



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 6 sty 2018, o 15:39 
Offline
Użytkownik

Dołączył(a): 14 sie 2016
Posty: 562
Pomógł: 20

Krzycho69 napisał(a):
z jakiego serwera czasu GMT korzystacie, jestem na etapie poradników o dawcy czasu w module wifi mam ustawiony serwer 132.163.4.103

topic19306.html#p196414

_________________
Moje porady są błędne,nie czytać,zbanować od razu.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 6 sty 2018, o 16:16 
Offline
Użytkownik

Dołączył(a): 14 lis 2017
Posty: 86
Pomógł: 0

Harry napisał(a):
Krzycho69 napisał(a):
z jakiego serwera czasu GMT korzystacie, jestem na etapie poradników o dawcy czasu w module wifi mam ustawiony serwer 132.163.4.103

topic19306.html#p196414


OK
W ATB WIFI w sekcji Common jest sekcja GMT Time, czy po ustawieniu w niej serwera i kliknięciu refresh time, czas i data powinny ukazać się w okienkach sekcji GMT Time?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 6 sty 2018, o 16:51 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 23201
Lokalizacja: Szczecin
Pomógł: 863

Krzycho69 napisał(a):
- w nocy wyświetlacz gaśnie, przyciemnianie jest za mocne , mam fotorezystor 16-50 k innego nie udało mi się kupić, czy wystarczy zmniejszyć rezystor R13 56 k?

proszę się tym nie przejmować - postaram się przygotować wsad w którym będzie można się kalibrować do dowolnej wartości fotorezystora - tylko troszkę jeszcze cierpliwości poproszę ok?

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 6 sty 2018, o 20:48 
Offline
Użytkownik

Dołączył(a): 14 lis 2017
Posty: 86
Pomógł: 0

mirekk36 napisał(a):
Krzycho69 napisał(a):
- w nocy wyświetlacz gaśnie, przyciemnianie jest za mocne , mam fotorezystor 16-50 k innego nie udało mi się kupić, czy wystarczy zmniejszyć rezystor R13 56 k?

proszę się tym nie przejmować - postaram się przygotować wsad w którym będzie można się kalibrować do dowolnej wartości fotorezystora - tylko troszkę jeszcze cierpliwości poproszę ok?



Jasne że OK



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 7 sty 2018, o 10:09 
Offline
Użytkownik

Dołączył(a): 14 lis 2017
Posty: 86
Pomógł: 0

Nie mogę odpalić pobierania czasu ntp, albo mam odpowiedź
+ok=unavailable
albo moduł nie odpowiada i przestaje reagaować na polecenia.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 7 sty 2018, o 11:28 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 23201
Lokalizacja: Szczecin
Pomógł: 863

to pokaż dokładnie jak masz ustawiony moduł na potrzeby ntp

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 7 sty 2018, o 13:04 
Offline
Użytkownik

Dołączył(a): 14 lis 2017
Posty: 86
Pomógł: 0

Ustawienia modułu, ustawiałem różne adresy serwerów


ObrazekObrazekObrazekObrazekObrazek



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 7 sty 2018, o 14:45 
Offline
Użytkownik

Dołączył(a): 14 lis 2017
Posty: 86
Pomógł: 0

Przez te wszystkie kombinacje teraz MagicMatrix(zegarek) nie daje się sterować programem Magicmatrix , ani nie można modułu WiFi użyć do programowania.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 7 sty 2018, o 15:45 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 23201
Lokalizacja: Szczecin
Pomógł: 863

Krzycho69 napisał(a):
ani nie można modułu WiFi użyć do programowania.

czyli co jak go podłączysz do przejściówki USB/RS232 to nie reaguje ? coś wątpię

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 7 sty 2018, o 17:28 
Offline
Użytkownik

Dołączył(a): 14 lis 2017
Posty: 86
Pomógł: 0

Przez RS232 działał, ale przez WiFi nie chciał, wrociłem do ustawień fabrycznych poustawiałem od nowa i dziala jak przedtem tzn wszystko chodzi oprócz pobietania czasu.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 7 sty 2018, o 22:47 
Offline
Użytkownik

Dołączył(a): 29 sty 2014
Posty: 121
Pomógł: 2

W zakładce STA ustaw adres DNS server 192.168.1.1 , czyli taki sam jak masz w Gateway.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 8 sty 2018, o 07:01 
Offline
Użytkownik

Dołączył(a): 14 lis 2017
Posty: 86
Pomógł: 0

milek22 napisał(a):
W zakładce STA ustaw adres DNS server 192.168.1.1 , czyli taki sam jak masz w Gateway.



Zmieniłem, ale nie pomoglo.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 8 sty 2018, o 09:09 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 23201
Lokalizacja: Szczecin
Pomógł: 863

A ja polecam obejrzeć poradnik o dawcy czasu i poczytać na forum o serwerach NTP że nie wszystkie działają, jak ich szukać i że trzeba czasem sobie zmienić taki serwer

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 8 sty 2018, o 09:20 
Offline
Użytkownik

Dołączył(a): 14 lis 2017
Posty: 86
Pomógł: 0

mirekk36 napisał(a):
A ja polecam obejrzeć poradnik o dawcy czasu i poczytać na forum o serwerach NTP że nie wszystkie działają, jak ich szukać i że trzeba czasem sobie zmienić taki serwer


Dlatego prosiłem o podanie jakiegoś sprawdzonego adresu serwera.
Tak się zastanawiam, a może ja coś źle robię.
Jestem w zakładce UDP (ATB-WiFi), wysyłam polecenie AT+GMT=1, rozumiem ,że powinienem w oknie powyżej zobaczyć pobrany czas?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 8 sty 2018, o 11:01 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 23201
Lokalizacja: Szczecin
Pomógł: 863

Krzycho69 napisał(a):
Jestem w zakładce UDP (ATB-WiFi), wysyłam polecenie AT+GMT=1, rozumiem ,że powinienem w oknie powyżej zobaczyć pobrany czas?


No widzisz - a w poradniku wideo mówiłem, że w zakładce UDP działają WSZYSTKIE komendy poza jedną, jedyną - akurat właśnie tą AT+GMT...

Weź że podłącz sobie wifi przez przejściówkę do kompa i skonfiguruj .... i tam sprawdź - będzie działać AT+GMT

a co do sprawdzonych serwerów NTP to nie pytaj tylko znajdź w necie i ustaw ten który będzie dobrze działać w twojej lokalizacji.

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 8 sty 2018, o 12:43 
Offline
Użytkownik

Dołączył(a): 14 lis 2017
Posty: 86
Pomógł: 0

Gdzieś to przegapiłem :(.

------------------------ [ Dodano po: 14 minutach ]

Dawca czasu - part 01 - 7 min 00 s.
Każde słowo jest bardzo istotne.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 8 sty 2018, o 18:48 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 23201
Lokalizacja: Szczecin
Pomógł: 863

no ale jak w końcu - poszło ?

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 8 sty 2018, o 19:33 
Offline
Użytkownik

Dołączył(a): 14 lis 2017
Posty: 86
Pomógł: 0

mirekk36 napisał(a):
no ale jak w końcu - poszło ?



Oczywiście, że poszło. Wielkie dzięki za pomoc użyłem serwera:194.29.130.252 .

Ale żeby nie było zbyt pięknie to po wgraniu pełnej wersji Magic Matrixa mam komunikat Error I2C.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 8 sty 2018, o 22:19 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 23201
Lokalizacja: Szczecin
Pomógł: 863

Krzycho69 napisał(a):
po wgraniu pełnej wersji Magic Matrixa mam komunikat Error I2C.

Im mniej i im krócej będziesz opisywał problem tym gorzej będzie ci pomóc

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 51 ]  Przejdź na stronę 1, 2  Następna strona

Strefa czasowa: UTC + 1


Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 1 gość


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
Sitemap
Technologię dostarcza phpBB® Forum Software © phpBB Group phpBB3.PL
phpBB SEO