Kanał - ATNEL tech-forum
Wszystkie działy
Najnowsze wątki



Teraz jest 25 wrz 2017, o 14:23


Strefa czasowa: UTC + 1





Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 9 ] 
Autor Wiadomość
PostNapisane: 16 sie 2017, o 12:07 
Offline
Nowy

Dołączył(a): 30 kwi 2017
Posty: 5
Pomógł: 0

Witam,

Zrobiłem sobie zdalnie sterowany pojazd, zdalne sterowanie odbywa się przy pomocy modułu bluetooth HC06.
Wszystko działa tak jak chciałem, jednak gdy w jednej chwili dam 100 % wypełnienia na oba silniki to nagły pobór prądu powoduje że moduł bluetooth się wyłącza. Próbowałem powpinać różne kondensatorki ( zarówno przy HC06 jak i przy pinach zasilania VMOT mostka H ) ale niestety bez skutku :(
Bardzo proszę o pomoc

Obrazek

Na schemacie widać możliwość wyboru napięcia zasilania dla mostka jednak ja na płytce stykowej mam na stałe napięcie VCC z dwóch szeregowo połączonych 18650



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 16 sie 2017, o 16:45 
Offline
Użytkownik

Dołączył(a): 25 lip 2013
Posty: 992
Pomógł: 47

Testujesz to na stykowce? Jeśli tak, to pierwsze co zrób to porządnie polutuj pająka - stykówki bardzo często płatają figle.

Sent from my Mi-4c using Tapatalk



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 16 sie 2017, o 19:51 
Offline
Nowy

Dołączył(a): 30 kwi 2017
Posty: 5
Pomógł: 0

Tak czy inaczej w końcu zrobię do tego porządną pcb .

Jednak sądzę że to nie jest wina płytki stykowej bo rozłączanie następuje jedynie w momencie gdy mostek pobiera większy prąd , i to tylko gdy dzieje się to skokowo, jak zwiększam obroty stopniowo to nie rozłącza się .

Nie da się tego rozwiązać jakimś filtrem ?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 16 sie 2017, o 21:21 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 22 paź 2013
Posty: 1223
Lokalizacja: Lipsko
Pomógł: 82

Puść zasilanie części logicznej przez diodę.

_________________
http://www.sylwekkuna.com



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 16 sie 2017, o 22:01 
Offline
Nowy

Dołączył(a): 03 sie 2017
Posty: 9
Pomógł: 0

Kiedyś budując swój pojazd z tym modułem też miałem podobny problem. Rozwiązałem go za pomocą dodania odrębnego zasilania dla modułu Bluetooth.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 17 sie 2017, o 23:46 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 12 paź 2011
Posty: 778
Pomógł: 20

Cześć

Zazwyczaj jak robię podobne zabawki używam przetwornicy tani i dobry LM2576 ;) za jakieś 5zł cały moduł :)
do zasilania części logicznej a bezpośrednio z aku zasilam mostki.
Przetwornica odcina śmieci jakie są od silników i wszystko w miarę stabilnie działa.
Układy HC-06 mają tendencje do nierozłączania się polecam HC-12 lub 13 trochę lepsze
ale najbardziej sprawdzone to chyba jednak BTM222 wszystko zależy od poboru prądu zasięgu itp

Najlepsze moduły BT tzn które sprawiają najmniej kłopotów są oparte o NRF Nordica świetnie to działa i masz od razu mikrokontroler wszystko w jednym.

Chyba w ELTY możesz kupić boardy do tych układów na robota mogło by ci starczyć zaprojektował byś sobie shield ale nie znam Twojej koncepcji.

Pozdrawiam

_________________
sig off ;(



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 18 sie 2017, o 11:37 
Offline
Nowy

Dołączył(a): 30 kwi 2017
Posty: 5
Pomógł: 0

Straciłem dwa wieczory na projektowanie filtrów, niestety bezskutecznie :D
Po prostu szarpnięcia prądu są zbyt wielkie, 7805 nie daje rady , jemu już podziękuje na zawsze.

Jak przyjdzie przesyłka to spróbuję z przetwornicą MP1584



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 18 sie 2017, o 12:02 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 22 paź 2013
Posty: 1223
Lokalizacja: Lipsko
Pomógł: 82

A sprawdzałeś jak mówiłem? Od głównego zasilania przez diodę podłącz 7805 tylko oczywiście kondensatory przy nim jakieś daj z obu stron 100uF i 0.1uF. Przy mostku H (jak najbliżej) powinien być około 100-220uF low ESR na napięcie min. 35V i nie ma bata musi działać

_________________
http://www.sylwekkuna.com



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 18 sie 2017, o 12:06 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 12 paź 2011
Posty: 778
Pomógł: 20

Zobacz czy Ci wystarczy Ci ta przetwornica ma 1A

_________________
sig off ;(



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 9 ] 

Strefa czasowa: UTC + 1


Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 0 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
Sitemap
Technologię dostarcza phpBB® Forum Software © phpBB Group phpBB3.PL
phpBB SEO