Kanał - ATNEL tech-forum
Wszystkie działy
Najnowsze wątki



Teraz jest 23 cze 2017, o 14:42


Strefa czasowa: UTC + 1





Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 27 ] 
Autor Wiadomość
PostNapisane: 31 gru 2016, o 11:48 
Offline
Użytkownik

Dołączył(a): 18 cze 2015
Posty: 105
Pomógł: 0

Witam jeszcze w Starym Roku.

Jest wiele wątków o ADC na forum, ale akurat tego przypadku nie znalazłem. Ponadto P. Mirek kiedyś zwrócił mi uwagę, że lepiej zakładać nowy temat, niż
"przyklejać się" do podobnych, a więc tak taż i czynię. Pytanie może banalnie proste, ale dla mnie ta informacja byłaby pomocna i cenna. Ćwiczyłem
pomiary napięć na atmedze w oparciu o BB i forum i wszystko było ok do momentu, kiedy zachciało mi się zmierzyć napięcie z dwóch źródeł, a w
przyszłości może z trzech, czterech...Ćwiczenie robię na "podstawowym" kodzie z BB bez wyliczania po przecinku i zamiany wartości cyfrowej na postać
dziesiętną. Podobno nie powinienem zamieszczać w/w kodów na forum, a więc ograniczę się tylko do małego fragmentu, co ja namodziłem. Ewentualnie
proszę o info, czy jednak można. Zrobiłem tak, jak poniżej, ponieważ tak uważałem, ale nie jestem pewien, czy słusznie. Po prostu za mało wiedzy.
Efektem "mojej pracy" jest wyświetlenie dwóch wartości ADC, przy czym jedna jest stała (na tą chwilę połączyłem jedno wejście żywcem do Vcc bez oporników
dzielników itp...- nie wiem, czy to nie błąd), gdzie wyświetla się wartość 1023, a druga wartość jest zmienna o wartości 0-1023 mierzona z potencjometru
zestawu uruchomieniowego Atnela.

Zauważyłem dwie sytuacje:

-kiedy potencjometr jest na "0", to ADC wacha się od 0-30 (nie było tego przy oryginalnym kodzie do pojedynczego pomiaru)
-przy tejże nastawie wartość stała 1023 zaczyna lekko pływać

Generalnie występuje lekka niestabilność całości. Niby działa, ale jestem przekonany, że jest babol. Sorry za obszerny opis, ale chcę żeby każdy o podobnej
wiedzy, jak moja, mógł zrozumieć problem, a i osoba pomagająca wiedziała, o co dokładnie chodzi. Poniżej fragment kodu i co robię źle. Z góry dziękuję za wszelką pomoc.

Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.




Czy nikt nie zechce wypowiedzieć się ?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 31 gru 2016, o 15:16 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 20994
Lokalizacja: Szczecin
Pomógł: 765

pokaż pan lepiej kod swojej funkcji pomiar() bo tam masz pewnie babola no a już nie wspomnę że przydałby się jakiś chociaż strzęp schematu do takiego pytania

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 31 gru 2016, o 15:42 
Offline
Użytkownik

Dołączył(a): 18 cze 2015
Posty: 105
Pomógł: 0

Witam P Mirku.

Dzięki za chęci pomocy. Załączam całość. Co do schematu, to pewnie masz rację, ale opisałem wcześniej konfigurację dość dokładnie. Korzystam z zestawu
Twojej produkcji, a więc schemat masz w głowie ;) , natomiast drugie wejście pomiarowe, jak napisałem, zostało podłączone do Vcc bez jakichkolwiek
dodatków w postaci potencjometru nr2, czy rezystora, dzielnika itp... Po prostu zależało mi na czasie, a żeby jak najszybciej potestować i podszedłem
trochę olewacko, myśląc, że w tym konkretnym przypadku nie będzie miało to znaczenia (tylko przewód między pinem Vcc, a pinem procka.

Proszę bardzo:


Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.



Trochę poczytałem, poszperałem i doszedłem do wniosku, że chyba nie da się pomierzyć dwóch napięć jednocześnie. Wynika z tego, że wejścia muszą być
przełączane na zmianę (multiplekser). Ponad to tu mamy do czynienia chyba z pomiarem na żądanie (nie wiem, czy to ma znaczenie), a znalazłem trochę
przykładów z pomiarami typu "free running", jeśli chodzi o pomiar wielokanałowy. Proszę podpowiedzieć, czy idę w dobrym kierunku.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 sty 2017, o 14:04 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 04 paź 2013
Posty: 133
Lokalizacja: Siedlce
Pomógł: 3

Czy przypadkiem sam nie odpowiedziałeś sobie na to pytanie? A spróbuj użyć delaya zaraz po pierwszym pomiarze .

_________________
Ucz się ucz ,nauka to potęgi klucz...



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 sty 2017, o 14:58 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 30 cze 2016
Posty: 195
Lokalizacja: Rybnik
Pomógł: 11

Witam. Miałem podobny problem. Pomogła zmiana prescalera i odczekanie po zmiane ADMUX.

_________________
Situs != Situs



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 sty 2017, o 15:17 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 20994
Lokalizacja: Szczecin
Pomógł: 765

Robert_1967 napisał(a):
rochę poczytałem, poszperałem i doszedłem do wniosku, że chyba nie da się pomierzyć dwóch napięć jednocześnie


To ciekawe gdzie się tego doczytałeś ? totalne zdziwienie ... bo pewnie, że można dokonywać w ten sposób pomiaru ...

Robert_1967 napisał(a):
Wynika z tego, że wejścia muszą być przełączane na zmianę (multiplekser).

A co niby robione jest w funkcji pomiar() wg ciebie jak nie przełączanie multipleksera ? Szczególnie ta linijka
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.


Robert_1967 napisał(a):
a znalazłem trochę
przykładów z pomiarami typu "free running", jeśli chodzi o pomiar wielokanałowy.

I co to za różnica? czyżby tam nie trzeba było przełączać multipleksera?

Robert_1967 napisał(a):
Korzystam z zestawu
Twojej produkcji, a więc schemat masz w głowie

Może i mam, ale jasnowidzem to ja nie jestem i nie potrafię się domyślić w jaki sposób podłączyłeś ten drugi sygnał .... poza tym jak ktoś ma zestaw ATB to ustawia sobie w profilu forum ikonkę że ma zestaw i wtedy szybciej to dociera do mojego oka, tak samo jak schemat.

------------------------ [ Dodano po: 1 minucie ]

RadekB86 napisał(a):
Czy przypadkiem sam nie odpowiedziałeś sobie na to pytanie? A spróbuj użyć delaya zaraz po pierwszym pomiarze .

Nie trzeba drugiego delaja bo tę rolę pełni oczekiwanie na pomiar w funkcji pomiar(), dokładnie ta linijka

Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.


------------------------ [ Dodano po: 2 minutach ]

Situs napisał(a):
Witam. Miałem podobny problem. Pomogła zmiana prescalera i odczekanie po zmiane ADMUX.

Toż zmiana ADMUX odbywa się w funkcji pomiar()

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 sty 2017, o 15:27 
Offline
Użytkownik

Dołączył(a): 18 cze 2015
Posty: 105
Pomógł: 0

Witam wszystkich w Nowym Roku.

Dziękuję za chęć pomocy. Przy pomiarze na jednym kanale jest super stabilnie i dokładnie, ale jak wcześniej pisałem, to dołożyłem kawałek kodu bezmyślnie,
bo tak mi się wydawało, a efekt nijaki. Zacząłem więcej szukać i znalazłem kilka tematów, które powinny mi pomóc. Myślę, że nie będzie nie ładnie, jeśli
zamieszczę je tutaj. Mogą się komuś przydać. Co do dely, to jeśli nie będą konieczne, to wolałbym ich nie używać. Po poradnikach Mirka jakoś utkwiło mi to
w pamięci. Ponad to programik, który chcę w pocie czoła napisać ma wykonywać więcej funkcji, niż tylko pomiar napięcia na dwóch kanałach i dla tego nie chcę
wprowadzać zbędnych opóźnień, ale dziękuję za sugestię. Do tej pory mierzyłem napięcia tylko na jednym pinie i nie było problemu, a tera doszło jeszcze do
tego, że muszę dodatkowo wybrać sposób pomiaru (na żądanie lub free running) i wiedzieć który w moim przypadku będzie lepszy. O tym drugim nic nie wiem.
Ale dobrze, że jest internet i fora, bo bez tego ani rusz. Proszę o jakieś sugestie bardziej doświadczonych forumowiczów, który sposób będzie lepszy i jak najlepiej
to rozwiązać. Ja zabieram się za śledzenie informacji z linków i pewnie coś się uda.


topic1341.html

topic1491.html

topic3728.html

topic14618.html

topic1534.html

[ dyskusję prowadzimy na forum atnel a nie między-forumowo - więc proszę jak już to pytania zadawać na naszym forum a nie jakieś linki, które później mogą być nieaktualne, ok? - mirekk36 ]


Co o tym myślicie ?.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 sty 2017, o 15:27 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 20994
Lokalizacja: Szczecin
Pomógł: 765

Robert_1967 napisał(a):
Sorry za obszerny opis, ale chcę żeby każdy o podobnej
wiedzy, jak moja, mógł zrozumieć problem, a i osoba pomagająca wiedziała, o co dokładnie chodzi

Nie gniewaj się proszę ale przypomnę po raz setny na tym forum, że to jest forum elektroników którzy posługują się schematami a nie forum literatów którzy posługują się prozą czy wierszami.

Jeden schemat powie więcej niż 1000 słów i nie ważne czy to schemat ATB jeśli ty piszesz o podłączaniu drugiego kanału a więc sam być pomoże wstawiasz jakiś dzielnik ? jaki ? itp ... mówię - schemat od razu pokazałby o co chodzi - to tak na przyszłość

Poza tym polecam ci jednak oglądać sobie poradniki wideo które robię do książek a TYM BARDZIEJ, że nie chwaląc się bardzo ładnie omówiłem i do końca praktycznie ADC w serii poradników ... jak je znaleźć ? BARDZO ŁATWO ...

wystarczy sobie pobrać darmowy program AVPlayer

http://atnel.pl/atnel-video-player.html

wpisać w jego polu do szukania hasło "ADC" i tadam ! ... proszę

Obrazek

mówię ci, usiądź sobie na spokojnie i po kolei obejrzyj te poradniki o ADC - warto

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 sty 2017, o 15:37 
Offline
Użytkownik

Dołączył(a): 18 cze 2015
Posty: 105
Pomógł: 0

Witam Mirku.
Dziękuję za porady i przepraszam. Faktycznie masz rację, że schemat, to schemat. Na przyszłość postaram się zamieszczać i kropka. Myślałem, że infor amacja zawarta w poście wystarczy. Napisałem, że na szybko podłączyłem kolejny pin wejścia adc prosto do +Vcc bez oporników, dzielników i nie wiem, czy na początek do prób może być.
Mam wiele Twoich poradników, oglądam i wiedza tam zawarta jest po prosu bezcenna. Niektóre przeglądałem dawno i po prostu nie pamiętam. Jakoś szybciej coś napisać :oops: . Zabiorę się za oglądanie.

Pozdrawiam.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 sty 2017, o 15:59 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 20994
Lokalizacja: Szczecin
Pomógł: 765

Robert_1967 napisał(a):
Zauważyłem dwie sytuacje:

-kiedy potencjometr jest na "0", to ADC wacha się od 0-30 (nie było tego przy oryginalnym kodzie do pojedynczego pomiaru)
-przy tejże nastawie wartość stała 1023 zaczyna lekko pływać


A zauważyłeś to?

Obrazek

w instrukcji PDF do zestawu ATB ? .... bo to nie jest zwykły potek za pomocą którego ustawia się napięcie na ADC - stanowi on część dzielnika i warto poczytać o tym rozwiązaniu w ATB również na stronie

http://atnel.pl/atb-pomiar-napiecia-adc.html


Co się zaś tyczy "skaczączych wartości i napięć" to jak mówię odsyłam do poradników wideo w których się rozprawiamy z tymi skaczącymi .... za pomocą miecza DŻEDAJ (JEDI) ;)

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 sty 2017, o 16:20 
Offline
Użytkownik

Dołączył(a): 18 cze 2015
Posty: 105
Pomógł: 0

Dziękuję Mirku.

Pośpiech rzadko kiedy jest wskazany. Muszę po prostu podłączyć wszystko zgodnie ze sztuką i dopiero wtedy kombinować, a ja chciałem już, szybko i wyszło
to, co wyszło. Chodziło mi o to, czy po tak zmienionym kodzie w ogóle będzie możliwy pomiar na dwóch kanałach jednocześnie. Ponad to napięcie mierzone
nie przekracza napięcia zasilania układu, czyli +5 volt, masa jest wspólna, a więc połączyłem drugi kanał na żywca przewodem do +Vcc bez dzielnika i elementów
dodatkowych. Nic nie napisałeś o samym programie, czy takie podejście jest właściwe i może być, czy to jednak babol. Przeglądając programy z linków widzę,
że nie są napisane tak prosto, jak ja próbowałem, a więc wnioskuje, że chyba jest babol.

Pozdrawiam.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 sty 2017, o 16:30 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 20994
Lokalizacja: Szczecin
Pomógł: 765

Nie spokojnie nie ma babola w twoim kodzie - tzn chodzi mi o to w pętli głównej
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.


bo co tutaj może być za babol , jak najbardziej tak można - oczywiście nie należy się spodziewać stabilnych wyników bez uśredniania i przy zasilaniu zestawu ze złącza USB komputera - ale to MUSI działać ;)

I możesz spokojnie podawać +5V na wejście ADC - zobaczysz sobie 1023 ... niezależnie nawet jakie źródło napięcia odniesienia ustawisz

a jak chcesz obserwować zmiany napięcia to na szybko możesz sobie podłączyć wejście ADC np do wyprowadzenia +3,3V w złączu ATB-MICROPORT ale to jeśli masz ATB v1.05a bo jeśli 1.05 to +3,3V masz na czerwonej zworce JP16 po prawej stronie ATB MICROPORT

albo wziąć sobie zewnętrzny potencjometr i go podłączyć pomiędzy VCC i GND zaś z suwak do ADC


Autor postu otrzymał pochwałę

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 sty 2017, o 17:15 
Offline
Użytkownik

Dołączył(a): 18 cze 2015
Posty: 105
Pomógł: 0

Nie chcę zakładać nowego tematu dla jednego pytania, ale czy może mi ktoś podpowiedzieć, jak wstawić np. krótki filmik do postu ?. Szukam i nie mogę znaleźć.
Nieraz widziałem telewizorek z filmem.
Z góry dziękuję.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 sty 2017, o 17:47 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 09 gru 2014
Posty: 1379
Pomógł: 227

Wejdź w Pełny edytor, a następnie jak najedziesz myszką na youtube (ten pod Dodaj obrazek) to pokaże ci się krótka instrukcja jak to należy zrobić:
Ze strony filmu na YT kopiujemy tylko... ;)



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 2 sty 2017, o 18:47 
Offline
Użytkownik

Dołączył(a): 18 cze 2015
Posty: 105
Pomógł: 0

Dziękuję anshar za podpowiedź.
Tak, zwróciłem wcześniej uwagę na ten przycisk, ale myślałem, że jest może jakiś prostszy sposób bez YT (nie mam konta). Wygląda na to, że będę musiał
się zmierzyć z całą tą historią założenia konta na YT, ale prędzej, cz później i tak pewnie bym musiał :cry: .

Dzięki i najlepszego w Nowym Roku.

Dziękuję za wszelkie sugestie i pomoc w tym temacie.

Po przeanalizowaniu różnych materiałów z internetu, BB, bezcennych poradników P Mirka doszedłem do takiego kodu, który na zestawie ATB działa teraz
wyśmienicie. Przy zasilaniu całości z portu usb, gdzie wiadomo nie jest to super wyjście, ale wygodne, nie ma najmniejszych mrugnięć cyferek. Jak by
wyświetlanie było zamrożone. Zdaję sobie sprawę, że to jest raptem kilkanaście dodatkowych literek kodu i starzy "wyżeracze" uśmiechają się pod nosem,
ale dla mnie to duży sukces. Początki są trudne i każdy skrawek kodu działający prawidłowo cieszy :D . Starałem się maksymalnie uprościć i okroić. Ma mi
tylko prawidłowo i stabilnie mierzyć ADC, które potem wykorzystam do innych celów. Oprócz tego, że trochę dopisałem, podstawową pomocą była
zmiana preskalera z 64 na 128. Chciałbym nie zakańczać na tym etapie prób przy ADC. Z tego, co czytałem, to jest jeszcze metoda free running, która
w moim przypadku może byłaby lepszym wyjściem, dokładniejszym itp..., ale na tym etapie nie rozumiem, jak się do tego zabrać i czy może dać spokój i
zostawić tak jak jest ?. Generalnie proszę doświadczonych forumowiczów o:

- wypowiedzenie się na temat zamieszczonego kodu, czy jest 100% dobrze, czy może jednak za szybko się pocieszyłem. To, że na LCD jest ok, to może
nie zawsze oznaczać pełny sukces ?

- czy free running jest istotnie godny polecania, czy nie koniecznie ?

Ktoś zapyta, do czego jest mi to potrzebne. Chcę zbudować małą obracarkę do anteny TVSAT i drugą do panela słonecznego. Ma to z założenia obracać
w dwóch płaszczyznach. Trochę kodów do obsługi silniczków już mam, które działają dobrze i powoli "kompletuję" soft. Oczywiście można kupić urządzenie
ponieważ nie są to drogie rzeczy, ale każdy elektronik hobbysta wie o co chodzi i nie ma sensu tłumaczyć, dlaczego spędzamy tyle czasu przy konstrukcjach. Bardzo proszę o odpowiedź, co dalej. W którym kierunku iść i co ewentualnie poprawić.



Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.



Mam jeszcze jedno pytanie, czy aby nie popełniłem babola przy kodzie ustawiającym preskaler na 32. Wiem, że kłania się tu przesunięcie bitowe, ale
jakoś nie mogę załapać ustawienia "0" bitu ADPS1. Załączam fotki.


Obrazek


Obrazek


Drugie pytanie, dlaczego przy preskalerze 64 wyświetlanie jest niestabilne, pomimo że częstotliwość mieści się w zakresie 8000000 / 64 = 125000000
czyli 125 KHz, zakres prawidłowy (50-200 KHz).

Przy preskalerze 128 (62500 czyli 62,5 KHz) jest sztywno i stabilnie.

Przy preskalerze 32 (pod warunkiem, że nie zrobiłem babola, o którym mowa wyżej-fotki), również jest na lcd ok. 8000000 / 32 = 250 KHz, czyli poza zakresem.

O co tu chodzi :(

Nikt nie zechce się wypowiedzieć ?



Ostatnio edytowano 4 sty 2017, o 19:51 przez Robert_1967, łącznie edytowano 1 raz

Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 4 sty 2017, o 10:11 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 30 cze 2016
Posty: 195
Lokalizacja: Rybnik
Pomógł: 11

Ja się zechcę wypowiedzieć :lol:
Kod:
ADCSRA |= (1 << ADEN) | (1<<ADPS0) | (0<<ADPS1) | (1<<ADPS2) ;

to to samo co
Kod:
ADCSRA |= (1<<ADEN) | (1<<ADPS0) | (1<<ADPS2) ;


(0<<ADPS1) nic nie wnosi. To to samo, co (0).

Ustawianie bitu np ADLAR w rejestrze np ADMUX wygląda tak
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.


Czyszczenie natomiast tak
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.


Jeżeli dobrze zrozumiałem to podpowiem, że
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.
to to samo co
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.

_________________
Situs != Situs



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 4 sty 2017, o 10:30 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 20994
Lokalizacja: Szczecin
Pomógł: 765

Robert_1967 napisał(a):
Nikt nie zechce się wypowiedzieć ?


Proszę pamiętać, że forum to nie czat - i każdy odpowiada w swoim tempie a nie nagle po tym gdy ktoś opublikuje swój post ... więc spokojnie

A jak widać, kolega wyżej bardzo ładnie opisał co i jak

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 4 sty 2017, o 11:37 
Offline
Użytkownik

Dołączył(a): 18 cze 2015
Posty: 105
Pomógł: 0

Dziękuję situs za konkretne odpowiedzi.
Bardzo mi to rozjaśniło. Myślałem, że jeśli w nocie pdf są trzy bity, to muszę je umieścić w kodzie, nawet te 0, tylko nie wiedziałem, czy
zrobiłem prawidłowo.

Najmocniej przepraszam za to moje zniecierpliwienie. Po prostu myślałem, że jak szybko nikt nie odpowie, to potem już nikt tu nie zajrzy,
albo może zrobiłem coś nie tak :oops: . Sorki jeszcze raz. Zapamiętam.

Nie wiem tylko, co z tym preskalerem i czemu takie efekty są. Jak ktoś będzie miał czas i wiedział, to proszę o słowo wyjaśnienia. Pozdrawiam.
Robert_1967



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 4 sty 2017, o 11:55 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 20994
Lokalizacja: Szczecin
Pomógł: 765

Robert_1967 napisał(a):
Nie wiem tylko, co z tym preskalerem i czemu takie efekty są. Jak ktoś będzie miał czas i wiedział, to proszę o słowo wyjaśnienia.

No toż zmienia się częstotliwość próbkowania i będzie to mocno skorelowane z częstotliwością zmian na zasilaniu ... a skoro nie stosujesz żadnego uśredniania to już pisałem wyżej i w poradnikach mocno o tym mówiłem skąd będzie taki efekt. Nie wiem nawet czemu ty się dziwisz ? Na prawdę. I do tego jeszcze na zasilaniu z USB ... To sugerować może nawet to, że nie oglądałeś jednak tych poradników wideo o uśrednianiu i skaczących napięciach - a szkoda ... Bo jeśli nie oglądałeś i nie zastosujesz - nie zrozumiesz po co i dlaczego jest uśrednianie - to będziesz jeszcze długo długo z tym walczył, żeby na końcu i tak to zrobić jak się należy.

Już dużo lepszy efekt będziesz miał jak np zasilisz zestaw z przetwornicy ATB-PWR3 na pokładzie zestawu ATB ... a jeszcze lepszy byłby przy DIGI-LION ... tak nawet bez uśredniania - ale i tak zawsze coś tam będzie skakać ... eeeeh no tu to nawet już szkoda gadać - na prawdę MUSISZ dokładnie obejrzeć te poradniki wideo ;)

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 4 sty 2017, o 13:14 
Offline
Użytkownik

Dołączył(a): 18 cze 2015
Posty: 105
Pomógł: 0

Tak Mirku.
Spokojnie, cierpliwości :D . Oglądałem wiele Twoich poradników i o uśrednianiu także. Jak wyżej pisałem, to przy preskalerze 32 i
128 jest super. Zero migotania, a jedynie przy 64 jest nie ciekawie, pomimo że jak sądzę-jest to prawidłowe ustawienie dla rezonatora 8Mhz.
Z mojego toku rozumowania wynikało, że skoro przy 32 i 128 jest git, to przyczyna nie leży np. w złym zasilaniu, ponieważ gdyby napięcie
vcc faktycznie mocno pływało, to żaden preskaler nie pomoże, ale być może się mylę . Druga sprawa. że często jestem drobiazgowy i bardzo uparty i jak się czepię jakiegoś szczegółu, to drążę i .....Ale nic. Dzisiaj podłączę solidne i stabilne zasilanie zewnętrzne i zobaczę, jaki będzie efekt. Wiem, że odpowiadasz na setki postów i inni nazwijmy to koledzy z forum i trzeba mieć anielską cierpliwość.

Ps.

Przy okazji, myślałem, że najpierw doprowadzę pomiary do właściwego stanu bez jakichkolwiek ulepszeń, a jak już wszystko będzie git, to
dopiero dopiszę małe uśrednianie, jako kropkę nad i. Ale wystarczy na ten temat. Nie ma co zamęczać w kółko forumowiczów tym tematem.
Można tak w nieskończoność hi, a jest jeszcze tyle ciekawego.

Pozdrawiam.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 4 sty 2017, o 13:21 
Offline
Użytkownik

Dołączył(a): 10 lip 2015
Posty: 291
Pomógł: 26

Bo ustawiasz nie 64, a 8. Powinieneś ustawić ADPS2 i ADPS1.


Autor postu otrzymał pochwałę


Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 4 sty 2017, o 14:48 
Offline
Użytkownik

Dołączył(a): 18 cze 2015
Posty: 105
Pomógł: 0

Dziękuję Homochemicus

Tylko wziąć i palnąć w ten pusty łeb (mnie oczywiście), ale wstrzymam się z tym do powrotu do domu i sprawdzę. Miałem notę katalogową
przed nosem (posty wyżej), ale nie popatrzyłem na wszystko. Pisałem trochę z książki i ciekaw jestem, czy się pomyliłem. Tak czy inaczej
powinienem się sugerować przede wszystkim notą pdf Atmegi. Lekcja na przyszłość. Sorry za zaprzątanie wszystkim głowy przez taką głupotę.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 4 sty 2017, o 19:44 
Offline
Użytkownik

Dołączył(a): 18 cze 2015
Posty: 105
Pomógł: 0

Jeszcze raz dzięki HomoChemicus za pokazanie błędu.

Po prawidłowym wpisaniu odnośnie preskalera teraz i na 64 wszystko działa prawidłowo. W książce wkradł się mały chochlik, a ja bezmyślnie przepisałem i do
głowy mi nie przyszło, że jest źle. Nie mam o to pretensji do autora, ponieważ takie rzeczy się zdarzają, a nota pdf powinna być na pierwszym miejscu.
Zresztą dzisiaj stałem się szczęśliwym posiadaczem GreenBuka, także kolekcja się powiększa. Pewnie to zdecydowanie za szybko, ale od przybytku głowa nie boli :) .



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 4 sty 2017, o 20:58 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 20994
Lokalizacja: Szczecin
Pomógł: 765

Robert_1967 napisał(a):
W książce wkradł się mały chochlik

Jeśli piszesz takie rzeczy to proszę uprzejmie bądź łaskaw powołać się na konkretne miejsce, kod w książce a nie pisać, że wkradł się jakiś chochlik - bo równie dobrze ty mogłeś coś źle zrozumieć a piszesz że błąd w książce - ok?

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 4 sty 2017, o 22:27 
Offline
Użytkownik

Dołączył(a): 18 cze 2015
Posty: 105
Pomógł: 0

Witam Mirku.

Jeśli istotnie zawiniłem i napisałem coś bez głębszego zastanowienia, to w tym miejscu bardzo przepraszam przy wszystkich. Natomiast proszę przejrzyj fotki.

Obrazek

strona 252

Obrazek


nota pdf. atmega32



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 5 sty 2017, o 00:50 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 20994
Lokalizacja: Szczecin
Pomógł: 765

Teraz wiem o co tobie chodziło ale to nie jest ŻADEN chochlik i pomimo, że nie ty pierwszy o tym piszesz i że od samego początku książki o tym wiem i poprawione zostało wiele różnych zgłaszanych błędów - to akurat tego i jeszcze kilku innych nie poprawiam....

Dlaczego? Ano właśnie dlatego, że bardzo wyraźnie piszę w książce i to wielokrotnie - nota PDF a nie przepisywanie z książki i tylko pułapki które zastawiam na czytelnika albo na kursach naziemnych - pomagały dopiero w 100% się przekonać o tym, że nota PDF to podstawa ...

Akurat ten przypadek to nie jest świadoma pułapka jaką zastawiłem ;) pułapki świadome są w okolicach LCD ;) ... tu po prostu testowałem kod z kilkoma różnymi dzielnikami i na końcu zmieniłem a nie poprawiłem komentarza. Na bazie tego ilu czytelników się już na to, że tak powiem "nacięło" i dzięki temu teraz wiedzą o co chodzi z notą PDF - to dlatego to specjalnie zostawiam i zostanie tak w tej książce na zawsze ;)

Sam spójrz po sobie - ile ci to dało ;)

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 5 sty 2017, o 07:12 
Offline
Użytkownik

Dołączył(a): 18 cze 2015
Posty: 105
Pomógł: 0

Witaj Mirku.
Tak, jak piszesz.Wiele dobrego wyciągnąłem z tego tematu, a pomyłki się zdarzają w wielu publikacjach. Przy takiej ilości informacji przekazywanej nie trudno o to. Najważniejsze, że wszystko zakończyło się pomyślnie, a ja nie zostałem posądzony o pomówienie :)
Od dzisiaj wiem, że nota pdf, to podstawa i zresztą wielokrotnie o tym mówisz w poradnikach.
Najlepszego w Nowym Roku.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 27 ] 

Strefa czasowa: UTC + 1


Kto przegląda forum

Użytkownicy przeglądający ten dział: Bing [Bot] i 4 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
Sitemap
Technologię dostarcza phpBB® Forum Software © phpBB Group phpBB3.PL
phpBB SEO