Kanał - ATNEL tech-forum
Wszystkie działy
Najnowsze wątki



Teraz jest 13 gru 2017, o 12:14


Strefa czasowa: UTC + 1





Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 10 ] 
Autor Wiadomość
PostNapisane: 5 gru 2017, o 15:14 
Offline
Nowy

Dołączył(a): 24 wrz 2016
Posty: 9
Pomógł: 0

Zacząłem testowac sobie komponent MkUsbDetector 1.6 i zauważyłem dziwne zachowanie, z poczatku myśłałem że robię coś źle, ale okazuje się że na programie demo zachowanie jest identyczne. A mianowicie zdarzenie MkUsbDetectorComDetect nie wykrywa mi portu COM. Dzieje się tak z wirtualnym portem COM Atmel Communication Device Class ASF http://asf.atmel.com/docs/latest/common.services.usb.class.cdc.device.example.sam3u_ek/html/index.html którego używam w jednym z projektów.
Dodam tylko że zdarzenie MkUsbDetectorUsbDetect bez problemu wykrywa podłaczenie urzadzenia:

podłączono urządzenie USB: VID_03EB && PID_2404 id: 5&19f4c0d2&0&6
odłączono USB: VID_03EB && PID_2404 id: 5&19f4c0d2&0&6

wywołanie MkUsbDetector.GetAvailableComPorts() poprawnie zwraca port:

COM43 \Device\USBSER000 (może to własnie dlatego że nie jest automatycznie rozpoznawany jako virtualny com? bo przy ftdi mam opis: "Virtual com port")

Proszę o informację czy komuś również pojawił się taki problem?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 5 gru 2017, o 18:19 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 22060
Lokalizacja: Szczecin
Pomógł: 805

Pokaż może zrzuty ekranu jak to się wykrywa - co pokazuje w jednym i drugim przypadku

------------------------ [ Dodano po: 10 minutach ]

przy okazji może sprawdzić jak się zachowa ten program z załącznika? tak samo czy coś się zmieni ?


Załączniki:

Aby zobaczyć załączniki musisz się zalogować. Tylko zalogowani użytkownicy mogą oglądać i pobierać załączniki.

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 5 gru 2017, o 18:32 
Offline
Nowy

Dołączył(a): 24 wrz 2016
Posty: 9
Pomógł: 0

Proszę, opisy na zrzutach:
ObrazekObrazek

Wersja z załącznika zachowuje się tak samo



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 5 gru 2017, o 18:48 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 22060
Lokalizacja: Szczecin
Pomógł: 805

a teraz sprawdź z załącznika


Załączniki:

Aby zobaczyć załączniki musisz się zalogować. Tylko zalogowani użytkownicy mogą oglądać i pobierać załączniki.

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 5 gru 2017, o 18:58 
Offline
Nowy

Dołączył(a): 24 wrz 2016
Posty: 9
Pomógł: 0

bez zmian...



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 5 gru 2017, o 19:01 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 22060
Lokalizacja: Szczecin
Pomógł: 805

poczekaj - czyli w końcu jak to jest ?

Tylko gdy ręcznie wydasz polecenie sprawdzenia portów COM to nie wykrywa się ten port ? a w trakcie fizycznego podłączania się pojawia ?

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 5 gru 2017, o 19:15 
Offline
Użytkownik

Dołączył(a): 14 sie 2016
Posty: 459
Pomógł: 17

Mirku, ze screenów wynika że w obu przypadkach port się wykrywa, tylko go nie wrzuca do ComboBoxa.

_________________
Moje porady są błędne,nie czytać,zbanować od razu.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 5 gru 2017, o 19:16 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 22060
Lokalizacja: Szczecin
Pomógł: 805

Harry napisał(a):
Mirku, ze screenów wynika że w obu przypadkach port się wykrywa, tylko go nie wrzuca do ComboBoxa.

No to właśnie się nie wykrywa w jednym z ważniejszych zdarzeń i o to dopytuję

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 5 gru 2017, o 19:46 
Offline
Nowy

Dołączył(a): 24 wrz 2016
Posty: 9
Pomógł: 0

Podczas gdy ręcznie wymuszam wykrycie, przyciskiem "Get All Comports EX" to jest wykrywany, w memo widać wpisy. Gdy robimy w comboxie dropDown też jest OK. Ale nie mam automatycznego wykrywania portu com, jak to jest np. w przypadku konwertera na FTDI:
_______________________________________________________________________________________________
podłączono urządzenie USB: VID_0403 && PID_6001 id: 6&32a5dfec&0&1
pojawił się port: COM8
------- new Com port Info -----------
COM8
USB Serial Port
VID_0403 & PID_6001
6&32a5dfec&0&1
FTDI
FT232R
zniknął port: COM8
odłączono USB: VID_0403 && PID_6001 id: 6&32a5dfec&0&1
_______________________________________________________________________________________________


Obrazek



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 5 gru 2017, o 21:27 
Offline
Moderator
Avatar użytkownika

Dołączył(a): 03 paź 2011
Posty: 22060
Lokalizacja: Szczecin
Pomógł: 805

ok rozumiem - ale to musiałbyś mnie złapać któregoś razu jak będę dostępny na skype online i może przez teamviewer udałoby się coś wybadać zdalnie

_________________
zapraszam na blog: http://www.mirekk36.blogspot.com (mój nick Skype: mirekk36 ) [ obejrzyj Kurs EAGLE ] [ mój kanał YT TV www.youtube.com/mirekk36 ]



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 10 ] 

Strefa czasowa: UTC + 1


Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 0 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
Sitemap
Technologię dostarcza phpBB® Forum Software © phpBB Group phpBB3.PL
phpBB SEO