Kanał - ATNEL tech-forum
Wszystkie działy
Najnowsze wątki



Teraz jest 17 gru 2017, o 14:55


Strefa czasowa: UTC + 1





Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 8 ] 
Autor Wiadomość
PostNapisane: 11 paź 2017, o 20:30 
Offline
Nowy

Dołączył(a): 11 paź 2017
Posty: 3
Pomógł: 0

Witam Wszystkich,
Zmagam się z problemem wyrównania potencjałów wszystkich mas kilku układów zasilanych z różnych źródeł. Ktoś powie "poszukaj już było" lub skieruje mnie na film z objaśnieniem Pana Mirka ( już go widziałem ;) ).
Problem zaczyna się w momencie połączenia mas dwóch z trzech źródeł, nadmienię że jeden z układów pracuje ze "sztucznym zerem". Układy dobrze pracują GND1+GND2 , GND3, dołączając układ poprzez SN75176BD rs485 i przewodami wyrównując GND uszkadza mi się nadajnik-odbiornik linii. Pytanie mam następujące czy jest konieczna wspólna masa ? Co mogę robić nie tak ? Proszę o pomoc.

Obrazek



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 11 paź 2017, o 21:44 
Offline
Użytkownik

Dołączył(a): 05 wrz 2017
Posty: 33
Pomógł: 5

Witaj.
W przeszłości miałem podobny problem, większość urządzeń pracujących w standardzie RS232/485 dopuszcza różnicę potencjałów odniesienia na poziomie max 7V (przynajmniej do takich wniosków doszedłem). Jeśli masz "pływającą masę" dobrym rozwiązaniem jest izolacja galwaniczna, można to zrobić w dwojaki sposób albo transoptory na linię dodać (zajmują więcej miejsca ale wychodzi taniej) albo wykorzystać scalony układ Analog Devices ADM2483 (koszt 15-50 pln zależy od wersji jeden scalak + 2 kondensatory odsprzęgające).
Ja dodałem jedno małe trafo (nie pamiętam dokładnie ale chyba coś w okolicach 1-2VA) i z niego zasilałem stronę wtórną wszystkich układów, obie wersje działały poprawnie, przy większych odległościach (powyżej 10m) kluczowa była impedancja przewodów i terminatory właściwe.
Pamiętaj żeby połączyć ekrany wszystkich przewodów z jednym potencjałem odniesienia - o ile stosujesz przewód ekranowany.

Edit.
Jeśli coś nie jasno napisałem to jutro wieczorem postaram się wrzucić jakiś kawałek schematu.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 11 paź 2017, o 22:45 
Offline
Nowy

Dołączył(a): 24 gru 2012
Posty: 10
Pomógł: 1

stealthman napisał(a):
Zmagam się z problemem wyrównania potencjałów wszystkich mas kilku układów zasilanych z różnych źródeł.


Ekran przewodów sygnałowych nie służy do wyrównania potencjałów, takie podłączenie jest nieodpowiednie. Powinieneś zastosować odrębny przewód wyrównujący potencjały lub gorsze rozwiązanie ekran podłączony tylko z jednej strony, do jednego urządzenia. Pozdrawiam Janek



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 12 paź 2017, o 08:55 
Offline
Nowy

Dołączył(a): 18 lis 2014
Posty: 20
Pomógł: 2

Ten pierwszy prostownik od góry jest podłączony bezpośrednio do sieci 230V ?
Gdzie dokładnie jest podłączony jego minus ?
Cały ten układ jest w jednym budynku zasilanym jednym przyłączem z sieci energetycznej ?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 12 paź 2017, o 09:02 
Offline
Nowy

Dołączył(a): 11 paź 2017
Posty: 3
Pomógł: 0

Mostek podłączony jest bezpośrednio pod sieć 250V AC. Minus, plus i "zero" idzie na IGBT.

Obecnie dalej walczę z GND i zwierając masę tych płytek zauważyłem że gdy nie dodam rezystorów podciągających linię A,B wtedy układ jakiś czas pracuje. Następuje przebicie w układzie SN i w konsekwencji prowadzi do uszkodzenia linii komunikacyjnej RS485.

Zrobiłem to co sugerował kolega SIM tylko wtedy w podłączanym układzie spada napięcie, ale nic się nie uszkadza :o

Panowie a czy to nie jest tak, że moja "masa" pracująca ze sztucznym czy jak wolicie z pływającym zerem to nie jest potencjał "zero" 0, tylko -160 V DC ???

Jest dokładnie tak jak opisałem moja masa w układzie z sztucznym zerem jest to -160 V , czyli istnieje jedynie opcja galwanicznej izolacji. Teraz pytanie do kolegi
ABEL11 czy zamiast układu ADM2483 mogę zastosować ADUM1201 na samej już linii RS485 "A","B". ???



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 12 paź 2017, o 20:54 
Offline
Użytkownik

Dołączył(a): 05 wrz 2017
Posty: 33
Pomógł: 5

Podpisuje się obiema rękoma pod tym co napisał kolega sim, ekran powinien być podłączony do napięcia odniesienia tylko w JEDNYM miejscu, prąd nim ma nie płynąć - no chyba, że nie ma działać jako ekran. Natomiast sprowadzanie potencjałów przy pływającej masie to z mojego doświadczenia ciężki temat, nie wart wysiłku jeśli da się zastosować izolacje.

Odnośnie układu ADUM1201 o który pytał kolega stealthman.
Nie stosowałem tego rozwiązania w praktyce, ale producent jasno napisał w nocie, że układ nadaje się do "RS-232/RS-422/RS-485 transceiver isolation". Wynika z tego, że powinien spełnić Twoje oczekiwania w dodatku przy niskim baudrate pobiera mniejszy prąd od ADM2483. To, że w jednym układzie zastosowano parę optoelektroniczną, a w drugim transformatory nie powinno mieć znaczenia dla poprawnego działania.
W dodatku AnalogDevices wypuściło kilka not aplikacyjnych dotyczących iCoupler Isolation, np:
http://www.analog.com/media/en/technica ... _825_0.pdf
http://www.analog.com/media/en/technica ... AN-793.pdf
http://www.analog.com/media/en/technica ... AN-727.pdf << ta dotyczy RS485

Pamiętaj o poprawnym podłączeniu ekranów, najlepiej wykorzystać przewody dedykowane pod RS485 z ekranem, nie zapomnij też o miejscu na rezystory "terminujące", w całej linii powinny być przy pierwszym i przy ostatnim urządzeniu.

Tak to wyglądało u mnie z ADM2483.
Obrazek
Tranzystor Q3 pozwala na korzystanie z sprzętowego flow controll UART - nie mogłem zanegować tego programowo ponieważ czas na przesyłanie danych był bardzo ograniczony. Względnie duże pojemności ułatwiają sprawę przy długich przewodach > 25m.

Ponieważ pisałeś o IGBT: Wiele bałaganu generują przy wyłączaniu więc koniecznie dobrze wylicz sobie gasiki bo inaczej dzwonienie skutecznie rozmontuje komunikacje. Kolejną sprawą będzie wybranie baudrate przy którym częstotliwość przełączania tranzystorów będzie możliwie daleka od częstotliwości z jaką przesyłasz dane (o ekranie nie będę powtarzał).

edit : poprawiłem link do noty aplikacyjnej



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 12 paź 2017, o 21:51 
Offline
Nowy

Dołączył(a): 18 lis 2014
Posty: 20
Pomógł: 2

Jeśli podłączasz to prawidłowo do sieci zasilającej tzn: L,N i PE, to mostek powinien odparować.
Jak już zauważyłeś masz na masie (tej na górze) -160V i łączysz to z innym układem który wg. schematu ma masę podłączoną do PE. Różnica potencjałów, prądy wyrównawcze i kłopot gotowy. Izolacja galwaniczna pewnie pomoże tylko myślę, że to tylko leczenie objawów bo przyczyna pozostanie.

Proponuję jeszcze raz przemyśleć połączenia mas i przewodów ochronnych, dla własnego bezpieczeństwa.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 17 paź 2017, o 08:59 
Offline
Nowy

Dołączył(a): 11 paź 2017
Posty: 3
Pomógł: 0

Witam,
Panowie w dniu dzisiejszym przyjdzie mi izolator cyfrowy ADUM1200 po podłączeniu opiszę czy wszystko działa poprawnie. W nocie katalogowej izolator ten zalecany jest do PROFIBUS i rs485. Powinno działać :?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 8 ] 

Strefa czasowa: UTC + 1


Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 0 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
Sitemap
Technologię dostarcza phpBB® Forum Software © phpBB Group phpBB3.PL
phpBB SEO