Kanał - ATNEL tech-forum
Wszystkie działy
Najnowsze wątki



Teraz jest 26 cze 2017, o 23:32


Strefa czasowa: UTC + 1





Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 57 ]  Przejdź na stronę 1, 2  Następna strona
Autor Wiadomość
PostNapisane: 12 kwi 2017, o 20:49 
Offline
Użytkownik

Dołączył(a): 08 cze 2016
Posty: 100
Lokalizacja: Katowice
Pomógł: 0

Mam problem z kodem program który ma sterować pompom i pokazywać poziom wody w studni zapalając diody led założenia są takie:
Sonda na dnie zbiornika (GND)
Sonda4 poziom wody niski pompa wyłączona
Sonda3 poziom wody średni pompa zaczyna prace
Sonda2 poziom następny pompa pracuje
Sonda1 poziom wysoki pompa pracuje
przy pierwszym napisanym kodzie wszystko działa zgodnie z założeniem tylko brakowało mi regulacji czasu , opóźnienia sygnału z sondy do włączania – wyłączania pompy i kontrolek led .
Podczas testowania na płytce okazało się że diody zaczęły mrugać naprzemiennie w kolejności zanurzenia a pompa włącza się i wyłącza po prostu istna dyskoteka proszę o podpowieć.
Pierwszy kod bez opóźnień delay ms
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.

Drugi kod z dyskoteką
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.


Pozdrawiam



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 12 kwi 2017, o 20:54 
Offline
Tech-support
Avatar użytkownika

Dołączył(a): 01 lis 2015
Posty: 1073
Lokalizacja: okolice Warszawa
Pomógł: 98

linijka 51, pompa off przenieś do else. :) (czyli wyłączy jeżeli sonda się odkryje a nie zanurzy )

------------------------ [ Dodano po: 10 minutach ]

Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.


a i jeszcze tu coś nie tego... ;)
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.

czy nie powinno być ?
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 12 kwi 2017, o 21:29 
Offline
Użytkownik

Dołączył(a): 08 cze 2016
Posty: 100
Lokalizacja: Katowice
Pomógł: 0

Nic to nie dało problem w tym że diody zamiast świeci jednostajnie zapalają się i gasną to samo z pampą w pierwszej wersji bez delay definicji funkcji Sondy wszystko działa poprawnie tylko w pierwszym kodzie brakowało mi opóźnień więc je dodałem tylko gdzieś popełniłem błąd.
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.

Obrazek
POZ.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 12 kwi 2017, o 22:52 
Offline
Tech-support
Avatar użytkownika

Dołączył(a): 01 lis 2015
Posty: 1073
Lokalizacja: okolice Warszawa
Pomógł: 98

Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 12 kwi 2017, o 23:42 
Offline
Użytkownik

Dołączył(a): 08 cze 2016
Posty: 100
Lokalizacja: Katowice
Pomógł: 0

Daro69 widzę żeś się trochę napracował twoja sugestia że jak sonda się wynurzy pompa zostanie wyłączona jest dobrym pomysłem ale problem polega na tym że brakowało mi bocji która eliminowała by moment całkowitego wynurzenie sondy można by powiedzieć tak zwane drganie styków tylko w dłuższym czasie moment całkowitego wynurzenia sondy kod który napisałem działa źle załącza led1 potem załącza led2 wyłącza led1 itd. czyli robi się dyskoteka.
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.

Poz.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 12 kwi 2017, o 23:55 
Offline
Tech-support
Avatar użytkownika

Dołączył(a): 01 lis 2015
Posty: 1073
Lokalizacja: okolice Warszawa
Pomógł: 98

Daro68 napisał(a):
załącza led1 potem załącza led2 wyłącza led1 itd. czyli robi się dyskoteka.

przypomnę o :
Daro68 napisał(a):
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.

załączając led_1 , kasujesz pozostałe ledy wystawiając stan wysoki na wszystkie pozostałe piny.
wpisz tak:
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.

załącz stan niski tylko na wskazanych.

------------------------ [ Dodano po: 22 minutach ]

mała zmiana w załączaniu i wyłączaniu.
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.


----albo tak w oparciu o Twój kod .-------------------- [ Dodano po: 35 minutach ]

Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 13 kwi 2017, o 09:11 
Offline
Nowy

Dołączył(a): 09 gru 2016
Posty: 13
Pomógł: 2

Ja mam pytanie trochę z innej branży, czy mówimy tu o studni do poboru wody z ziemi, czy to jest jakaś studzienka do zbierania wody np. opadowej?



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 13 kwi 2017, o 09:42 
Offline
Tech-support
Avatar użytkownika

Dołączył(a): 01 lis 2015
Posty: 1073
Lokalizacja: okolice Warszawa
Pomógł: 98

Z tego co skojarzyłem z kodu kolegi,
To raczej zbiornik w ktorym zbiera się woda
i trzeba pilnować by się nie przepełniło. + wskazania poziomu na diodach.
Hmm.. ale może faktycznie źle odczytałem intencję.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 13 kwi 2017, o 16:55 
Offline
Użytkownik

Dołączył(a): 08 cze 2016
Posty: 100
Lokalizacja: Katowice
Pomógł: 0

Sondy mają mierzyć poziom wody w studni włączać i wyłączać pompę przy zadanym poziomie
Obrazek
Poz.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 14 kwi 2017, o 23:58 
Offline
Użytkownik

Dołączył(a): 08 cze 2016
Posty: 100
Lokalizacja: Katowice
Pomógł: 0

Teraz mam inny problem po resecie diody 1,2,3 są włączone a chcę żeby były wyłączone proszę o pomoc.
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.

Poz.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 15 kwi 2017, o 09:11 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 11 sty 2013
Posty: 1763
Pomógł: 194

Witam
Daro68 napisał(a):
... po resecie diody 1,2,3 są włączone a chcę żeby były wyłączone

Więc napisz:
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.


Pozdr.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 15 kwi 2017, o 11:05 
Offline
Użytkownik

Dołączył(a): 08 cze 2016
Posty: 100
Lokalizacja: Katowice
Pomógł: 0

Właśnie w tym problem po kompilacji wywala mi błąd
Obrazek
Poz.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 15 kwi 2017, o 11:37 
Offline
Tech-support
Avatar użytkownika

Dołączył(a): 01 lis 2015
Posty: 1073
Lokalizacja: okolice Warszawa
Pomógł: 98

ajć, bo przyjrzyj się co to jest LED4_OFF "PORTC |=(1<<PC5)"
wystarczy:
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.

pozdrawiam.

------------------------ [ Dodano po: 10 minutach ]

aha ... i jeszcze nie jasny dla mnie zapis
Daro68 napisał(a):
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.


------------------------ [ Dodano po: 33 minutach ]

Daro68 napisał(a):

Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.

może zmień na
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 15 kwi 2017, o 12:30 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 11 sty 2013
Posty: 1763
Pomógł: 194

Witam
Daro68 napisał(a):
Właśnie w tym problem po kompilacji wywala mi błąd

Ja tylko podałem sposób jak wygasić ale staranność zapisów leży już po Twojej stronie.
Kol.Daro69 w pocie czoła poprawia co może, ale zwróć uwagę na liczbę Twoich "literówek"
Kompilator albo to przepuści ale program "się inaczej wykona", albo zawarczy że "tak nie będzie"
Np.:Obrazek

Pozdr.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 15 kwi 2017, o 13:01 
Offline
Użytkownik

Dołączył(a): 08 cze 2016
Posty: 100
Lokalizacja: Katowice
Pomógł: 0

Poprawiłem kod wszystko działa ale teraz chciałbym dołączyć jeszcze jedną funkcję obsługi przycisku którą można by sterować włączanie wyłączanie pompy przy każdej sondzie:
SONDA1- przycisk – pompa_on lub pompa_off
SONDA2- przycisk – pompa_on lub pompa_off
SONDA3- przycisk – pompa_on lub pompa_off
SONDA4- przycisk – pompa_on lub pompa_off
spróbuje coś sensownego napisać.
Poprawiony kod
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.

Poz.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 15 kwi 2017, o 13:14 
Offline
Tech-support
Avatar użytkownika

Dołączył(a): 01 lis 2015
Posty: 1073
Lokalizacja: okolice Warszawa
Pomógł: 98

Daro68 napisał(a):
chciałbym dołączyć jeszcze jedną funkcję obsługi przycisku którą można by sterować włączanie wyłączanie pompy przy każdej sondzie:

to może w tym kierunku:
przyciskiem zmieniasz priorytet.
1) MANUAL_POMPA_OFF
2) AUTO_POMPA
3) MANUAL_POMPA_ON\

klawiszem wybierasz jedną z trzech a w pętli 'while' sprawdzasz która jest.
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.

może jakoś w tę stronę.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 15 kwi 2017, o 13:54 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 11 sty 2013
Posty: 1763
Pomógł: 194

Witam
Ja robiłem coś podobnego, z tym że wskaźnikiem była rurka "wypełniona" stykami kontaktronu - każdy z nich zwierał inną liczbę diod a pomiar następował na ADC. Po tym poruszał się pływak z magnesem. Niestety nie zachował się schemat.
Jeśli miałoby się do czegoś przydać to dołączam kod ( ATm8, 8MHz - wew).
Chodzi o te warunki wł/wył ręczne pompy; u mnie było tak że wł/wył następowało na zasadzie TOG z tym że dla poziom_min nie można ręcznie włączyć pompy, dla poziom_max nie można jej ręcznie wyłączyć ( no chyba że przegryźć druty :) ).
Dodatkowo jest sprawdzenie "antysabotażowe" - czy nie ma przerwy lub zwarcia linii.

Pozdr.

P.S
Folder LCD z wiadomych przyczyn ( BB ) jest pusty - służył tylko do kalibracji; stan wody wskazywały dwie podwójne diody RG.


Załączniki:

Aby zobaczyć załączniki musisz się zalogować. Tylko zalogowani użytkownicy mogą oglądać i pobierać załączniki.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 15 kwi 2017, o 19:08 
Offline
Użytkownik

Dołączył(a): 08 cze 2016
Posty: 100
Lokalizacja: Katowice
Pomógł: 0

Daro69 napisał(a):
1) MANUAL_POMPA_OFF
2) AUTO_POMPA
3) MANUAL_POMPA_ON\


Nie bardzo rozumie przy moim stanie wiedzy proszę o kolejne koło ratunkowe ja zamierzałem zrobić cztery przyciski na każdy stopień sondy przyciskiem włączało by się pompę lub wysączało pompę na danej sondzie do tego jeszcze dioda led sygnalizująca czy pompa na danym stopniu sondy jest zaprogramowana na włączenie czy wyłączenie.

Poz.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 15 kwi 2017, o 19:32 
Offline
Tech-support
Avatar użytkownika

Dołączył(a): 01 lis 2015
Posty: 1073
Lokalizacja: okolice Warszawa
Pomógł: 98

Daro68 napisał(a):
zamierzałem zrobić cztery przyciski na każdy stopień sondy przyciskiem włączało by się pompę lub wysączało pompę na danej sondzie do tego jeszcze dioda led sygnalizująca czy pompa na danym stopniu sondy jest zaprogramowana na włączenie czy wyłączenie.

Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.

i dalej w kodzie
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 15 kwi 2017, o 22:00 
Offline
Użytkownik

Dołączył(a): 08 cze 2016
Posty: 100
Lokalizacja: Katowice
Pomógł: 0

Dzięki za podpowiedź zabieram się do pisania kodu jak się z nim uporam poproszę o sprawdzenie.

Poz.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 16 kwi 2017, o 18:04 
Offline
Użytkownik

Dołączył(a): 08 cze 2016
Posty: 100
Lokalizacja: Katowice
Pomógł: 0

Przepraszam że umieszczam posty obok siebie ale potrzebowałem podłączyć do celów testowych klawisz pod VCC więc wyłączyłem podciągnięcie rezystorów programowych i skasowałem ‘!’ w obsłudze sondy, podciągnąłem VCC rezystorem 10k do masy ale program zaczął żyć własnym życiem i nie wiem gdzie popełniłem błąd proszę o pomoc.
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.

Poz.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 16 kwi 2017, o 18:27 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 11 sty 2013
Posty: 1763
Pomógł: 194

Witam
Daro68 napisał(a):
podciągnąłem VCC rezystorem 10k do masy

Mógłbyś rozwinąć/narysować?
Jeśli chcesz sprawdzić PINx bez "!" to kiedy
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.

będzie prawdą.

Pozdr.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 16 kwi 2017, o 20:07 
Offline
Użytkownik

Dołączył(a): 08 cze 2016
Posty: 100
Lokalizacja: Katowice
Pomógł: 0

Na razie chcą wyśrubować ale program bez aktywacji sond robi co chce ,testuje na stykówce ale chcą wypróbować w wodzie .
Obrazek



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 16 kwi 2017, o 22:25 
Offline
Tech-support
Avatar użytkownika

Dołączył(a): 01 lis 2015
Posty: 1073
Lokalizacja: okolice Warszawa
Pomógł: 98

Jezeli klawisze są podciągnięte do GND,
to należy sprawdzać czy po naciśnięciu mają stan wysoki,
ale i klawisze należy zwierać z VCC a nie GND.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 17 kwi 2017, o 00:05 
Offline
Użytkownik

Dołączył(a): 08 cze 2016
Posty: 100
Lokalizacja: Katowice
Pomógł: 0

Daro69 napisał(a):
Jezeli klawisze są podciągnięte do GND,
to należy sprawdzać czy po naciśnięciu mają stan wysoki,
ale i klawisze należy zwierać z VCC a nie GND.

Nie rozumie klawisz (sonda ) zwieram do VCC plus rezystor 10k do GND przy wciśnięciu klawisz (zanurzeniu sondy ) otrzymuje stan wysoki chyba że coś w kodzie złe pozmieniałem .



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 17 kwi 2017, o 00:08 
Offline
Tech-support
Avatar użytkownika

Dołączył(a): 01 lis 2015
Posty: 1073
Lokalizacja: okolice Warszawa
Pomógł: 98

doczytałem że tak robisz, :)
jeżeli kod nie działa to wygląda na to że coś niewłaściwie podłączone.

------------------------ [ Dodano po: 19 minutach ]

Daro68 napisał(a):
chcą wypróbować w wodzie
może daj większe wartości rezystorów (słabsze ściąganie do GND), woda zbyt czysta słabo przewodzi,
tu powstanie dzielnik napięcia(woda pomiędzy sondą a "+5V" to rezystancja ).



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 17 kwi 2017, o 17:38 
Offline
Użytkownik

Dołączył(a): 08 cze 2016
Posty: 100
Lokalizacja: Katowice
Pomógł: 0

Zmieniłem rezystor z 10k na 47k i wszystko zadziałało testy przeprowadziłem w szklance wody wiem ze to nie studnia ale do testowania kodu wystarczy tylko pojawił się kolejny problem na przykład gdy wystąpi brak zasilania to przy ponownym uruchomieniu zapala się tylko jedna dioda led wskazująca najwyższy stan poziomu wody pozostałe diody led zanurzonych sond nie świecą dopiero po ręcznym odłączeniu i ponownym włączeniu diody poniżej zanurzonych sond zapalają się jak sprawić żeby program po resecie zapalił wszystkie diody led zanurzonych sond

Przykład po przywróceniu zasilania :
sonda1- led1- zapalona
sonda2- led2- wyłączona
sonda3- led3- wyłączona
sonda4- led4- wyłączona

Przykład po przywróceniu zasilania i ręcznym wyłączeniu i włączeniu sond:
sonda1- led1- zapalona
sonda2- led2- zapalona
sonda3- led3- zapalona
sonda4- led4- zapalona

Poz.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 17 kwi 2017, o 18:45 
Offline
Użytkownik
Avatar użytkownika

Dołączył(a): 31 mar 2015
Posty: 195
Pomógł: 13

Pytasz, jak zapamiętać ostatni stan diod? Odpowiedź jest w poradniku o strukturach. A dokładnie w projekcie P. Mirka EEMEM_STRUCT - dostępny na blogu.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 17 kwi 2017, o 20:10 
Offline
Tech-support
Avatar użytkownika

Dołączył(a): 01 lis 2015
Posty: 1073
Lokalizacja: okolice Warszawa
Pomógł: 98

to daj wszystkie ledy w ifie sond.
jeżeli sonda1 {led1_ON; led2_ON;led3_ON;led4_ON;}
jeżeli sonda2 {led1_OFF;led2_ON;led3_ON;led4_ON;}
jeżeli sonda3 {led1_OFF;led2_OFF;led3_ON;led4_ON;}
jeżeli sonda4 {led1_OFF;led2_OFF;led3_OFF;led4_ON;}
zawsze będzie zapalało pozostałe diody. :)

------------------------ [ Dodano po: 18 minutach ]

jeżeli korzystasz nadal z tego kodu to jakoś tak:
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
PostNapisane: 20 kwi 2017, o 21:31 
Offline
Użytkownik

Dołączył(a): 08 cze 2016
Posty: 100
Lokalizacja: Katowice
Pomógł: 0

Próbuje zmodyfikować kod i dołożyć kolejne funkcje czyli dodatkowy klawisz i kontrolkę led Daro69 podesłał podpowiedzi ja starałem się rozwiązać podobnie problem na razie na pierwszej sondzie ale coś nie wyszło założenia są takie :
SONDA1- przycisk naciśnięcie – pompa_on (led_on) kolejne naciśnięcie -pompa_off(led_off) 
SONDA2- przycisk naciśnięcie – pompa_on (led_on) kolejne naciśnięcie -pompa_off(led_off) 
SONDA3- przycisk naciśnięcie – pompa_on (led_on) kolejne naciśnięcie -pompa_off(led_off) 
SONDA4- przycisk naciśnięcie – pompa_on (led_on) kolejne naciśnięcie -pompa_off(led_off) 
na razie klawisz nie reaguje a dioda sygnalizująca włą.-wył,pompy po odebraniu sygnału z sondy świeci cały czsa.
Składnia: [ Pobierz ] [ Ukryj ]
język c
Musisz się zalogować, aby zobaczyć kod źródłowy. Tylko zalogowani użytkownicy mogą widzieć kod.

Poz.



Góra
 Zobacz profil  
cytowanie selektywne  Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 57 ]  Przejdź na stronę 1, 2  Następna strona

Strefa czasowa: UTC + 1


Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 0 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
Sitemap
Technologię dostarcza phpBB® Forum Software © phpBB Group phpBB3.PL
phpBB SEO